]> git.pld-linux.org Git - SPECS.git/blob - godep.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / godep.spec
1 Summary:        Dependency tool for go
2 Name:           godep
3 Version:        60
4 Release:        1
5 License:        BSD
6 Group:          Development/Building
7 Source0:        https://github.com/tools/godep/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  03194aeb9b4d22ea6201ef83163cda70
9 URL:            https://github.com/tools/godep
10 ExclusiveArch:  %{ix86} %{x8664} %{arm}
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 # go stuff
14 %define _enable_debug_packages 0
15 %define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
16 %define import_path github.com/tools/godep
17
18 %description
19 Dependency tool for go.
20
21 %prep
22 %setup -q
23
24 install -d src/github.com/tools
25 ln -s ../../../ src/github.com/tools/godep
26
27 %build
28 export GOPATH=$(pwd):$(pwd)/Godeps/_workspace
29 %gobuild -o bin/godep %{import_path}
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d -p $RPM_BUILD_ROOT%{_bindir}
34 install -p bin/godep $RPM_BUILD_ROOT%{_bindir}
35
36 %clean
37 rm -rf $RPM_BUILD_ROOT
38
39 %files
40 %defattr(644,root,root,755)
41 %doc Changelog.md Readme.md License
42 %attr(755,root,root) %{_bindir}/godep
This page took 0.638337 seconds and 3 git commands to generate.