]> git.pld-linux.org Git - packages/go-bindata.git/blob - go-bindata.spec
post 3.0.7 to add support for -nometadata
[packages/go-bindata.git] / go-bindata.spec
1 %define         commit  a0ff2567
2 %define         rel     1
3 Summary:        A small utility which generates Go code from any file
4 Name:           go-bindata
5 Version:        3.0.7
6 Release:        %{rel}.%{commit}
7 License:        MIT
8 Group:          Development/Tools
9 #Source0:       https://github.com/jteeuwen/go-bindata/archive/v%{version}/%{name}-%{version}.tar.gz
10 Source0:        https://github.com/jteeuwen/go-bindata/archive/%{commit}/%{name}-%{version}-%{commit}.tar.gz
11 # Source0-md5:  d630353abae8c73adf2ed2af3d0e74a0
12 URL:            http://github.com/jteeuwen/go-bindata
13 BuildRequires:  golang >= 1.3.3
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 # go stuff
17 %define _enable_debug_packages 0
18 %define gobuild(o:) go build -ldflags "${LDFLAGS:-} -B 0x$(head -c20 /dev/urandom|od -An -tx1|tr -d ' \\n')" -a -v -x %{?**};
19
20 %description
21 This tool converts any file into managable Go source code. Useful for
22 embedding binary data into a go program. The file data is optionally
23 gzip compressed before being converted to a raw byte slice.
24
25 %prep
26 %setup -qc
27 mv %{name}-*/* .
28
29 install -d _build/src/github.com/jteeuwen
30 ln -s $(pwd) _build/src/github.com/jteeuwen/go-bindata
31
32 %build
33 export GOPATH=$(pwd)/_build
34 cd go-bindata
35 %gobuild .
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_bindir}
40 install -p go-bindata/go-bindata $RPM_BUILD_ROOT%{_bindir}/go-bindata
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc LICENSE README.md
48 %attr(755,root,root) %{_bindir}/go-bindata
This page took 0.060048 seconds and 4 git commands to generate.