]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- up to 3.6.6
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
4 %bcond_without  openssl         # libgnutls-openssl compatibility library
5 %bcond_without  tpm             # TPM support in gnutls
6 %bcond_without  static_libs     # static libraries
7 %bcond_without  doc             # do not generate documentation
8 %bcond_without  guile
9 #
10 Summary:        The GNU Transport Layer Security Library
11 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
12 Name:           gnutls
13 Version:        3.6.6
14 Release:        1
15 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
16 Group:          Libraries
17 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.6/%{name}-%{version}.tar.xz
18 # Source0-md5:  30c5b63686edcd260d87d8fb8a06977f
19 Patch0:         %{name}-info.patch
20 Patch1:         %{name}-link.patch
21 URL:            http://www.gnutls.org/
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  autogen
24 BuildRequires:  autogen-devel
25 BuildRequires:  automake >= 1:1.12.2
26 BuildRequires:  gettext-tools >= 0.19
27 BuildRequires:  gmp-devel
28 %{?with_doc:BuildRequires:      gtk-doc >= 1.14}
29 %{?with_guile:BuildRequires:    guile-devel >= 5:2.2.0}
30 BuildRequires:  libidn2-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtasn1-devel >= 4.11
33 BuildRequires:  libunistring-devel
34 BuildRequires:  libtool >= 2:2
35 BuildRequires:  nettle-devel >= 3.3
36 # miniopencdk is included in sources and currently maintained
37 # as part of gnutls, not external package
38 #BuildRequires: opencdk-devel >= 0.6.6
39 BuildRequires:  p11-kit-devel >= 0.23.1
40 BuildRequires:  pkgconfig
41 BuildRequires:  readline-devel
42 BuildRequires:  rpmbuild(macros) >= 1.383
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 %{?with_doc:BuildRequires:      texinfo >= 4.8}
46 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
47 %{?with_dane:BuildRequires:     unbound-devel}
48 BuildRequires:  xz
49 BuildRequires:  zlib-devel
50 Requires:       %{name}-libs = %{version}-%{release}
51 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 GnuTLS is a project that aims to develop a library which provides a
56 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
57 the gnuTLS library implements the proposed standards by the IETF's TLS
58 working group.
59
60 %description -l pl.UTF-8
61 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
62 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
63 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
64 grupę roboczą IETF TLS.
65
66 %package libs
67 Summary:        GnuTLS shared libraries
68 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
69 Group:          Libraries
70 Requires:       libtasn1 >= 4.11
71 Requires:       nettle >= 3.3
72 #Requires:      opencdk >= 0.6.6
73 Requires:       p11-kit >= 0.23.1
74 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
75 Conflicts:      gnutls < 3.2.0
76
77 %description libs
78 GnuTLS shared libraries.
79
80 %description libs -l pl.UTF-8
81 Biblioteki współdzielone GnuTLS.
82
83 %package devel
84 Summary:        Header files etc to develop gnutls applications
85 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
86 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
87 Group:          Development/Libraries
88 Requires:       %{name}-libs = %{version}-%{release}
89 Requires:       libidn2-devel
90 Requires:       libtasn1-devel >= 4.11
91 Requires:       libunistring-devel
92 Requires:       nettle-devel >= 3.3
93 #Requires:      opencdk-devel >= 0.6.6
94 Requires:       p11-kit-devel >= 0.23.1
95 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
96 Requires:       zlib-devel
97
98 %description devel
99 Header files etc to develop gnutls applications.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe i inne do gnutls.
103
104 %package static
105 Summary:        Static gnutls library
106 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
107 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110
111 %description static
112 Static gnutls library.
113
114 %description static -l pl.UTF-8
115 Biblioteka statyczna gnutls.
116
117 %package c++
118 Summary:        libgnutlsxx - C++ interface to gnutls library
119 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
120 License:        LGPL v2.1+
121 Group:          Libraries
122 Requires:       %{name}-libs = %{version}-%{release}
123
124 %description c++
125 libgnutlsxx - C++ interface to gnutls library.
126
127 %description c++ -l pl.UTF-8
128 libgnutlsxx - interfejs C++ do biblioteki gnutls.
129
130 %package c++-devel
131 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
132 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
133 License:        LGPL v2.1+
134 Group:          Development/Libraries
135 Requires:       %{name}-c++ = %{version}-%{release}
136 Requires:       %{name}-devel = %{version}-%{release}
137 Requires:       libstdc++-devel
138
139 %description c++-devel
140 Header files for libgnutlsxx, a C++ interface to gnutls library.
141
142 %description c++-devel -l pl.UTF-8
143 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
144
145 %package c++-static
146 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
147 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
148 License:        LGPL v2.1+
149 Group:          Development/Libraries
150 Requires:       %{name}-c++-devel = %{version}-%{release}
151
152 %description c++-static
153 Static version of libgnutlsxx, a C++ interface to gnutls library.
154
155 %description c++-static -l pl.UTF-8
156 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
157
158 %package dane
159 Summary:        DANE security library
160 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
161 Group:          Libraries
162 Requires:       %{name}-libs = %{version}-%{release}
163
164 %description dane
165 DANE security library.
166
167 %description dane -l pl.UTF-8
168 Biblioteka bezpieczeństwa DANE.
169
170 %package dane-devel
171 Summary:        Header file for DANE security library
172 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
173 Group:          Development/Libraries
174 Requires:       %{name}-dane = %{version}-%{release}
175 Requires:       %{name}-devel = %{version}-%{release}
176 Requires:       unbound-devel
177
178 %description dane-devel
179 Header file for DANE security library.
180
181 %description dane-devel -l pl.UTF-8
182 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
183
184 %package dane-static
185 Summary:        Static DANE security library
186 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
187 Group:          Development/Libraries
188 Requires:       %{name}-dane-devel = %{version}-%{release}
189
190 %description dane-static
191 Static DANE security library.
192
193 %description dane-static -l pl.UTF-8
194 Statyczna biblioteka bezpieczeństwa DANE.
195
196 %package openssl
197 Summary:        OpenSSL compatibility library for GnuTLS
198 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
199 Group:          Libraries
200 Requires:       %{name}-libs = %{version}-%{release}
201
202 %description openssl
203 OpenSSL compatibility library for GnuTLS.
204
205 %description openssl -l pl.UTF-8
206 Biblioteka zgodności z OpenSSL dla GnuTLS.
207
208 %package openssl-devel
209 Summary:        Header file for gnutls-openssl library
210 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
211 Group:          Development/Libraries
212 Requires:       %{name}-devel = %{version}-%{release}
213 Requires:       %{name}-openssl = %{version}-%{release}
214
215 %description openssl-devel
216 Header file for gnutls-openssl library.
217
218 %description openssl-devel -l pl.UTF-8
219 Plik nagłówkowy biblioteki gnutls-openssl.
220
221 %package openssl-static
222 Summary:        Static gnutls-openssl library
223 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
224 Group:          Development/Libraries
225 Requires:       %{name}-openssl-devel = %{version}-%{release}
226
227 %description openssl-static
228 Static gnutls-openssl library.
229
230 %description openssl-static -l pl.UTF-8
231 Statyczna biblioteka gnutls-openssl.
232
233 %package -n guile-gnutls
234 Summary:        Guile bindings for GnuTLS
235 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
236 License:        LGPL v2.1+
237 Group:          Development/Languages
238 Requires:       %{name}-libs = %{version}-%{release}
239 Requires:       guile >= 5:2.2.0
240
241 %description -n guile-gnutls
242 Guile bindings for GnuTLS.
243
244 %description -n guile-gnutls -l pl.UTF-8
245 Wiązania Guile do GnuTLS.
246
247 %prep
248 %setup -q
249 %patch0 -p1
250 %patch1 -p1
251
252 %{__rm} po/stamp-po
253
254 %build
255 %{__libtoolize}
256 %{__aclocal} -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4
257 %{__autoconf}
258 %{__autoheader}
259 %{__automake}
260 %configure \
261         %{?with_openssl:--enable-openssl-compatibility} \
262         --disable-silent-rules \
263         %{?with_static_libs:--enable-static} \
264         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
265         %{!?with_tpm:--without-tpm} \
266         %{!?with_guile:--enable-guile=no} \
267         --with-trousers-lib=%{_libdir}/libtspi.so.1 \
268         %{!?with_doc:--disable-doc}
269
270 # docs build is broken with -jN
271 %{__make} -j1
272
273 %install
274 rm -rf $RPM_BUILD_ROOT
275
276 %{__make} install \
277         DESTDIR=$RPM_BUILD_ROOT
278
279 # although libgnutls.la is obsoleted by pkg-config, there is
280 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
281
282 %if %{with guile}
283 # guile module - dynamic only
284 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
285 %if %{with static_libs}
286 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
287 %endif
288 %endif
289
290 # images for (not installed) htmlized infos - already packaged with infos
291 %{__rm} $RPM_BUILD_ROOT%{_docdir}/gnutls/*.png
292
293 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
294
295 %find_lang %{name}
296
297 %clean
298 rm -rf $RPM_BUILD_ROOT
299
300 %post
301 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
302
303 %postun
304 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
305
306 %post   libs -p /sbin/ldconfig
307 %postun libs -p /sbin/ldconfig
308
309 %post   c++ -p /sbin/ldconfig
310 %postun c++ -p /sbin/ldconfig
311
312 %post   dane -p /sbin/ldconfig
313 %postun dane -p /sbin/ldconfig
314
315 %post   openssl -p /sbin/ldconfig
316 %postun openssl -p /sbin/ldconfig
317
318 %post   -n guile-gnutls -p /sbin/ldconfig
319 %postun -n guile-gnutls -p /sbin/ldconfig
320
321 %files -f %{name}.lang
322 %defattr(644,root,root,755)
323 %doc AUTHORS ChangeLog NEWS README.md THANKS
324 %attr(755,root,root) %{_bindir}/certtool
325 %attr(755,root,root) %{_bindir}/gnutls-*
326 %attr(755,root,root) %{_bindir}/ocsptool
327 %attr(755,root,root) %{_bindir}/p11tool
328 %attr(755,root,root) %{_bindir}/psktool
329 %attr(755,root,root) %{_bindir}/srptool
330 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
331 %if %{with doc}
332 %{_mandir}/man1/certtool.1*
333 %{_mandir}/man1/gnutls-*.1*
334 %{_mandir}/man1/ocsptool.1*
335 %{_mandir}/man1/p11tool.1*
336 %{_mandir}/man1/psktool.1*
337 %{_mandir}/man1/srptool.1*
338 %{_mandir}/man1/tpmtool.1*
339 %{_infodir}/gnutls.info*
340 %{_infodir}/gnutls-*.png
341 %{_infodir}/pkcs11-vision.png
342 %endif
343
344 %files libs
345 %defattr(644,root,root,755)
346 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
347 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
348
349 %files devel
350 %defattr(644,root,root,755)
351 %attr(755,root,root) %{_libdir}/libgnutls.so
352 %{_libdir}/libgnutls.la
353 %{_includedir}/gnutls
354 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
355 %exclude %{_includedir}/gnutls/gnutlsxx.h
356 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
357 %{_pkgconfigdir}/gnutls.pc
358 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
359
360 %if %{with static_libs}
361 %files static
362 %defattr(644,root,root,755)
363 %{_libdir}/libgnutls.a
364 %endif
365
366 %files c++
367 %defattr(644,root,root,755)
368 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
369 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
370
371 %files c++-devel
372 %defattr(644,root,root,755)
373 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
374 %{_libdir}/libgnutlsxx.la
375 %{_includedir}/gnutls/gnutlsxx.h
376
377 %if %{with static_libs}
378 %files c++-static
379 %defattr(644,root,root,755)
380 %{_libdir}/libgnutlsxx.a
381 %endif
382
383 %if %{with dane}
384 %files dane
385 %defattr(644,root,root,755)
386 %attr(755,root,root) %{_bindir}/danetool
387 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
388 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
389 %{?with_doc:%{_mandir}/man1/danetool.1*}
390
391 %files dane-devel
392 %defattr(644,root,root,755)
393 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
394 %{_libdir}/libgnutls-dane.la
395 %{_includedir}/gnutls/dane.h
396 %{_pkgconfigdir}/gnutls-dane.pc
397 %{_mandir}/man3/dane_*.3*
398
399 %if %{with static_libs}
400 %files dane-static
401 %defattr(644,root,root,755)
402 %{_libdir}/libgnutls-dane.a
403 %endif
404 %endif
405
406 %if %{with openssl}
407 %files openssl
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
411
412 %files openssl-devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
415 %{_libdir}/libgnutls-openssl.la
416 %{_includedir}/gnutls/openssl.h
417
418 %files openssl-static
419 %defattr(644,root,root,755)
420 %{_libdir}/libgnutls-openssl.a
421 %endif
422
423 %if %{with guile}
424 %files -n guile-gnutls
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
427 %{_libdir}/guile/2.0/site-ccache/gnutls.go
428 %{_libdir}/guile/2.0/site-ccache/gnutls
429 %{_datadir}/guile/site/2.0/gnutls.scm
430 %{_datadir}/guile/site/2.0/gnutls
431 %{_infodir}/gnutls-guile.info*
432 %endif
This page took 0.148027 seconds and 4 git commands to generate.