]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.4.2
[packages/gnutls.git] / gnutls.spec
1 # NOTE: 3.3.x is previous-stable line
2 # - for 3.5.x (current stable) see DEVEL branch (requires DEVEL p11-kit)
3 #
4 # Conditional build:
5 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
6 %bcond_without  openssl         # libgnutls-openssl compatibility library
7 %bcond_without  tpm             # TPM support in gnutls
8 %bcond_without  static_libs     # static libraries
9 %bcond_without  doc             # do not generate documentation
10 #
11 Summary:        The GNU Transport Layer Security Library
12 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
13 Name:           gnutls
14 Version:        3.4.2
15 Release:        1
16 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
17 Group:          Libraries
18 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4/%{name}-%{version}.tar.lz
19 # Source0-md5:  62537f59d8c6e01aec1066ff870109dd
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-link.patch
22 URL:            http://www.gnutls.org/
23 BuildRequires:  autoconf >= 2.61
24 BuildRequires:  autogen
25 BuildRequires:  autogen-devel
26 BuildRequires:  automake >= 1:1.12.2
27 BuildRequires:  gettext-tools >= 0.18
28 BuildRequires:  gmp-devel
29 %{?with_doc:BuildRequires:      gtk-doc >= 1.1}
30 BuildRequires:  guile-devel >= 5:2.0
31 BuildRequires:  libcfg+-devel
32 BuildRequires:  libidn-devel >= 0.5.6
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtasn1-devel >= 4.3
35 BuildRequires:  libtool >= 2:2
36 BuildRequires:  lzip
37 BuildRequires:  nettle-devel >= 3.1
38 # miniopencdk is included in sources and currently maintained
39 # as part of gnutls, not external package
40 #BuildRequires: opencdk-devel >= 0.6.6
41 BuildRequires:  p11-kit-devel >= 0.23.1
42 BuildRequires:  pkgconfig
43 BuildRequires:  readline-devel
44 BuildRequires:  rpmbuild(macros) >= 1.383
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  tar >= 1:1.22
47 %{?with_doc:BuildRequires:      texinfo >= 4.8}
48 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
49 %{?with_dane:BuildRequires:     unbound-devel}
50 BuildRequires:  xz
51 BuildRequires:  zlib-devel
52 Requires:       %{name}-libs = %{version}-%{release}
53 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 GnuTLS is a project that aims to develop a library which provides a
58 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
59 the gnuTLS library implements the proposed standards by the IETF's TLS
60 working group.
61
62 %description -l pl.UTF-8
63 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
64 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
65 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
66 grupę roboczą IETF TLS.
67
68 %package libs
69 Summary:        GnuTLS shared libraries
70 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
71 Group:          Libraries
72 Requires:       libidn >= 0.5.6
73 Requires:       libtasn1 >= 4.3
74 Requires:       nettle >= 3.1
75 #Requires:      opencdk >= 0.6.6
76 Requires:       p11-kit >= 0.23.1
77 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
78 Conflicts:      gnutls < 3.2.0
79
80 %description libs
81 GnuTLS shared libraries.
82
83 %description libs -l pl.UTF-8
84 Biblioteki współdzielone GnuTLS.
85
86 %package devel
87 Summary:        Header files etc to develop gnutls applications
88 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
89 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
90 Group:          Development/Libraries
91 Requires:       %{name}-libs = %{version}-%{release}
92 Requires:       libidn-devel >= 0.5.6
93 Requires:       libtasn1-devel >= 4.3
94 Requires:       nettle-devel >= 3.1
95 #Requires:      opencdk-devel >= 0.6.6
96 Requires:       p11-kit-devel >= 0.23.1
97 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
98 Requires:       zlib-devel
99
100 %description devel
101 Header files etc to develop gnutls applications.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe i inne do gnutls.
105
106 %package static
107 Summary:        Static gnutls library
108 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
109 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description static
114 Static gnutls library.
115
116 %description static -l pl.UTF-8
117 Biblioteka statyczna gnutls.
118
119 %package c++
120 Summary:        libgnutlsxx - C++ interface to gnutls library
121 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
122 License:        LGPL v2.1+
123 Group:          Libraries
124 Requires:       %{name}-libs = %{version}-%{release}
125
126 %description c++
127 libgnutlsxx - C++ interface to gnutls library.
128
129 %description c++ -l pl.UTF-8
130 libgnutlsxx - interfejs C++ do biblioteki gnutls.
131
132 %package c++-devel
133 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
134 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
135 License:        LGPL v2.1+
136 Group:          Development/Libraries
137 Requires:       %{name}-c++ = %{version}-%{release}
138 Requires:       %{name}-devel = %{version}-%{release}
139 Requires:       libstdc++-devel
140
141 %description c++-devel
142 Header files for libgnutlsxx, a C++ interface to gnutls library.
143
144 %description c++-devel -l pl.UTF-8
145 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
146
147 %package c++-static
148 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
149 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
150 License:        LGPL v2.1+
151 Group:          Development/Libraries
152 Requires:       %{name}-c++-devel = %{version}-%{release}
153
154 %description c++-static
155 Static version of libgnutlsxx, a C++ interface to gnutls library.
156
157 %description c++-static -l pl.UTF-8
158 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
159
160 %package dane
161 Summary:        DANE security library
162 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
163 Group:          Libraries
164 Requires:       %{name}-libs = %{version}-%{release}
165
166 %description dane
167 DANE security library.
168
169 %description dane -l pl.UTF-8
170 Biblioteka bezpieczeństwa DANE.
171
172 %package dane-devel
173 Summary:        Header file for DANE security library
174 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
175 Group:          Development/Libraries
176 Requires:       %{name}-dane = %{version}-%{release}
177 Requires:       %{name}-devel = %{version}-%{release}
178 Requires:       unbound-devel
179
180 %description dane-devel
181 Header file for DANE security library.
182
183 %description dane-devel -l pl.UTF-8
184 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
185
186 %package dane-static
187 Summary:        Static DANE security library
188 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
189 Group:          Development/Libraries
190 Requires:       %{name}-dane-devel = %{version}-%{release}
191
192 %description dane-static
193 Static DANE security library.
194
195 %description dane-static -l pl.UTF-8
196 Statyczna biblioteka bezpieczeństwa DANE.
197
198 %package openssl
199 Summary:        OpenSSL compatibility library for GnuTLS
200 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
201 Group:          Libraries
202 Requires:       %{name}-libs = %{version}-%{release}
203
204 %description openssl
205 OpenSSL compatibility library for GnuTLS.
206
207 %description openssl -l pl.UTF-8
208 Biblioteka zgodności z OpenSSL dla GnuTLS.
209
210 %package openssl-devel
211 Summary:        Header file for gnutls-openssl library
212 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
213 Group:          Development/Libraries
214 Requires:       %{name}-devel = %{version}-%{release}
215 Requires:       %{name}-openssl = %{version}-%{release}
216
217 %description openssl-devel
218 Header file for gnutls-openssl library.
219
220 %description openssl-devel -l pl.UTF-8
221 Plik nagłówkowy biblioteki gnutls-openssl.
222
223 %package openssl-static
224 Summary:        Static gnutls-openssl library
225 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
226 Group:          Development/Libraries
227 Requires:       %{name}-openssl-devel = %{version}-%{release}
228
229 %description openssl-static
230 Static gnutls-openssl library.
231
232 %description openssl-static -l pl.UTF-8
233 Statyczna biblioteka gnutls-openssl.
234
235 %package -n guile-gnutls
236 Summary:        Guile bindings for GnuTLS
237 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
238 License:        LGPL v2.1+
239 Group:          Development/Languages
240 Requires:       %{name}-libs = %{version}-%{release}
241 Requires:       guile >= 5:2.0
242
243 %description -n guile-gnutls
244 Guile bindings for GnuTLS.
245
246 %description -n guile-gnutls -l pl.UTF-8
247 Wiązania Guile do GnuTLS.
248
249 %prep
250 %setup -q
251 %patch0 -p1
252 %patch1 -p1
253
254 %{__rm} po/stamp-po
255
256 %build
257 %{__mv} build-aux/snippet{,.save}
258 %{__libtoolize}
259 %{__mv} build-aux/snippet{.save,}
260 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4
261 %{__autoconf}
262 %{__autoheader}
263 %{__automake}
264 %configure \
265         %{?with_openssl:--enable-openssl-compatibility} \
266         --disable-silent-rules \
267         %{?with_static_libs:--enable-static} \
268         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
269         %{!?with_tpm:--without-tpm} \
270         --with-trousers-lib=%{_libdir}/libtspi.so.1 \
271         %{!?with_doc:--disable-doc}
272
273 # docs build is broken with -jN
274 %{__make} -j1
275
276 %install
277 rm -rf $RPM_BUILD_ROOT
278
279 %{__make} install \
280         DESTDIR=$RPM_BUILD_ROOT
281
282 # although libgnutls.la is obsoleted by pkg-config, there is
283 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
284
285 # guile module - dynamic only
286 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
287 %if %{with static_libs}
288 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
289 %endif
290
291 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
292
293 %find_lang %{name}
294
295 %clean
296 rm -rf $RPM_BUILD_ROOT
297
298 %post
299 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
300
301 %postun
302 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
303
304 %post   libs -p /sbin/ldconfig
305 %postun libs -p /sbin/ldconfig
306
307 %post   c++ -p /sbin/ldconfig
308 %postun c++ -p /sbin/ldconfig
309
310 %post   dane -p /sbin/ldconfig
311 %postun dane -p /sbin/ldconfig
312
313 %post   openssl -p /sbin/ldconfig
314 %postun openssl -p /sbin/ldconfig
315
316 %post   -n guile-gnutls -p /sbin/ldconfig
317 %postun -n guile-gnutls -p /sbin/ldconfig
318
319 %files -f %{name}.lang
320 %defattr(644,root,root,755)
321 %doc AUTHORS ChangeLog NEWS README THANKS
322 %attr(755,root,root) %{_bindir}/certtool
323 %attr(755,root,root) %{_bindir}/crywrap
324 %attr(755,root,root) %{_bindir}/gnutls-*
325 %attr(755,root,root) %{_bindir}/ocsptool
326 %attr(755,root,root) %{_bindir}/p11tool
327 %attr(755,root,root) %{_bindir}/psktool
328 %attr(755,root,root) %{_bindir}/srptool
329 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
330 %if %{with doc}
331 %{_mandir}/man1/certtool.1*
332 %{_mandir}/man1/gnutls-*.1*
333 %{_mandir}/man1/ocsptool.1*
334 %{_mandir}/man1/p11tool.1*
335 %{_mandir}/man1/psktool.1*
336 %{_mandir}/man1/srptool.1*
337 %{_mandir}/man1/tpmtool.1*
338 %{_infodir}/gnutls.info*
339 %{_infodir}/gnutls-*.png
340 %{_infodir}/pkcs11-vision.png
341 %endif
342
343 %files libs
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
346 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
347
348 %files devel
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/libgnutls.so
351 %{_libdir}/libgnutls.la
352 %{_includedir}/gnutls
353 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
354 %exclude %{_includedir}/gnutls/gnutlsxx.h
355 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
356 %{_pkgconfigdir}/gnutls.pc
357 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
358
359 %if %{with static_libs}
360 %files static
361 %defattr(644,root,root,755)
362 %{_libdir}/libgnutls.a
363 %endif
364
365 %files c++
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
368 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
369
370 %files c++-devel
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
373 %{_libdir}/libgnutlsxx.la
374 %{_includedir}/gnutls/gnutlsxx.h
375
376 %if %{with static_libs}
377 %files c++-static
378 %defattr(644,root,root,755)
379 %{_libdir}/libgnutlsxx.a
380 %endif
381
382 %if %{with dane}
383 %files dane
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_bindir}/danetool
386 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
388 %{?with_doc:%{_mandir}/man1/danetool.1*}
389
390 %files dane-devel
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
393 %{_libdir}/libgnutls-dane.la
394 %{_includedir}/gnutls/dane.h
395 %{_pkgconfigdir}/gnutls-dane.pc
396
397 %if %{with static_libs}
398 %files dane-static
399 %defattr(644,root,root,755)
400 %{_libdir}/libgnutls-dane.a
401 %endif
402 %endif
403
404 %if %{with openssl}
405 %files openssl
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
408 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
409
410 %files openssl-devel
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
413 %{_libdir}/libgnutls-openssl.la
414 %{_includedir}/gnutls/openssl.h
415
416 %files openssl-static
417 %defattr(644,root,root,755)
418 %{_libdir}/libgnutls-openssl.a
419 %endif
420
421 %files -n guile-gnutls
422 %defattr(644,root,root,755)
423 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
424 %{_datadir}/guile/site/gnutls.scm
425 %{_datadir}/guile/site/gnutls
426 %{?with_doc:%{_infodir}/gnutls-guile.info*}
This page took 0.108774 seconds and 4 git commands to generate.