]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
- updated to 3.5.8 (fixes GNUTLS-SA-2017-1 GNUTLS-SA-2017-2)
[packages/gnutls.git] / gnutls.spec
1 # NOTE: 3.3.x is previous-stable line
2 # - for 3.5.x (current stable) see DEVEL branch (requires DEVEL p11-kit)
3 #
4 # Conditional build:
5 %bcond_without  dane            # libdane (DANE with DNSSEC certificate verification)
6 %bcond_without  openssl         # libgnutls-openssl compatibility library
7 %bcond_without  tpm             # TPM support in gnutls
8 %bcond_without  static_libs     # static libraries
9 %bcond_without  doc             # do not generate documentation
10 #
11 Summary:        The GNU Transport Layer Security Library
12 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
13 Name:           gnutls
14 Version:        3.5.8
15 Release:        1
16 License:        LGPL v2.1+ (libgnutls), LGPL v3+ (libdane), GPL v3+ (openssl library and tools)
17 Group:          Libraries
18 Source0:        ftp://ftp.gnutls.org/gcrypt/gnutls/v3.5/%{name}-%{version}.tar.xz
19 # Source0-md5:  113e892e51acdb11b81804cd355adfee
20 Patch0:         %{name}-info.patch
21 Patch1:         %{name}-link.patch
22 URL:            http://www.gnutls.org/
23 BuildRequires:  autoconf >= 2.61
24 BuildRequires:  autogen
25 BuildRequires:  autogen-devel
26 BuildRequires:  automake >= 1:1.12.2
27 BuildRequires:  gettext-tools >= 0.19
28 BuildRequires:  gmp-devel
29 %{?with_doc:BuildRequires:      gtk-doc >= 1.1}
30 BuildRequires:  guile-devel >= 5:2.0
31 BuildRequires:  libcfg+-devel
32 BuildRequires:  libidn-devel >= 1.31
33 BuildRequires:  libstdc++-devel
34 BuildRequires:  libtasn1-devel >= 4.9
35 BuildRequires:  libunistring-devel
36 BuildRequires:  libtool >= 2:2
37 BuildRequires:  nettle-devel >= 3.3
38 # miniopencdk is included in sources and currently maintained
39 # as part of gnutls, not external package
40 #BuildRequires: opencdk-devel >= 0.6.6
41 BuildRequires:  p11-kit-devel >= 0.23.1
42 BuildRequires:  pkgconfig
43 BuildRequires:  readline-devel
44 BuildRequires:  rpmbuild(macros) >= 1.383
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  tar >= 1:1.22
47 %{?with_doc:BuildRequires:      texinfo >= 4.8}
48 %{?with_tpm:BuildRequires:      trousers-devel >= 0.3.11}
49 %{?with_dane:BuildRequires:     unbound-devel}
50 BuildRequires:  xz
51 BuildRequires:  zlib-devel
52 Requires:       %{name}-libs = %{version}-%{release}
53 %{?with_dane:Requires:  %{name}-dane = %{version}-%{release}}
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 GnuTLS is a project that aims to develop a library which provides a
58 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
59 the gnuTLS library implements the proposed standards by the IETF's TLS
60 working group.
61
62 %description -l pl.UTF-8
63 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
64 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
65 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
66 grupę roboczą IETF TLS.
67
68 %package libs
69 Summary:        GnuTLS shared libraries
70 Summary(pl.UTF-8):      Biblioteki współdzielone GnuTLS
71 Group:          Libraries
72 Requires:       libidn >= 1.31
73 Requires:       libtasn1 >= 4.9
74 Requires:       nettle >= 3.3
75 #Requires:      opencdk >= 0.6.6
76 Requires:       p11-kit >= 0.23.1
77 %{?with_tpm:Requires:   trousers-libs >= 0.3.11}
78 Conflicts:      gnutls < 3.2.0
79
80 %description libs
81 GnuTLS shared libraries.
82
83 %description libs -l pl.UTF-8
84 Biblioteki współdzielone GnuTLS.
85
86 %package devel
87 Summary:        Header files etc to develop gnutls applications
88 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
89 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
90 Group:          Development/Libraries
91 Requires:       %{name}-libs = %{version}-%{release}
92 Requires:       libidn-devel >= 1.31
93 Requires:       libtasn1-devel >= 4.9
94 Requires:       libunistring-devel
95 Requires:       nettle-devel >= 3.3
96 #Requires:      opencdk-devel >= 0.6.6
97 Requires:       p11-kit-devel >= 0.23.1
98 %{?with_tpm:Requires:   trousers-devel >= 0.3.11}
99 Requires:       zlib-devel
100
101 %description devel
102 Header files etc to develop gnutls applications.
103
104 %description devel -l pl.UTF-8
105 Pliki nagłówkowe i inne do gnutls.
106
107 %package static
108 Summary:        Static gnutls library
109 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
110 License:        LGPL v2.1+ (libgnutls), GPL v3+ (openssl library)
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Static gnutls library.
116
117 %description static -l pl.UTF-8
118 Biblioteka statyczna gnutls.
119
120 %package c++
121 Summary:        libgnutlsxx - C++ interface to gnutls library
122 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
123 License:        LGPL v2.1+
124 Group:          Libraries
125 Requires:       %{name}-libs = %{version}-%{release}
126
127 %description c++
128 libgnutlsxx - C++ interface to gnutls library.
129
130 %description c++ -l pl.UTF-8
131 libgnutlsxx - interfejs C++ do biblioteki gnutls.
132
133 %package c++-devel
134 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
135 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
136 License:        LGPL v2.1+
137 Group:          Development/Libraries
138 Requires:       %{name}-c++ = %{version}-%{release}
139 Requires:       %{name}-devel = %{version}-%{release}
140 Requires:       libstdc++-devel
141
142 %description c++-devel
143 Header files for libgnutlsxx, a C++ interface to gnutls library.
144
145 %description c++-devel -l pl.UTF-8
146 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
147
148 %package c++-static
149 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
150 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
151 License:        LGPL v2.1+
152 Group:          Development/Libraries
153 Requires:       %{name}-c++-devel = %{version}-%{release}
154
155 %description c++-static
156 Static version of libgnutlsxx, a C++ interface to gnutls library.
157
158 %description c++-static -l pl.UTF-8
159 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
160
161 %package dane
162 Summary:        DANE security library
163 Summary(pl.UTF-8):      Biblioteka bezpieczeństwa DANE
164 Group:          Libraries
165 Requires:       %{name}-libs = %{version}-%{release}
166
167 %description dane
168 DANE security library.
169
170 %description dane -l pl.UTF-8
171 Biblioteka bezpieczeństwa DANE.
172
173 %package dane-devel
174 Summary:        Header file for DANE security library
175 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki bezpieczeństwa DANE
176 Group:          Development/Libraries
177 Requires:       %{name}-dane = %{version}-%{release}
178 Requires:       %{name}-devel = %{version}-%{release}
179 Requires:       unbound-devel
180
181 %description dane-devel
182 Header file for DANE security library.
183
184 %description dane-devel -l pl.UTF-8
185 Plik nagłówkowy biblioteki bezpieczeństwa DANE.
186
187 %package dane-static
188 Summary:        Static DANE security library
189 Summary(pl.UTF-8):      Statyczna biblioteka bezpieczeństwa DANE
190 Group:          Development/Libraries
191 Requires:       %{name}-dane-devel = %{version}-%{release}
192
193 %description dane-static
194 Static DANE security library.
195
196 %description dane-static -l pl.UTF-8
197 Statyczna biblioteka bezpieczeństwa DANE.
198
199 %package openssl
200 Summary:        OpenSSL compatibility library for GnuTLS
201 Summary(pl.UTF-8):      Biblioteka zgodności z OpenSSL dla GnuTLS
202 Group:          Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204
205 %description openssl
206 OpenSSL compatibility library for GnuTLS.
207
208 %description openssl -l pl.UTF-8
209 Biblioteka zgodności z OpenSSL dla GnuTLS.
210
211 %package openssl-devel
212 Summary:        Header file for gnutls-openssl library
213 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki gnutls-openssl
214 Group:          Development/Libraries
215 Requires:       %{name}-devel = %{version}-%{release}
216 Requires:       %{name}-openssl = %{version}-%{release}
217
218 %description openssl-devel
219 Header file for gnutls-openssl library.
220
221 %description openssl-devel -l pl.UTF-8
222 Plik nagłówkowy biblioteki gnutls-openssl.
223
224 %package openssl-static
225 Summary:        Static gnutls-openssl library
226 Summary(pl.UTF-8):      Statyczna biblioteka gnutls-openssl
227 Group:          Development/Libraries
228 Requires:       %{name}-openssl-devel = %{version}-%{release}
229
230 %description openssl-static
231 Static gnutls-openssl library.
232
233 %description openssl-static -l pl.UTF-8
234 Statyczna biblioteka gnutls-openssl.
235
236 %package -n guile-gnutls
237 Summary:        Guile bindings for GnuTLS
238 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
239 License:        LGPL v2.1+
240 Group:          Development/Languages
241 Requires:       %{name}-libs = %{version}-%{release}
242 Requires:       guile >= 5:2.0
243
244 %description -n guile-gnutls
245 Guile bindings for GnuTLS.
246
247 %description -n guile-gnutls -l pl.UTF-8
248 Wiązania Guile do GnuTLS.
249
250 %prep
251 %setup -q
252 %patch0 -p1
253 %patch1 -p1
254
255 %{__rm} po/stamp-po
256
257 %build
258 %{__mv} build-aux/snippet{,.save}
259 %{__libtoolize}
260 %{__mv} build-aux/snippet{.save,}
261 %{__aclocal} -I m4 -I gl/m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4
262 %{__autoconf}
263 %{__autoheader}
264 %{__automake}
265 %configure \
266         %{?with_openssl:--enable-openssl-compatibility} \
267         --disable-silent-rules \
268         %{?with_static_libs:--enable-static} \
269         --with-default-trust-store-file=/etc/certs/ca-certificates.crt \
270         %{!?with_tpm:--without-tpm} \
271         --with-trousers-lib=%{_libdir}/libtspi.so.1 \
272         %{!?with_doc:--disable-doc}
273
274 # docs build is broken with -jN
275 %{__make} -j1
276
277 %install
278 rm -rf $RPM_BUILD_ROOT
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT
282
283 # although libgnutls.la is obsoleted by pkg-config, there is
284 # .pc file missing for libgnutls-openssl, and it needs libgnutls.la
285
286 # guile module - dynamic only
287 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.la
288 %if %{with static_libs}
289 %{__rm} $RPM_BUILD_ROOT%{_libdir}/guile/2.0/guile-gnutls-*.a
290 %endif
291
292 %{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
293
294 %find_lang %{name}
295
296 %clean
297 rm -rf $RPM_BUILD_ROOT
298
299 %post
300 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
301
302 %postun
303 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
304
305 %post   libs -p /sbin/ldconfig
306 %postun libs -p /sbin/ldconfig
307
308 %post   c++ -p /sbin/ldconfig
309 %postun c++ -p /sbin/ldconfig
310
311 %post   dane -p /sbin/ldconfig
312 %postun dane -p /sbin/ldconfig
313
314 %post   openssl -p /sbin/ldconfig
315 %postun openssl -p /sbin/ldconfig
316
317 %post   -n guile-gnutls -p /sbin/ldconfig
318 %postun -n guile-gnutls -p /sbin/ldconfig
319
320 %files -f %{name}.lang
321 %defattr(644,root,root,755)
322 %doc AUTHORS ChangeLog NEWS README.md THANKS
323 %attr(755,root,root) %{_bindir}/certtool
324 %attr(755,root,root) %{_bindir}/gnutls-*
325 %attr(755,root,root) %{_bindir}/ocsptool
326 %attr(755,root,root) %{_bindir}/p11tool
327 %attr(755,root,root) %{_bindir}/psktool
328 %attr(755,root,root) %{_bindir}/srptool
329 %{?with_tpm:%attr(755,root,root) %{_bindir}/tpmtool}
330 %if %{with doc}
331 %{_mandir}/man1/certtool.1*
332 %{_mandir}/man1/gnutls-*.1*
333 %{_mandir}/man1/ocsptool.1*
334 %{_mandir}/man1/p11tool.1*
335 %{_mandir}/man1/psktool.1*
336 %{_mandir}/man1/srptool.1*
337 %{_mandir}/man1/tpmtool.1*
338 %{_infodir}/gnutls.info*
339 %{_infodir}/gnutls-*.png
340 %{_infodir}/pkcs11-vision.png
341 %endif
342
343 %files libs
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
346 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.30
347
348 %files devel
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/libgnutls.so
351 %{_libdir}/libgnutls.la
352 %{_includedir}/gnutls
353 %{?with_dane:%exclude %{_includedir}/gnutls/dane.h}
354 %exclude %{_includedir}/gnutls/gnutlsxx.h
355 %{?with_openssl:%exclude %{_includedir}/gnutls/openssl.h}
356 %{_pkgconfigdir}/gnutls.pc
357 %{?with_doc:%{_mandir}/man3/gnutls_*.3*}
358
359 %if %{with static_libs}
360 %files static
361 %defattr(644,root,root,755)
362 %{_libdir}/libgnutls.a
363 %endif
364
365 %files c++
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
368 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
369
370 %files c++-devel
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
373 %{_libdir}/libgnutlsxx.la
374 %{_includedir}/gnutls/gnutlsxx.h
375
376 %if %{with static_libs}
377 %files c++-static
378 %defattr(644,root,root,755)
379 %{_libdir}/libgnutlsxx.a
380 %endif
381
382 %if %{with dane}
383 %files dane
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_bindir}/danetool
386 %attr(755,root,root) %{_libdir}/libgnutls-dane.so.*.*.*
387 %attr(755,root,root) %ghost %{_libdir}/libgnutls-dane.so.0
388 %{?with_doc:%{_mandir}/man1/danetool.1*}
389
390 %files dane-devel
391 %defattr(644,root,root,755)
392 %attr(755,root,root) %{_libdir}/libgnutls-dane.so
393 %{_libdir}/libgnutls-dane.la
394 %{_includedir}/gnutls/dane.h
395 %{_pkgconfigdir}/gnutls-dane.pc
396 %{_mandir}/man3/dane_*.3*
397
398 %if %{with static_libs}
399 %files dane-static
400 %defattr(644,root,root,755)
401 %{_libdir}/libgnutls-dane.a
402 %endif
403 %endif
404
405 %if %{with openssl}
406 %files openssl
407 %defattr(644,root,root,755)
408 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
409 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
410
411 %files openssl-devel
412 %defattr(644,root,root,755)
413 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
414 %{_libdir}/libgnutls-openssl.la
415 %{_includedir}/gnutls/openssl.h
416
417 %files openssl-static
418 %defattr(644,root,root,755)
419 %{_libdir}/libgnutls-openssl.a
420 %endif
421
422 %files -n guile-gnutls
423 %defattr(644,root,root,755)
424 %attr(755,root,root) %{_libdir}/guile/2.0/guile-gnutls-v-2.so*
425 %{_libdir}/guile/2.0/site-ccache/gnutls.go
426 %{_libdir}/guile/2.0/site-ccache/gnutls
427 %{_datadir}/guile/site/2.0/gnutls.scm
428 %{_datadir}/guile/site/2.0/gnutls
429 %{_infodir}/gnutls-guile.info*
This page took 0.082201 seconds and 4 git commands to generate.