]> git.pld-linux.org Git - packages/gnutls.git/blob - gnutls.spec
cbf3536c14bd89cd91b3d247a3b44d648f15f03c
[packages/gnutls.git] / gnutls.spec
1 #
2 # Conditional build:
3 %bcond_with     gcrypt  # use gcrypt crypto backend instead of nettle (broken or withdrawn?)
4 #
5 Summary:        The GNU Transport Layer Security Library
6 Summary(pl.UTF-8):      Biblioteka GNU TLS (Transport Layer Security)
7 Name:           gnutls
8 Version:        3.0.4
9 Release:        2
10 License:        LGPL v3+ (libgnutls), GPL v3+ (extra libs and tools)
11 Group:          Libraries
12 Source0:        ftp://ftp.gnutls.org/pub/gnutls/%{name}-%{version}.tar.xz
13 # Source0-md5:  748d537027978abcb7dd33ec396dc511
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-pl.po-update.patch
17 URL:            http://www.gnu.org/software/gnutls/
18 BuildRequires:  autoconf >= 2.61
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  gtk-doc >= 1.1
22 BuildRequires:  guile-devel >= 5:1.8
23 BuildRequires:  libcfg+-devel
24 %{?with_gcrypt:BuildRequires:   libgcrypt-devel >= 1.4.0}
25 BuildRequires:  libidn-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtasn1-devel >= 2.9
28 BuildRequires:  libtool >= 2:1.5
29 %{!?with_gcrypt:BuildRequires:  nettle-devel >= 2.4}
30 # miniopencdk is included in sources and currently maintained
31 # as part of gnutls, not external package
32 #BuildRequires: opencdk-devel >= 0.6.6
33 BuildRequires:  p11-kit-devel >= 0.4
34 BuildRequires:  pkgconfig
35 BuildRequires:  readline-devel
36 BuildRequires:  rpmbuild(macros) >= 1.383
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  texinfo >= 4.8
39 BuildRequires:  xz
40 BuildRequires:  zlib-devel
41 Requires(post,postun):  /sbin/ldconfig
42 %{?with_gcrypt:Requires:        libgcrypt >= 1.4.0}
43 Requires:       libtasn1 >= 2.9
44 %{!?with_gcrypt:Requires:       nettle >= 2.4}
45 #Requires:      opencdk >= 0.6.6
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 GnuTLS is a project that aims to develop a library which provides a
50 secure layer, over a reliable transport layer (ie. TCP/IP). Currently
51 the gnuTLS library implements the proposed standards by the IETF's TLS
52 working group.
53
54 %description -l pl.UTF-8
55 GnuTLS to projekt mający na celu stworzenie biblioteki udostępniającej
56 powłokę bezpieczeństwa ponad powłoką transportową (np. TCP/IP).
57 Aktualnie biblioteka gnuTLS implementuje standardy proponowane przez
58 grupę roboczą IETF TLS.
59
60 %package devel
61 Summary:        Header files etc to develop gnutls applications
62 Summary(pl.UTF-8):      Pliki nagłówkowe i inne do gnutls
63 License:        LGPL v2.1+ (libgnutls), GPL v3+ (extra libs)
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 %{?with_gcrypt:Requires:        libgcrypt-devel >= 1.4.0}
67 Requires:       libtasn1-devel >= 2.9
68 %{!?with_gcrypt:Requires:       nettle-devel >= 2.4}
69 #Requires:      opencdk-devel >= 0.6.6
70 Requires:       p11-kit-devel >= 0.4
71 Requires:       zlib-devel
72
73 %description devel
74 Header files etc to develop gnutls applications.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe i inne do gnutls.
78
79 %package static
80 Summary:        Static gnutls library
81 Summary(pl.UTF-8):      Biblioteka statyczna gnutls
82 License:        LGPL v2.1+ (libgnutls), GPL v3+ (extra libs)
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static gnutls library.
88
89 %description static -l pl.UTF-8
90 Biblioteka statyczna gnutls.
91
92 %package c++
93 Summary:        libgnutlsxx - C++ interface to gnutls library
94 Summary(pl.UTF-8):      libgnutlsxx - interfejs C++ do biblioteki gnutls
95 License:        LGPL v2.1+
96 Group:          Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description c++
100 libgnutlsxx - C++ interface to gnutls library.
101
102 %description c++ -l pl.UTF-8
103 libgnutlsxx - interfejs C++ do biblioteki gnutls.
104
105 %package c++-devel
106 Summary:        Header files for libgnutlsxx, a C++ interface to gnutls library
107 Summary(pl.UTF-8):      Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls
108 License:        LGPL v2.1+
109 Group:          Development/Libraries
110 Requires:       %{name}-c++ = %{version}-%{release}
111 Requires:       %{name}-devel = %{version}-%{release}
112 Requires:       libstdc++-devel
113
114 %description c++-devel
115 Header files for libgnutlsxx, a C++ interface to gnutls library.
116
117 %description c++-devel -l pl.UTF-8
118 Pliki nagłówkowe libgnutlsxx - interfejsu C++ do biblioteki gnutls.
119
120 %package c++-static
121 Summary:        Static version of libgnutlsxx, a C++ interface to gnutls library
122 Summary(pl.UTF-8):      Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls
123 License:        LGPL v2.1+
124 Group:          Development/Libraries
125 Requires:       %{name}-c++-devel = %{version}-%{release}
126
127 %description c++-static
128 Static version of libgnutlsxx, a C++ interface to gnutls library.
129
130 %description c++-static -l pl.UTF-8
131 Statyczna wersja libgnutlsxx - interfejsu C++ do biblioteki gnutls.
132
133 %package -n guile-gnutls
134 Summary:        Guile bindings for GnuTLS
135 Summary(pl.UTF-8):      Wiązania Guile do GnuTLS
136 License:        LGPL v2.1+ (gnutls binding), GPL v3+ (gnutls-extra binding)
137 Group:          Development/Languages
138 Requires:       %{name} = %{version}-%{release}
139 Requires:       guile >= 5:1.8
140
141 %description -n guile-gnutls
142 Guile bindings for GnuTLS.
143
144 %description -n guile-gnutls -l pl.UTF-8
145 Wiązania Guile do GnuTLS.
146
147 %prep
148 %setup -q
149 %patch0 -p1
150 %patch1 -p1
151 %patch2 -p1
152
153 %{__rm} po/stamp-po
154
155 %build
156 %{__libtoolize}
157 %{__aclocal} -I m4 -I gl/m4
158 %{__autoconf}
159 %{__autoheader}
160 %{__automake}
161 %configure \
162         --disable-silent-rules \
163         %{?with_gcrypt:--with-libgcrypt}
164
165 %{__make}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 %{__make} install \
171         DESTDIR=$RPM_BUILD_ROOT
172
173 # although libgnutls{,-extra}.la are obsoleted by pkg-config, there are
174 # .pc files missing for libgnutls{-openssl,xx}, and they need libgnutls.la
175
176 # guile module - dynamic only
177 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libguile-gnutls-*.{la,a}
178
179 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
180
181 %find_lang %{name}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 /sbin/ldconfig
188 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
189
190 %postun
191 /sbin/ldconfig
192 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
193
194 %post   c++ -p /sbin/ldconfig
195 %postun c++ -p /sbin/ldconfig
196
197 %post   -n guile-gnutls -p /sbin/ldconfig
198 %postun -n guile-gnutls -p /sbin/ldconfig
199
200 %files -f %{name}.lang
201 %defattr(644,root,root,755)
202 %doc AUTHORS ChangeLog NEWS README THANKS
203 %attr(755,root,root) %{_bindir}/certtool
204 %attr(755,root,root) %{_bindir}/crywrap
205 %attr(755,root,root) %{_bindir}/gnutls-*
206 %attr(755,root,root) %{_bindir}/p11tool
207 %attr(755,root,root) %{_bindir}/psktool
208 %attr(755,root,root) %{_bindir}/srptool
209 %attr(755,root,root) %{_libdir}/libgnutls.so.*.*.*
210 %attr(755,root,root) %ghost %{_libdir}/libgnutls.so.28
211 %attr(755,root,root) %{_libdir}/libgnutls-extra.so.*.*.*
212 %attr(755,root,root) %ghost %{_libdir}/libgnutls-extra.so.28
213 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so.*.*.*
214 %attr(755,root,root) %ghost %{_libdir}/libgnutls-openssl.so.27
215 %{_mandir}/man1/certtool.1*
216 %{_mandir}/man1/gnutls-*.1*
217 %{_mandir}/man1/p11tool.1*
218 %{_mandir}/man1/psktool.1*
219 %{_mandir}/man1/srptool.1*
220 %{_infodir}/gnutls.info*
221 %{_infodir}/gnutls-*.png
222 %{_infodir}/pkcs11-vision.png
223
224 %files devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libgnutls.so
227 %attr(755,root,root) %{_libdir}/libgnutls-extra.so
228 %attr(755,root,root) %{_libdir}/libgnutls-openssl.so
229 %{_libdir}/libgnutls.la
230 %{_libdir}/libgnutls-extra.la
231 %{_libdir}/libgnutls-openssl.la
232 %{_includedir}/gnutls
233 %exclude %{_includedir}/gnutls/gnutlsxx.h
234 %{_pkgconfigdir}/gnutls.pc
235 %{_pkgconfigdir}/gnutls-extra.pc
236 %{_mandir}/man3/gnutls*.3*
237
238 %files static
239 %defattr(644,root,root,755)
240 %{_libdir}/libgnutls.a
241 %{_libdir}/libgnutls-extra.a
242 %{_libdir}/libgnutls-openssl.a
243
244 %files c++
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_libdir}/libgnutlsxx.so.*.*.*
247 %attr(755,root,root) %ghost %{_libdir}/libgnutlsxx.so.28
248
249 %files c++-devel
250 %defattr(644,root,root,755)
251 %attr(755,root,root) %{_libdir}/libgnutlsxx.so
252 %{_libdir}/libgnutlsxx.la
253 %{_includedir}/gnutls/gnutlsxx.h
254
255 %files c++-static
256 %defattr(644,root,root,755)
257 %{_libdir}/libgnutlsxx.a
258
259 %files -n guile-gnutls
260 %defattr(644,root,root,755)
261 %attr(755,root,root) %{_libdir}/libguile-gnutls-v-1.so.*.*.*
262 %attr(755,root,root) %ghost %{_libdir}/libguile-gnutls-v-1.so.0
263 %attr(755,root,root) %{_libdir}/libguile-gnutls-v-1.so
264 %attr(755,root,root) %{_libdir}/libguile-gnutls-extra-v-1.so.*.*.*
265 %attr(755,root,root) %ghost %{_libdir}/libguile-gnutls-extra-v-1.so.0
266 %attr(755,root,root) %{_libdir}/libguile-gnutls-extra-v-1.so
267 %{_datadir}/guile/site/gnutls.scm
268 %dir %{_datadir}/guile/site/gnutls
269 %{_datadir}/guile/site/gnutls/extra.scm
270 %{_infodir}/gnutls-guile.info*
This page took 0.043589 seconds and 2 git commands to generate.