]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- up to 0.9.4
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.9.4
5 Release:        2
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  399b3a2341899d12710f4d1ed36f3002
10 Patch0:         %{name}-themes.patch
11 Patch2:         %{name}-nocompressdocs.patch
12 Patch3:         %{name}-segv.patch
13 #Patch4:                %{name}-include.patch
14 Patch5:         %{name}-doc.patch
15 URL:            http://www.gnustep.org/
16 BuildRequires:  audiofile-devel
17 BuildRequires:  gcc-objc
18 BuildRequires:  gnustep-base-devel >= 1.9.0
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  zlib-devel
22 Requires:       gnustep-base >= 1.9.0
23 Conflicts:      gnustep-core
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _prefix         /usr/%{_lib}/GNUstep
27
28 %define         libcombo        gnu-gnu-gnu
29 %define         gsos            linux-gnu
30 %ifarch %{ix86}
31 %define         gscpu           ix86
32 %else
33 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
34 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
35 %endif
36
37 %description
38 It is a library of graphical user interface classes written completely
39 in the Objective-C language; the classes are based upon the OpenStep
40 specification as release by NeXT Software, Inc. The library does not
41 completely conform to the specification and has been enhanced in a
42 number of ways to take advantage of the GNU system. These classes
43 include graphical objects such as buttons, text fields, popup lists,
44 browser lists, and windows; there are also many associated classes for
45 handling events, colors, fonts, pasteboards and images.
46
47 %description -l pl
48 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
49 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
50 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
51 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
52 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
53 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
54 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
55
56 %package devel
57 Summary:        GNUstep GUI headers and libs
58 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       audiofile-devel
62 Requires:       gnustep-base-devel >= 1.9.0
63 Requires:       libjpeg-devel
64 Requires:       libtiff-devel
65 Conflicts:      gnustep-core
66
67 %description devel
68 Header files required to build applications against the GNUstep GUI
69 library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
73 biblioteki GNUstep GUI.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch2 -p1
79 %patch3 -p1
80 #%patch4 -p1
81 %patch5 -p1
82
83 %build
84 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
85 %configure
86
87 %{__make} \
88         messages=yes
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
93
94 %{__make} install \
95         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
96         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
97 %{__make} install -C Documentation \
98         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
99         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
100
101 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
102         -type f -name .cvsignore | xargs rm -f
103 # not (yet?) supported by rpm-compress-doc
104 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
105         -type f -a ! -name '*.html' | xargs gzip -9nf
106
107 mv $RPM_BUILD_ROOT/usr/lib/GNUstep/System/Library/Documentation/info/manual.info.gz $RPM_BUILD_ROOT/usr/lib/GNUstep/System/Library/Documentation/info/gnustep-gui.info.gz
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc ChangeLog
118
119 %docdir %{_prefix}/System/Library/Documentation
120 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
121 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
122 %{_prefix}/System/Library/Documentation/User/Gui
123 %{_prefix}/System/Library/Documentation/man/man1/*
124
125 %dir %{_prefix}/System/Library/Bundles/TextConverters
126 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
127 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
128 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
129 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
130 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
131 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
132
133 %dir %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle
134 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources
135 %{_prefix}/System/Library/Bundles/GSPrinting/GSLPR.bundle/%{gscpu}
136
137
138 %dir %{_prefix}/System/Library/ColorPickers
139 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
140 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
141 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
142 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
143 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
144 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
145 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
146 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
147 %dir %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle
148 %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
149 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/%{gscpu}
150 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
151 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
152 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
153
154 %{_prefix}/System/Library/Images/*
155 %{_prefix}/System/Library/KeyBindings/*.dict
156
157 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
158 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
159 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
160
161 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
162
163 %dir %{_prefix}/System/Library/PostScript
164 %{_prefix}/System/Library/PostScript/GSProlog.ps
165 %dir %{_prefix}/System/Library/PostScript/PPD
166 %{_prefix}/System/Library/PostScript/PPD/English.lproj
167 %dir %{_prefix}/System/Library/Services/GSspell.service
168 %{_prefix}/System/Library/Services/GSspell.service/Resources
169 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
170
171 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
172
173 %files devel
174 %defattr(644,root,root,755)
175 %docdir %{_prefix}/System/Library/Documentation
176 %{_prefix}/System/Library/Documentation/Developer/Gui/Additions
177 %{_prefix}/System/Library/Documentation/Developer/Gui/General
178 %{_prefix}/System/Library/Documentation/Developer/Gui/ProgrammingManual
179 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
180 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
181 %{_prefix}/System/Library/Documentation/info/gnustep-gui.info*
182
183 %{_prefix}/System/Library/Headers/%{libcombo}/AppKit
184 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepGUI
185 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
186
187 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
188 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.075621 seconds and 4 git commands to generate.