]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.7.0
5 Release:        1
6 License:        GPL
7 Vendor:         The Seawood Project
8 Group:          Development/Tools
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 Patch0:         gstep-gui-headers.patch
11 URL:            http://www.gnustep.org/
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13 Conflicts:      gnustep-core
14 Requires:       gnustep-base
15
16 %description
17 It is a library of graphical user interface classes written completely
18 in the Objective-C language; the classes are based upon the OpenStep
19 specification as release by NeXT Software, Inc. The library does not
20 completely conform to the specification and has been enhanced in a
21 number of ways to take advantage of the GNU system. These classes
22 include graphical objects such as buttons, text fields, popup lists,
23 browser lists, and windows; there are also many associated classes for
24 handling events, colors, fonts, pasteboards and images.
25
26 Library combo is %{libcombo}. %{_buildblurb}
27
28 %description -l pl
29 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
30 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
31 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
32 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
33 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
34 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
35 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
36
37 %package devel
38 Summary:        GNUstep GUI headers and libs
39 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}, gnustep-base-devel
42 Conflicts:      gnustep-core
43
44 %description devel
45 Header files required to build applications against the GNUstep GUI
46 library. Library combo is %{libcombo}. %{_buildblurb}
47
48 %description devel -l pl
49 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
50 biblioteki GNUstep GUI.
51
52 %prep
53 %setup -q -n gstep-%{ver}/gui
54 %patch -p2
55
56 %build
57 if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
58    . %{_prefix}/GNUstep/Makefiles/GNUstep.sh 
59 fi
60 CFLAGS="%{rpmcflags}" ./configure --prefix=%{_prefix}/GNUstep --with-library-combo=%{libcombo}
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
66    . %{_prefix}/GNUstep/Makefiles/GNUstep.sh 
67 fi
68 install -d ${RPM_BUILD_ROOT}%{_prefix}/GNUstep/Library/Services
69
70 %{__make} install GNUSTEP_INSTALLATION_DIR=${RPM_BUILD_ROOT}%{_prefix}/GNUstep
71
72 cat > filelist.rpm.in << EOF
73 %defattr (-, bin, bin)
74 %doc ANNOUNCE COPYING* ChangeLog INSTALL NEWS NOTES README SUPPORT Version
75
76 %dir %{_prefix}/GNUstep/Library
77
78 %{_prefix}/GNUstep/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so.*
79 %{_prefix}/GNUstep/Libraries/Resources
80 %{_prefix}/GNUstep/Library/Model
81 %{_prefix}/GNUstep/Library/Services/*
82 %{_prefix}/GNUstep/Tools/make_services
83 %{_prefix}/GNUstep/Tools/set_show_service
84 # gpbs is now provided by xgps
85 #%{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/gpbs
86 %{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/make_services
87 %{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/set_show_service
88
89 EOF
90
91 cat > filelist-devel.rpm.in  << EOF
92 %defattr(-, root, root)
93 %{_prefix}/GNUstep/Headers/gnustep/gui
94 %{_prefix}/GNUstep/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so
95
96 EOF
97
98 sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist.rpm.in > filelist.rpm
99 sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist-devel.rpm.in > filelist-devel.rpm
100
101 # Don't worry about ld.so.conf on linux as gnustep-base should take care of it.
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files -f filelist.rpm
110 %defattr(644,root,root,755)
111
112 %files -f filelist-devel.rpm devel
113 %defattr(644,root,root,755)
This page took 0.104158 seconds and 4 git commands to generate.