]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- raw version.
[packages/gnustep-gui.git] / gnustep-gui.spec
1 # This package is not relocatable
2 %define ver     0.6.0
3 %define date    19990918
4 %define prefix  /usr
5 %define gsr     %{prefix}/GNUstep
6 %define libcombo gnu-gnu-gnu-xgps
7 Name:           gnustep-gui
8 Version:        %{ver}
9 Release:        1
10 Source:         ftp://ftp.gnustep.org/pub/gnustep/core/gstep-gui-%{ver}.tar.gz
11 #Source:        /cvs/gnustep-gui-%{ver}-%{date}.tar.gz
12 Patch:          gstep-gui-0.6.0-headers.patch
13 Copyright:      GPL
14 Group:          Development/Tools
15 Summary:        GNUstep GUI library package
16 Packager:       Christopher Seawood <cls@seawood.org>
17 Distribution:   Seawood's Random RPMS (%{_buildsym})
18 Vendor:         The Seawood Project
19 URL:            http://www.gnustep.org/
20 BuildRoot:      /var/tmp/build-%{name}
21 Conflicts:      gnustep-core
22 Requires:       gnustep-base
23
24 %description
25    It is a library of graphical user interface classes written
26 completely in the Objective-C language; the classes are based upon the
27 OpenStep specification as release by NeXT Software, Inc.  The library
28 does not completely conform to the specification and has been enhanced
29 in a number of ways to take advantage of the GNU system.  These classes
30 include graphical objects such as buttons, text fields, popup lists,
31 browser lists, and windows; there are also many associated classes for
32 handling events, colors, fonts, pasteboards and images.
33
34 Library combo is %{libcombo}.
35 %{_buildblurb}
36
37 %package devel
38 Summary: GNUstep GUI headers and libs.
39 Group: Development/Libraries
40 Requires: %{name} = %{ver}, gnustep-base-devel
41 Conflicts: gnustep-core
42
43 %description devel
44 Header files required to build applications against the GNUstep GUI library.
45 Library combo is %{libcombo}.
46 %{_buildblurb}
47
48 %prep
49 %setup -q -n gstep-%{ver}/gui
50 %patch -p2 -b .headers
51
52 %build
53 if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
54    . %{gsr}/Makefiles/GNUstep.sh 
55 fi
56 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{gsr} --with-library-combo=%{libcombo}
57 make
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
62    . %{gsr}/Makefiles/GNUstep.sh 
63 fi
64 mkdir -p ${RPM_BUILD_ROOT}%{gsr}/Library/Services
65
66 make install GNUSTEP_INSTALLATION_DIR=${RPM_BUILD_ROOT}%{gsr}
67
68 cat > filelist.rpm.in << EOF
69 %defattr (-, bin, bin)
70 %doc ANNOUNCE COPYING* ChangeLog INSTALL NEWS NOTES README SUPPORT Version
71
72 %dir %{gsr}/Library
73
74 %{gsr}/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so.*
75 %{gsr}/Libraries/Resources
76 %{gsr}/Library/Model
77 %{gsr}/Library/Services/*
78 %{gsr}/Tools/make_services
79 %{gsr}/Tools/set_show_service
80 # gpbs is now provided by xgps
81 #%{gsr}/Tools/GSARCH/GSOS/%{libcombo}/gpbs
82 %{gsr}/Tools/GSARCH/GSOS/%{libcombo}/make_services
83 %{gsr}/Tools/GSARCH/GSOS/%{libcombo}/set_show_service
84
85 EOF
86
87 cat > filelist-devel.rpm.in  << EOF
88 %defattr(-, bin, bin)
89 %{gsr}/Headers/gnustep/gui
90 %{gsr}/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so
91
92 EOF
93
94 sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist.rpm.in > filelist.rpm
95 sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist-devel.rpm.in > filelist-devel.rpm
96
97 # Don't worry about ld.so.conf on linux as gnustep-base should take care of it.
98
99 %ifos Linux
100 %post -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102 %endif
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files -f filelist.rpm
108 %files -f filelist-devel.rpm devel
109
110 %changelog
111 * Sat Sep 18 1999 Christopher Seawood <cls@seawood.org>
112 - Version 0.6.0
113 - Added headers patch
114
115 * Sat Aug 07 1999 Christopher Seawood <cls@seawood.org>
116 - Updated to cvs dawn_6 branch
117
118 * Sat Jun 26 1999 Christopher Seawood <cls@seawood.org>
119 - Split into separate rpm from gnustep-core
120 - Build from cvs snapshot
121 - Split into -devel, -libs & -zoneinfo packages
This page took 0.042485 seconds and 4 git commands to generate.