]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- more %%{__make} macros.
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Name:           gnustep-gui
3 Version:        0.6.0
4 Release:        1
5 License:        GPL
6 Vendor:         The Seawood Project
7 Group:          Development/Tools
8 Group(fr):      Development/Outils
9 Group(pl):      Programowanie/Narzêdzia
10 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
11 Source0:        /cvs/gnustep-gui-%{version}-%{date}.tar.gz
12 Patch0:         gstep-gui-headers.patch
13 URL:            http://www.gnustep.org/
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15 Conflicts:      gnustep-core
16 Requires:       gnustep-base
17
18 %description
19 It is a library of graphical user interface classes written completely
20 in the Objective-C language; the classes are based upon the OpenStep
21 specification as release by NeXT Software, Inc. The library does not
22 completely conform to the specification and has been enhanced in a
23 number of ways to take advantage of the GNU system. These classes
24 include graphical objects such as buttons, text fields, popup lists,
25 browser lists, and windows; there are also many associated classes for
26 handling events, colors, fonts, pasteboards and images.
27
28 Library combo is %{libcombo}. %{_buildblurb}
29
30 %package devel
31 Summary:        GNUstep GUI headers and libs.
32 Group:          Development/Libraries
33 Group(fr):      Development/Librairies
34 Group(pl):      Programowanie/Biblioteki
35 Requires:       %{name} = %{version}, gnustep-base-devel
36 Conflicts:      gnustep-core
37
38 %description devel
39 Header files required to build applications against the GNUstep GUI
40 library. Library combo is %{libcombo}. %{_buildblurb}
41
42 %prep
43 %setup -q -n gstep-%{ver}/gui
44 %patch -p2
45
46 %build
47 if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
48    . %{_prefix}/GNUstep/Makefiles/GNUstep.sh 
49 fi
50 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}/GNUstep --with-library-combo=%{libcombo}
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 if [ -z "$GNUSTEP_SYSTEM_ROOT" ]; then
56    . %{_prefix}/GNUstep/Makefiles/GNUstep.sh 
57 fi
58 install -d ${RPM_BUILD_ROOT}%{_prefix}/GNUstep/Library/Services
59
60 %{__make} install GNUSTEP_INSTALLATION_DIR=${RPM_BUILD_ROOT}%{_prefix}/GNUstep
61
62 cat > filelist.rpm.in << EOF
63 %defattr (-, bin, bin)
64 %doc ANNOUNCE COPYING* ChangeLog INSTALL NEWS NOTES README SUPPORT Version
65
66 %dir %{_prefix}/GNUstep/Library
67
68 %{_prefix}/GNUstep/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so.*
69 %{_prefix}/GNUstep/Libraries/Resources
70 %{_prefix}/GNUstep/Library/Model
71 %{_prefix}/GNUstep/Library/Services/*
72 %{_prefix}/GNUstep/Tools/make_services
73 %{_prefix}/GNUstep/Tools/set_show_service
74 # gpbs is now provided by xgps
75 #%{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/gpbs
76 %{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/make_services
77 %{_prefix}/GNUstep/Tools/GSARCH/GSOS/%{libcombo}/set_show_service
78
79 EOF
80
81 cat > filelist-devel.rpm.in  << EOF
82 %defattr(-, bin, bin)
83 %{_prefix}/GNUstep/Headers/gnustep/gui
84 %{_prefix}/GNUstep/Libraries/GSARCH/GSOS/%{libcombo}/lib*.so
85
86 EOF
87
88 sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist.rpm.in > filelist.rpm
89 sed -e "s|GSARCH|${GNUSTEP_HOST_CPU}|" -e "s|GSOS|${GNUSTEP_HOST_OS}|" < filelist-devel.rpm.in > filelist-devel.rpm
90
91 # Don't worry about ld.so.conf on linux as gnustep-base should take care of it.
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files -f filelist.rpm
100 %defattr(644,root,root,755)
101
102 %files -f filelist-devel.rpm devel
103 %defattr(644,root,root,755)
104
105 %changelog
106 * %{date} PLD Team <pld-list@pld.org.pl>
107 All persons listed below can be reached at <cvs_login>@pld.org.pl
108
109 $Log: gnustep-gui.spec,v $
110 Revision 1.5  2000-06-09 07:54:42  kloczek
111 - more %%{__make} macros.
112
113 Revision 1.4  2000/06/09 07:22:52  kloczek
114 - added using %%{__make} macro.
115
116 Revision 1.3  2000/05/20 13:37:50  kloczek
117 - spec adapterized and partialy rewrited.
118
119 * Sat Sep 18 1999 Christopher Seawood <cls@seawood.org>
120 - Version 0.6.0
121 - Added headers patch
122
123 * Sat Aug 07 1999 Christopher Seawood <cls@seawood.org>
124 - Updated to cvs dawn_6 branch
125
126 * Sat Jun 26 1999 Christopher Seawood <cls@seawood.org>
127 - Split into separate rpm from gnustep-core
128 - Build from cvs snapshot
129 - Split into -devel, -libs & -zoneinfo packages
This page took 0.038176 seconds and 4 git commands to generate.