]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- updated to 0.8.9
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.8.9
5 Release:        1
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  294b03e9c39e6f08c56ff66abade121e
10 Patch0:         %{name}-themes.patch
11 Patch1:         %{name}-target.patch
12 Patch2:         %{name}-nocompressdocs.patch
13 URL:            http://www.gnustep.org/
14 BuildRequires:  audiofile-devel
15 BuildRequires:  gcc-objc
16 BuildRequires:  gnustep-base-devel >= 1.7.3
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  zlib-devel
20 Requires:       gnustep-base >= 1.7.3
21 Conflicts:      gnustep-core
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _prefix         /usr/lib/GNUstep
25
26 %define         libcombo        gnu-gnu-gnu
27 %define         gsos            linux-gnu
28 %ifarch %{ix86}
29 %define         gscpu           ix86
30 %else
31 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
32 %define         gscpu           %{_target_cpu}
33 %endif
34
35 %description
36 It is a library of graphical user interface classes written completely
37 in the Objective-C language; the classes are based upon the OpenStep
38 specification as release by NeXT Software, Inc. The library does not
39 completely conform to the specification and has been enhanced in a
40 number of ways to take advantage of the GNU system. These classes
41 include graphical objects such as buttons, text fields, popup lists,
42 browser lists, and windows; there are also many associated classes for
43 handling events, colors, fonts, pasteboards and images.
44
45 %description -l pl
46 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
47 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
48 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
49 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
50 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
51 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
52 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
53
54 %package devel
55 Summary:        GNUstep GUI headers and libs
56 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}
59 Requires:       audiofile-devel
60 Requires:       gnustep-base-devel >= 1.7.3
61 Requires:       libjpeg-devel
62 Requires:       libtiff-devel
63 Conflicts:      gnustep-core
64
65 %description devel
66 Header files required to build applications against the GNUstep GUI
67 library.
68
69 %description devel -l pl
70 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
71 biblioteki GNUstep GUI.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch1 -p0
77 %patch2 -p1
78
79 %build
80 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
81 %configure
82
83 %{__make} \
84         messages=yes
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
89
90 %{__make} install \
91         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
92         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
93
94 # not (yet?) supported by rpm-compress-doc
95 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
96         -type f -a ! -name '*.html' | xargs gzip -9nf
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc ChangeLog
107
108 %docdir %{_prefix}/System/Library/Documentation
109 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
110 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
111
112 %dir %{_prefix}/System/Library/Bundles/TextConverters
113 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
114 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
115 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
116 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
117 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
118 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
119
120 %dir %{_prefix}/System/Library/ColorPickers
121 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
122 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
123 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
124 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
125 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
126 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
127 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
128 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
129 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
130 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
131 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
132 %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
133 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/%{gscpu}
134
135 %dir %{_prefix}/System/Applications/md5Digest.app
136 %dir %{_prefix}/System/Applications/md5Digest.app/Resources
137 %{_prefix}/System/Applications/md5Digest.app/Resources/*.desktop
138 %{_prefix}/System/Applications/md5Digest.app/Resources/*.plist
139 %attr(755,root,root) %{_prefix}/System/Applications/md5Digest.app/%{gscpu}
140 %attr(755,root,root) %{_prefix}/System/Applications/md5Digest.app/md5Digest
141
142 %{_prefix}/System/Library/Images/*
143 %{_prefix}/System/Library/KeyBindings/*.dict
144
145 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
146 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
147 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
148
149 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
150
151 %dir %{_prefix}/System/Library/PostScript
152 %{_prefix}/System/Library/PostScript/GSProlog.ps
153 %{_prefix}/System/Library/PostScript/Printers
154 %dir %{_prefix}/System/Library/PostScript/PPD
155 %{_prefix}/System/Library/PostScript/PPD/English.lproj
156 %lang(fr) %{_prefix}/System/Library/PostScript/PPD/French.lproj
157 %lang(de) %{_prefix}/System/Library/PostScript/PPD/German.lproj
158 %lang(it) %{_prefix}/System/Library/PostScript/PPD/Italian.lproj
159 %lang(es) %{_prefix}/System/Library/PostScript/PPD/Spanish.lproj
160 %lang(sv) %{_prefix}/System/Library/PostScript/PPD/Swedish.lproj
161
162 %dir %{_prefix}/System/Library/Services/GSspell.service
163 %{_prefix}/System/Library/Services/GSspell.service/Resources
164 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
165 %dir %{_prefix}/System/Library/Services/example.service
166 %{_prefix}/System/Library/Services/example.service/Resources
167 %attr(755,root,root) %{_prefix}/System/Library/Services/example.service/%{gscpu}
168
169 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %docdir %{_prefix}/System/Library/Documentation
174 %{_prefix}/System/Library/Documentation/Developer/Gui
175 %{_prefix}/System/Library/Documentation/User/Gui
176 %{_prefix}/System/Library/Documentation/man/man1/*
177
178 %{_prefix}/System/Library/Headers/%{libcombo}/AppKit
179 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepGUI
180 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
181
182 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
183 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.053424 seconds and 4 git commands to generate.