]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- up to 0.8.7
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.8.7
5 Release:        1
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  a3da917a6ac77917ddfaddf356a8a469
10 URL:            http://www.gnustep.org/
11 BuildRequires:  audiofile-devel
12 BuildRequires:  gcc-objc
13 BuildRequires:  gnustep-base-devel >= 1.7.0
14 BuildRequires:  libjpeg-devel
15 BuildRequires:  libtiff-devel
16 BuildRequires:  zlib-devel
17 Requires:       gnustep-base >= 1.7.0
18 Conflicts:      gnustep-core
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _prefix         /usr/lib/GNUstep
22
23 %define         libcombo        gnu-gnu-gnu
24 %define         gsos            linux-gnu
25 %ifarch %{ix86}
26 %define         gscpu           ix86
27 %else
28 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
29 %define         gscpu           %{_target_cpu}
30 %endif
31
32 %description
33 It is a library of graphical user interface classes written completely
34 in the Objective-C language; the classes are based upon the OpenStep
35 specification as release by NeXT Software, Inc. The library does not
36 completely conform to the specification and has been enhanced in a
37 number of ways to take advantage of the GNU system. These classes
38 include graphical objects such as buttons, text fields, popup lists,
39 browser lists, and windows; there are also many associated classes for
40 handling events, colors, fonts, pasteboards and images.
41
42 %description -l pl
43 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
44 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
45 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
46 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
47 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
48 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
49 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
50
51 %package devel
52 Summary:        GNUstep GUI headers and libs
53 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}
56 Requires:       audiofile-devel
57 Requires:       gnustep-base-devel >= 1.7.0
58 Requires:       libjpeg-devel
59 Requires:       libtiff-devel
60 Conflicts:      gnustep-core
61
62 %description devel
63 Header files required to build applications against the GNUstep GUI
64 library.
65
66 %description devel -l pl
67 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
68 biblioteki GNUstep GUI.
69
70 %prep
71 %setup -q
72
73 %build
74 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
75 %configure
76
77 %{__make} \
78         messages=yes
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
83
84 %{__make} install \
85         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
86         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
87
88 # not (yet?) supported by rpm-compress-doc
89 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
90         -type f -a ! -name '*.html' | xargs gzip -9nf
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc ChangeLog
101
102 %docdir %{_prefix}/System/Library/Documentation
103 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
104 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
105
106 %dir %{_prefix}/System/Library/Bundles/TextConverters
107 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
108 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
109 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
110 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
111 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
112 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
113
114 %dir %{_prefix}/System/Library/ColorPickers
115 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
116 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
117 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
118 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
119 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
120 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
121 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
122 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
123 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
124 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
125 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
126
127 %{_prefix}/System/Library/Images/*
128 %{_prefix}/System/Library/KeyBindings/*.dict
129
130 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
131 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
132 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
133
134 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
135
136 %dir %{_prefix}/System/Library/PostScript
137 %{_prefix}/System/Library/PostScript/GSProlog.ps
138 %{_prefix}/System/Library/PostScript/Printers
139 %dir %{_prefix}/System/Library/PostScript/PPD
140 %{_prefix}/System/Library/PostScript/PPD/English.lproj
141 %lang(fr) %{_prefix}/System/Library/PostScript/PPD/French.lproj
142 %lang(de) %{_prefix}/System/Library/PostScript/PPD/German.lproj
143 %lang(it) %{_prefix}/System/Library/PostScript/PPD/Italian.lproj
144 %lang(es) %{_prefix}/System/Library/PostScript/PPD/Spanish.lproj
145 %lang(sv) %{_prefix}/System/Library/PostScript/PPD/Swedish.lproj
146
147 %dir %{_prefix}/System/Library/Services/GSspell.service
148 %{_prefix}/System/Library/Services/GSspell.service/Resources
149 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
150 %dir %{_prefix}/System/Library/Services/example.service
151 %{_prefix}/System/Library/Services/example.service/Resources
152 %attr(755,root,root) %{_prefix}/System/Library/Services/example.service/%{gscpu}
153
154 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %docdir %{_prefix}/System/Library/Documentation
159 %{_prefix}/System/Library/Documentation/Developer/Gui/Manual
160 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
161 %{_prefix}/System/Library/Documentation/info/*.info*
162
163 %{_prefix}/System/Library/Headers/AppKit
164 %{_prefix}/System/Library/Headers/gnustep/gui
165
166 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
167 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.043681 seconds and 4 git commands to generate.