]> git.pld-linux.org Git - packages/gnustep-gui.git/blob - gnustep-gui.spec
- added segv patch, release 2
[packages/gnustep-gui.git] / gnustep-gui.spec
1 Summary:        GNUstep GUI library package
2 Summary(pl):    Biblioteka GNUstep GUI
3 Name:           gnustep-gui
4 Version:        0.9.1
5 Release:        2
6 License:        LGPL/GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
9 # Source0-md5:  327931f757d36cf135a7c3ce5f84e51d
10 Patch0:         %{name}-themes.patch
11 Patch2:         %{name}-nocompressdocs.patch
12 Patch3:         %{name}-segv.patch
13 URL:            http://www.gnustep.org/
14 BuildRequires:  audiofile-devel
15 BuildRequires:  gcc-objc
16 BuildRequires:  gnustep-base-devel >= 1.9.0
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  zlib-devel
20 Requires:       gnustep-base >= 1.9.0
21 Conflicts:      gnustep-core
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _prefix         /usr/lib/GNUstep
25
26 %define         libcombo        gnu-gnu-gnu
27 %define         gsos            linux-gnu
28 %ifarch %{ix86}
29 %define         gscpu           ix86
30 %else
31 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
32 %define         gscpu           %{_target_cpu}
33 %endif
34
35 %description
36 It is a library of graphical user interface classes written completely
37 in the Objective-C language; the classes are based upon the OpenStep
38 specification as release by NeXT Software, Inc. The library does not
39 completely conform to the specification and has been enhanced in a
40 number of ways to take advantage of the GNU system. These classes
41 include graphical objects such as buttons, text fields, popup lists,
42 browser lists, and windows; there are also many associated classes for
43 handling events, colors, fonts, pasteboards and images.
44
45 %description -l pl
46 To jest biblioteka klas graficznego interfejsu u¿ytkownika napisana w
47 Objective-C. Klasy bazuj± na specyfikacji OpenStep wypuszczonej przez
48 NeXT Software. Biblioteka nie jest ca³kowicie zgodna ze specyfikacj± i
49 zosta³a rozszerzona, aby wykorzystaæ mo¿liwo¶ci systemu GNU. Klasy
50 zawieraj± graficzne obiekty takie jak przyciski, pola tekstowe, listy
51 rozwijane, listy przewijane i okienka; jest tak¿e wiele klas do
52 obs³ugi zdarzeñ, kolorów, fontów i obrazków.
53
54 %package devel
55 Summary:        GNUstep GUI headers and libs
56 Summary(pl):    Pliki nag³ówkowe GNUstep GUI
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}
59 Requires:       audiofile-devel
60 Requires:       gnustep-base-devel >= 1.7.3
61 Requires:       libjpeg-devel
62 Requires:       libtiff-devel
63 Conflicts:      gnustep-core
64
65 %description devel
66 Header files required to build applications against the GNUstep GUI
67 library.
68
69 %description devel -l pl
70 Pliki nag³ówkowe potrzebne do budowania aplikacji korzystaj±cych z
71 biblioteki GNUstep GUI.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch2 -p1
77 %patch3 -p1
78
79 %build
80 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
81 %configure
82
83 %{__make} \
84         messages=yes
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
89
90 %{__make} install \
91         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
92         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
93 %{__make} install -C Documentation \
94         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
95         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT
96
97 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
98         -type f -name .cvsignore | xargs rm -f
99 # not (yet?) supported by rpm-compress-doc
100 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
101         -type f -a ! -name '*.html' | xargs gzip -9nf
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ChangeLog
112
113 %docdir %{_prefix}/System/Library/Documentation
114 %dir %{_prefix}/System/Library/Documentation/Developer/Gui
115 %{_prefix}/System/Library/Documentation/Developer/Gui/ReleaseNotes
116 %{_prefix}/System/Library/Documentation/User/Gui
117 %{_prefix}/System/Library/Documentation/man/man1/*
118
119 %dir %{_prefix}/System/Library/Bundles/TextConverters
120 %dir %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle
121 %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/Resources
122 %attr(755,root,root) %{_prefix}/System/Library/Bundles/TextConverters/RTFConverter.bundle/%{gscpu}
123 %dir %{_prefix}/System/Library/Bundles/libgmodel.bundle
124 %{_prefix}/System/Library/Bundles/libgmodel.bundle/Resources
125 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgmodel.bundle/%{gscpu}
126
127 %dir %{_prefix}/System/Library/ColorPickers
128 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle
129 %dir %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources
130 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.tiff
131 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/*.plist
132 %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/English.lproj
133 %lang(fr) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/French.lproj
134 %lang(sv) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/Resources/Swedish.lproj
135 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/StandardPicker.bundle/%{gscpu}
136 %dir %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle
137 %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/Resources
138 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/WheelPicker.bundle/%{gscpu}
139 %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/Resources
140 %attr(755,root,root) %{_prefix}/System/Library/ColorPickers/NamedPicker.bundle/%{gscpu}
141
142 %{_prefix}/System/Library/Images/*
143 %{_prefix}/System/Library/KeyBindings/*.dict
144
145 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-gui
146 %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/English.lproj
147 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-gui/Italian.lproj
148
149 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
150
151 %dir %{_prefix}/System/Library/PostScript
152 %{_prefix}/System/Library/PostScript/GSProlog.ps
153 %{_prefix}/System/Library/PostScript/Printers
154 %dir %{_prefix}/System/Library/PostScript/PPD
155 %{_prefix}/System/Library/PostScript/PPD/English.lproj
156 %lang(fr) %{_prefix}/System/Library/PostScript/PPD/French.lproj
157 %lang(de) %{_prefix}/System/Library/PostScript/PPD/German.lproj
158 %lang(it) %{_prefix}/System/Library/PostScript/PPD/Italian.lproj
159 %lang(es) %{_prefix}/System/Library/PostScript/PPD/Spanish.lproj
160 %lang(sv) %{_prefix}/System/Library/PostScript/PPD/Swedish.lproj
161
162 %dir %{_prefix}/System/Library/Services/GSspell.service
163 %{_prefix}/System/Library/Services/GSspell.service/Resources
164 %attr(755,root,root) %{_prefix}/System/Library/Services/GSspell.service/%{gscpu}
165
166 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %docdir %{_prefix}/System/Library/Documentation
171 %{_prefix}/System/Library/Documentation/Developer/Gui/Additions
172 %{_prefix}/System/Library/Documentation/Developer/Gui/Reference
173
174 %{_prefix}/System/Library/Headers/%{libcombo}/AppKit
175 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepGUI
176 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep/gui
177
178 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
179 %{_prefix}/System/Library/Makefiles/Additional/gui.make
This page took 0.778269 seconds and 3 git commands to generate.