]> git.pld-linux.org Git - packages/gnustep-base.git/blob - gnustep-base.spec
cd372e867fd3a8b6c7244bed55e076c826960eb6
[packages/gnustep-base.git] / gnustep-base.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't generate documentation (bootstrap build w/o gnustep-base)
4 #
5 Summary:        GNUstep Base library package
6 Summary(pl):    Podstawowa biblioteka GNUstep
7 Name:           gnustep-base
8 Version:        1.9.2
9 Release:        1
10 License:        LGPL/GPL
11 Group:          Libraries
12 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
13 # Source0-md5:  b1fe102145f32aa05ebff41ffd7b9fd0
14 Source1:        %{name}.init
15 Patch0:         %{name}-link.patch
16 URL:            http://www.gnustep.org/
17 BuildRequires:  ffcall-devel
18 BuildRequires:  gcc-objc
19 BuildRequires:  gmp-devel
20 %{?with_doc:BuildRequires:      gnustep-base-devel >= 1.8.0}
21 %{?with_doc:BuildRequires:      docbook-dtd41-sgml}
22 BuildRequires:  gnustep-make-devel >= 1.8.0
23 BuildRequires:  libxml2-devel >= 2.3.0
24 BuildRequires:  openssl-devel >= 0.9.7d
25 BuildRequires:  zlib-devel
26 Requires(post,preun):   grep
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(post,postun):  /sbin/ldconfig
29 Requires:       gnustep-make >= 1.8.0
30 # with gdomap in /etc/services
31 Requires:       setup >= 2.4.3
32 Conflicts:      gnustep-core
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _prefix         /usr/%{_lib}/GNUstep
36
37 %define         libcombo        gnu-gnu-gnu
38 %define         gsos            linux-gnu
39 %ifarch %{ix86}
40 %define         gscpu           ix86
41 %else
42 %ifarch amd64
43 %define         gscpu           x86_64
44 %else
45 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
46 %define         gscpu           %{_target_cpu}
47 %endif
48 %endif
49
50 %description
51 The GNUstep Base Library is a library of general-purpose,
52 non-graphical Objective C objects. For example, it includes classes
53 for strings, object collections, byte streams, typed coders,
54 invocations, notifications, notification dispatchers, moments in time,
55 network ports, remote object messaging support (distributed objects),
56 event loops, and random number generators.
57
58 %description -l pl
59 Podstawowa biblioteka GNUstep jest bibliotek± innych ni¿ graficzne
60 obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
61 stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
62 sieci, obiektów rozproszonych, pêtli zdarzeñ, generatorów liczb
63 losowych.
64
65 %package devel
66 Summary:        GNUstep Base headers
67 Summary(pl):    Pliki nag³ówkowe podstawowej biblioteki GNUstep
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       ffcall-devel
71 Requires:       gcc-objc
72 Requires:       gmp-devel
73 Requires:       gnustep-make-devel >= 1.8.0
74 Requires:       libxml2-devel
75 Requires:       zlib-devel
76 Conflicts:      gnustep-core
77
78 %description devel
79 Header files required to build applications against the GNUstep Base
80 library.
81
82 %description devel -l pl
83 Pliki nag³ówkowe potrzebne do budowania aplikacji u¿ywaj±cych
84 podstawowej biblioteki GNUstep.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
92 # gnustep can use one of 3 ways of getting argc,argv,env:
93 # - /proc (default on Linux) - gnustep programs won't run in procless system
94 # - fake-main hack (main is secretly renamed and wrapped)
95 # - pass-arguments (program must call NSProcessInfo initialize)
96 %configure \
97         --enable-pass-arguments
98
99 %{__make} \
100         messages=yes
101
102 %if %{with doc}
103 # requires already installed gnustep-base
104 %{__make} -C Documentation
105 %{__make} -C Documentation/manual
106 %endif
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
111 %{__make} install \
112         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT \
113         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
114
115 %if %{with doc}
116 %{__make} -C Documentation install \
117         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
118 %{__make} -C Documentation/manual install \
119         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
120 # not (yet?) supported by rpm-compress-doc
121 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
122         -type f -a ! -name '*.html' -a ! -name '*.gz' | xargs gzip -9nf
123 %endif
124
125 install -d $RPM_BUILD_ROOT%{_initrddir}
126 sed -e "s!@TOOLSARCHDIR@!%{_prefix}/System/Tools/%{gscpu}/%{gsos}!" %{SOURCE1} \
127         > $RPM_BUILD_ROOT%{_initrddir}/gnustep
128
129 echo 'GMT' > $RPM_BUILD_ROOT%{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 umask 022
136 if ! grep -q '%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}' \
137     /etc/ld.so.conf ; then
138         echo "%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}" >> /etc/ld.so.conf
139 fi
140 /sbin/ldconfig
141 /sbin/chkconfig --add gnustep
142 if [ -f /var/lock/subsys/gnustep ]; then
143         /etc/rc.d/init.d/gnustep restart 1>&2
144 else
145         echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
146 fi
147
148 %preun
149 if [ "$1" = "0" ]; then
150         if [ -f /var/lock/subsys/gnustep ]; then
151                 /etc/rc.d/init.d/gnustep stop 1>&2
152         fi
153         /sbin/chkconfig --del gnustep
154 fi
155
156 %postun
157 if [ "$1" = "0" ]; then
158         umask 022
159         grep -v "^%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
160                 > /etc/ld.so.conf.tmp
161         mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
162         /sbin/ldconfig
163 fi
164
165 %triggerpostun -- gnustep-base < 1.7.0
166 umask 022
167 grep -v "^%{_prefix}/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
168         > /etc/ld.so.conf.tmp
169 mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
170 /sbin/ldconfig
171
172 %files
173 %defattr(644,root,root,755)
174 %doc ChangeLog*
175 %attr(754,root,root) %{_initrddir}/gnustep
176
177 %dir %{_prefix}/System/Library/Bundles/SSL.bundle
178 %{_prefix}/System/Library/Bundles/SSL.bundle/Resources
179 %attr(755,root,root) %{_prefix}/System/Library/Bundles/SSL.bundle/%{gscpu}
180
181 %docdir %{_prefix}/System/Library/Documentation
182 %if %{with doc}
183 %dir %{_prefix}/System/Library/Documentation/Developer/Base
184 %{_prefix}/System/Library/Documentation/Developer/Base/ReleaseNotes
185 %endif
186 %dir %{_prefix}/System/Library/Documentation/man/man8
187 %{_prefix}/System/Library/Documentation/man/man1/*.1*
188 %{_prefix}/System/Library/Documentation/man/man8/*.8*
189
190 %dir %{_prefix}/System/Library/DTDs
191 %{_prefix}/System/Library/DTDs/*.dtd
192
193 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base
194 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/English.lproj
195 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/French.lproj
196 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/German.lproj
197 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Italian.lproj
198 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/TraditionalChinese.lproj
199 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages
200 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Locale.*
201 %lang(nl) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
202 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/English
203 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/French
204 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/German
205 %lang(hu) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
206 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Italian
207 %lang(ru) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Russian
208 %lang(sk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Slovak
209 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/TraditionalChinese
210 %lang(uk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/UkraineRussian
211 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSCharacterSets
212 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones
213 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUmakefile
214 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUstep_zones
215 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/README
216 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/abbreviations
217 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/regions
218 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones
219 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/*.m
220 %config(noreplace) %verify(not size mtime md5) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
221
222 %dir %{_prefix}/System/Library/Libraries/%{gscpu}
223 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}
224 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}
225 %attr(755,root,root) %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
226
227 %dir %{_prefix}/System/Tools/%{gscpu}
228 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}
229 # is suid necessary here??? it runs as daemon...
230 #%attr(4755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
231 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
232 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}
233 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
234
235 %files devel
236 %defattr(644,root,root,755)
237 %if %{with doc}
238 %docdir %{_prefix}/System/Library/Documentation
239 %{_prefix}/System/Library/Documentation/Developer/Base/General
240 %{_prefix}/System/Library/Documentation/Developer/Base/ProgrammingManual
241 %{_prefix}/System/Library/Documentation/Developer/Base/Reference
242 %{_prefix}/System/Library/Documentation/Developer/BaseAdditions
243 %{_prefix}/System/Library/Documentation/Developer/CodingStandards
244 %{_prefix}/System/Library/Documentation/info/*.info*
245 %endif
246
247 %{_prefix}/System/Library/Headers/%{libcombo}/Foundation
248 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepBase
249 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep
250 %{_prefix}/System/Library/Headers/%{libcombo}/%{gscpu}/%{gsos}/*.h
251
252 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
253 %dir %{_prefix}/System/Library/Makefiles/Additional
254 %{_prefix}/System/Library/Makefiles/Additional/base.make
This page took 0.032482 seconds and 2 git commands to generate.