]> git.pld-linux.org Git - packages/gnustep-base.git/blob - gnustep-base.spec
- cosmetics
[packages/gnustep-base.git] / gnustep-base.spec
1 #
2 # Conditional build:
3 # _without_doc  - don't generate documentation (bootstrap build w/o gnustep-base)
4 #
5 Summary:        GNUstep Base library package
6 Summary(pl):    Podstawowa biblioteka GNUstep
7 Name:           gnustep-base
8 Version:        1.7.2
9 Release:        2
10 License:        LGPL/GPL
11 Group:          Libraries
12 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
13 # Source0-md5:  bc1b74be8544ffe5fe4bf57a8df382c2
14 Source1:        %{name}.init
15 Patch0:         %{name}-link.patch
16 URL:            http://www.gnustep.org/
17 BuildRequires:  ffcall-devel
18 BuildRequires:  gcc-objc
19 BuildRequires:  gmp-devel
20 %{!?_without_doc:BuildRequires: gnustep-base-devel >= 1.7.1}
21 %{!?_without_doc:BuildRequires: docbook-dtd41-sgml}
22 BuildRequires:  gnustep-make-devel >= 1.7.1
23 BuildRequires:  libxml2-devel >= 2.3.0
24 BuildRequires:  openssl-devel >= 0.9.7
25 BuildRequires:  zlib-devel
26 Requires(post,preun):   grep
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(post,postun):  /sbin/ldconfig
29 Requires:       gnustep-make >= 1.7.1
30 # with gdomap in /etc/services
31 Requires:       setup >= 2.4.3
32 Conflicts:      gnustep-core
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _prefix         /usr/lib/GNUstep
36
37 %define         libcombo        gnu-gnu-gnu
38 %define         gsos            linux-gnu
39 %ifarch %{ix86}
40 %define         gscpu           ix86
41 %else
42 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
43 %define         gscpu           %{_target_cpu}
44 %endif
45
46 %description
47 The GNUstep Base Library is a library of general-purpose,
48 non-graphical Objective C objects. For example, it includes classes
49 for strings, object collections, byte streams, typed coders,
50 invocations, notifications, notification dispatchers, moments in time,
51 network ports, remote object messaging support (distributed objects),
52 event loops, and random number generators.
53
54 %description -l pl
55 Podstawowa biblioteka GNUstep jest bibliotek± innych ni¿ graficzne
56 obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
57 stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
58 sieci, obiektów rozproszonych, pêtli zdarzeñ, generatorów liczb
59 losowych.
60
61 %package devel
62 Summary:        GNUstep Base headers
63 Summary(pl):    Pliki nag³ówkowe podstawowej biblioteki GNUstep
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}
66 Requires:       ffcall-devel
67 Requires:       gcc-objc
68 Requires:       gmp-devel
69 Requires:       gnustep-make-devel >= 1.7.1
70 Requires:       libxml2-devel
71 Requires:       zlib-devel
72 Conflicts:      gnustep-core
73
74 %description devel
75 Header files required to build applications against the GNUstep Base
76 library.
77
78 %description devel -l pl
79 Pliki nag³ówkowe potrzebne do budowania aplikacji u¿ywaj±cych
80 podstawowej biblioteki GNUstep.
81
82 %prep
83 %setup -q
84 %patch -p1
85
86 %build
87 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
88 %configure
89
90 %{__make} \
91         messages=yes
92
93 %if %{?_without_doc:0}%{!?_without_doc:1}
94 # requires already installed gnustep-base
95 %{__make} -C Documentation
96 %{__make} -C Documentation/manual
97 %endif
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
102 %{__make} install \
103         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT \
104         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
105
106 %if %{?_without_doc:0}%{!?_without_doc:1}
107 %{__make} -C Documentation install \
108         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
109 %{__make} -C Documentation/manual install \
110         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
111 # not (yet?) supported by rpm-compress-doc
112 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
113         -type f -a ! -name '*.html' -a ! -name '*.gz' | xargs gzip -9nf
114 %endif
115
116 install -d $RPM_BUILD_ROOT%{_initrddir}
117 sed -e "s!@TOOLSARCHDIR@!%{_prefix}/System/Tools/%{gscpu}/%{gsos}!" %{SOURCE1} \
118         > $RPM_BUILD_ROOT%{_initrddir}/gnustep
119
120 echo 'GMT' > $RPM_BUILD_ROOT%{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 umask 022
127 if ! grep -q '%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}' \
128     /etc/ld.so.conf ; then
129         echo "%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}" >> /etc/ld.so.conf
130 fi
131 /sbin/ldconfig
132 /sbin/chkconfig --add gnustep
133 if [ -f /var/lock/subsys/gnustep ]; then
134         /etc/rc.d/init.d/gnustep restart 1>&2
135 else
136         echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
137 fi
138
139 %preun
140 if [ "$1" = "0" ]; then
141         if [ -f /var/lock/subsys/gnustep ]; then
142                 /etc/rc.d/init.d/gnustep stop 1>&2
143         fi
144         /sbin/chkconfig --del gnustep
145 fi
146
147 %postun
148 if [ "$1" = "0" ]; then
149         umask 022
150         grep -v "^%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
151                 > /etc/ld.so.conf.tmp
152         mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
153         /sbin/ldconfig
154 fi
155
156 %triggerpostun -- gnustep-base < 1.7.0
157 umask 022
158 grep -v "^%{_prefix}/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
159         > /etc/ld.so.conf.tmp
160 mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
161 /sbin/ldconfig
162
163 %files
164 %defattr(644,root,root,755)
165 %doc ChangeLog*
166 %attr(754,root,root) %{_initrddir}/gnustep
167
168 %dir %{_prefix}/System/Library/Bundles/SSL.bundle
169 %{_prefix}/System/Library/Bundles/SSL.bundle/Resources
170 %attr(755,root,root) %{_prefix}/System/Library/Bundles/SSL.bundle/%{gscpu}
171
172 %{_prefix}/System/Library/DocTemplates/*.gsdoc
173
174 %docdir %{_prefix}/System/Library/Documentation
175 %if 0%{!?_without_doc:1}
176 %dir %{_prefix}/System/Library/Documentation/Developer/Base
177 %{_prefix}/System/Library/Documentation/Developer/Base/ReleaseNotes
178 %endif
179 %dir %{_prefix}/System/Library/Documentation/man/man1
180 %dir %{_prefix}/System/Library/Documentation/man/man8
181 %{_prefix}/System/Library/Documentation/man/man1/*.1*
182 %{_prefix}/System/Library/Documentation/man/man8/*.8*
183
184 %dir %{_prefix}/System/Library/DTDs
185 %{_prefix}/System/Library/DTDs/*.dtd
186
187 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base
188 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/English.lproj
189 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/French.lproj
190 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/German.lproj
191 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Italian.lproj
192 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages
193 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Locale.*
194 %lang(nl) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
195 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/English
196 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/French
197 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/German
198 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Italian
199 %lang(ru) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Russian
200 %lang(sk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Slovak
201 %lang(uk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/UkraineRussian
202 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSCharacterSets
203 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones
204 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUmakefile
205 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUstep_zones
206 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/README
207 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/abbreviations
208 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/regions
209 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones
210 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/*.m
211 %config(noreplace) %verify(not size mtime md5) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
212
213 %dir %{_prefix}/System/Library/Libraries/%{gscpu}
214 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}
215 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}
216 %attr(755,root,root) %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
217
218 %dir %{_prefix}/System/Tools/%{gscpu}
219 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}
220 # is suid necessary here??? it runs as daemon...
221 #%attr(4755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
222 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
223 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}
224 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
225
226 %files devel
227 %defattr(644,root,root,755)
228 %if 0%{!?_without_doc:1}
229 %docdir %{_prefix}/System/Library/Documentation
230 %{_prefix}/System/Library/Documentation/Developer/Base/ProgrammingManual
231 %{_prefix}/System/Library/Documentation/Developer/Base/Reference
232 %{_prefix}/System/Library/Documentation/Developer/BaseAdditions
233 %{_prefix}/System/Library/Documentation/Developer/CodingStandards
234 %{_prefix}/System/Library/Documentation/info/*.info*
235 %endif
236
237 %{_prefix}/System/Library/Headers/Foundation
238 %{_prefix}/System/Library/Headers/gnustep
239 %{_prefix}/System/Library/Headers/%{gscpu}
240
241 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
242 %dir %{_prefix}/System/Library/Makefiles/Additional
243 %{_prefix}/System/Library/Makefiles/Additional/base.make
This page took 0.065488 seconds and 3 git commands to generate.