]> git.pld-linux.org Git - packages/gnustep-base.git/blob - gnustep-base.spec
- updated to 1.13.0
[packages/gnustep-base.git] / gnustep-base.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't generate documentation (bootstrap build w/o gnustep-base)
4 #
5 Summary:        GNUstep Base library package
6 Summary(pl):    Podstawowa biblioteka GNUstep
7 Name:           gnustep-base
8 Version:        1.13.0
9 Release:        1
10 License:        LGPL/GPL
11 Group:          Libraries
12 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
13 # Source0-md5:  edd01516ba49915150f030848efc0baf
14 Source1:        %{name}.init
15 Source2:        %{name}.sysconfig
16 Patch0:         %{name}-pass-arguments.patch
17 URL:            http://www.gnustep.org/
18 %{?with_doc:BuildRequires:      docbook-dtd41-sgml}
19 BuildRequires:  ffcall-devel
20 BuildRequires:  gcc-objc
21 BuildRequires:  gmp-devel
22 %{?with_doc:BuildRequires:      gnustep-base-devel >= 1.8.0}
23 BuildRequires:  gnustep-make-devel >= 1.11.2
24 BuildRequires:  libxml2-devel >= 2.3.0
25 BuildRequires:  openssl-devel >= 0.9.7d
26 BuildRequires:  zlib-devel
27 Requires(post): /sbin/ldconfig
28 Requires(post,preun):   /sbin/chkconfig
29 Requires(triggerpostun):        sed >= 4.0
30 Requires:       glibc >= 6:2.3.5-7.6
31 Requires:       gnustep-make >= 1.11.2
32 # with gdomap in /etc/services
33 Requires:       setup >= 2.4.3
34 Conflicts:      gnustep-core
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _prefix         /usr/%{_lib}/GNUstep
38
39 %description
40 The GNUstep Base Library is a library of general-purpose,
41 non-graphical Objective C objects. For example, it includes classes
42 for strings, object collections, byte streams, typed coders,
43 invocations, notifications, notification dispatchers, moments in time,
44 network ports, remote object messaging support (distributed objects),
45 event loops, and random number generators.
46
47 %description -l pl
48 Podstawowa biblioteka GNUstep jest bibliotek± innych ni¿ graficzne
49 obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
50 stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
51 sieci, obiektów rozproszonych, pêtli zdarzeñ, generatorów liczb
52 losowych.
53
54 %package devel
55 Summary:        GNUstep Base headers
56 Summary(pl):    Pliki nag³ówkowe podstawowej biblioteki GNUstep
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       ffcall-devel
60 Requires:       gcc-objc
61 Requires:       gmp-devel
62 Requires:       gnustep-make-devel >= 1.11.2
63 Requires:       libxml2-devel
64 Requires:       zlib-devel
65 Conflicts:      gnustep-core
66
67 %description devel
68 Header files required to build applications against the GNUstep Base
69 library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne do budowania aplikacji u¿ywaj±cych
73 podstawowej biblioteki GNUstep.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78
79 %build
80 # don't assume that GNUstep.sh is imported in environment
81 export GNUSTEP_MAKEFILES=%{_prefix}/System/Library/Makefiles
82 export GNUSTEP_FLATTENED=yes
83
84 # gnustep can use one of 3 ways of getting argc,argv,env:
85 # - /proc (default on Linux) - gnustep programs won't run in procless system
86 # - fake-main hack (main is secretly renamed and wrapped)
87 # - pass-arguments (program must call NSProcessInfo initialize)
88 %configure \
89         --enable-pass-arguments
90
91 # fake GUI_MAKE_LOADED to avoid linking with gnustep-gui
92 %{__make} \
93         GUI_MAKE_LOADED=yes \
94         messages=yes
95
96 %if %{with doc}
97 export LD_LIBRARY_PATH=`pwd`/Source/obj
98 # requires already installed gnustep-base
99 %{__make} -C Documentation
100 %{__make} -C Documentation/manual
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 export GNUSTEP_MAKEFILES=%{_prefix}/System/Library/Makefiles
106 export GNUSTEP_FLATTENED=yes
107
108 %{__make} install \
109         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT \
110         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
111
112 %if %{with doc}
113 %{__make} -C Documentation install \
114         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
115 %{__make} -C Documentation/manual install \
116         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
117 # not (yet?) supported by rpm-compress-doc
118 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
119         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
120 %endif
121
122 install -d $RPM_BUILD_ROOT%{_initrddir}
123 sed -e "s!@TOOLSARCHDIR@!%{_prefix}/System/Tools/!" %{SOURCE1} \
124         > $RPM_BUILD_ROOT%{_initrddir}/gnustep
125
126 install -d $RPM_BUILD_ROOT/etc/sysconfig
127 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/gnustep
128
129 echo 'GMT' > $RPM_BUILD_ROOT%{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
130
131 install -d $RPM_BUILD_ROOT/etc/ld.so.conf.d
132 echo '%{_prefix}/System/Library/Libraries' > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{name}.conf
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post
138 /sbin/ldconfig
139 /sbin/chkconfig --add gnustep
140 if [ -f /var/lock/subsys/gnustep ]; then
141         /etc/rc.d/init.d/gnustep restart 1>&2
142 else
143         echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
144 fi
145
146 %preun
147 if [ "$1" = "0" ]; then
148         if [ -f /var/lock/subsys/gnustep ]; then
149                 /etc/rc.d/init.d/gnustep stop 1>&2
150         fi
151         /sbin/chkconfig --del gnustep
152 fi
153
154 %postun -p /sbin/ldconfig
155
156 %triggerpostun -- %{name} < 1.11.0-1.1
157 sed -i -e "/^%(echo %{_prefix}/Libraries/ | sed -e 's,/,\\/,g')$/d" /etc/ld.so.conf
158
159 %files
160 %defattr(644,root,root,755)
161 %doc ChangeLog*
162 /etc/ld.so.conf.d/%{name}.conf
163 %attr(754,root,root) %{_initrddir}/gnustep
164 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/gnustep
165
166 %dir %{_prefix}/System/Library/Bundles/SSL.bundle
167 %attr(755,root,root) %{_prefix}/System/Library/Bundles/SSL.bundle/SSL
168 %{_prefix}/System/Library/Bundles/SSL.bundle/Resources
169
170 %docdir %{_prefix}/System/Library/Documentation
171 %if %{with doc}
172 %{_prefix}/System/Library/Documentation/*.jpg
173 %{_prefix}/System/Library/Documentation/index.html
174 %{_prefix}/System/Library/Documentation/style.css
175 %dir %{_prefix}/System/Library/Documentation/Developer/Base
176 %{_prefix}/System/Library/Documentation/Developer/Base/ReleaseNotes
177 %endif
178 %dir %{_prefix}/System/Library/Documentation/man/man8
179 %{_prefix}/System/Library/Documentation/man/man1/*.1*
180 %{_prefix}/System/Library/Documentation/man/man8/*.8*
181
182 %dir %{_prefix}/System/Library/DTDs
183 %{_prefix}/System/Library/DTDs/*.dtd
184 %{_prefix}/System/Library/DTDs/*.rnc
185
186 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base
187 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/*.plist
188 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/English.lproj
189 %lang(eo) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Esperanto.lproj
190 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/French.lproj
191 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/German.lproj
192 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Italian.lproj
193 %lang(ko) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Korean.lproj
194 %lang(es) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Spanish.lproj
195 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/TraditionalChinese.lproj
196 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages
197 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Locale.*
198 %lang(nl) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
199 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/English
200 %lang(eo) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Esperanto
201 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/French
202 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/German
203 %lang(hu) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
204 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Italian
205 %lang(ko) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Korean
206 %lang(ru) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Russian
207 %lang(sk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Slovak
208 %lang(es) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Spanish
209 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/TraditionalChinese
210 %lang(uk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Ukrainian
211 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones
212 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUmakefile
213 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUstep_zones
214 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/README
215 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/abbreviations
216 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/regions
217 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones
218 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/*.m
219 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/*.plist
220 %config(noreplace) %verify(not md5 mtime size) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
221
222 %attr(755,root,root) %{_prefix}/System/Library/Libraries/lib*.so.*
223
224 # is suid necessary here??? it runs as daemon...
225 #%attr(4755,root,root) %{_prefix}/System/Tools/gdomap
226 %dir %{_prefix}/System/Tools
227 %attr(755,root,root) %{_prefix}/System/Tools/*
228
229 %files devel
230 %defattr(644,root,root,755)
231 %if %{with doc}
232 %docdir %{_prefix}/System/Library/Documentation
233 %{_prefix}/System/Library/Documentation/Developer/Base/General
234 %{_prefix}/System/Library/Documentation/Developer/Base/ProgrammingManual
235 %{_prefix}/System/Library/Documentation/Developer/Base/Reference
236 %{_prefix}/System/Library/Documentation/Developer/BaseAdditions
237 %{_prefix}/System/Library/Documentation/Developer/CodingStandards
238 %{_prefix}/System/Library/Documentation/Developer/Tools
239 %{_prefix}/System/Library/Documentation/info/*.info*
240 %endif
241
242 %{_prefix}/System/Library/Headers/Foundation
243 %{_prefix}/System/Library/Headers/GNUstepBase
244 %{_prefix}/System/Library/Headers/gnustep
245 %{_prefix}/System/Library/Headers/*.h
246
247 %{_prefix}/System/Library/Libraries/lib*.so
248 %dir %{_prefix}/System/Library/Makefiles/Additional
249 %{_prefix}/System/Library/Makefiles/Additional/base.make
This page took 0.060426 seconds and 3 git commands to generate.