]> git.pld-linux.org Git - packages/gnustep-base.git/blob - gnustep-base.spec
- release 1
[packages/gnustep-base.git] / gnustep-base.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't generate documentation (bootstrap build w/o gnustep-base)
4 #
5 Summary:        GNUstep Base library package
6 Summary(pl):    Podstawowa biblioteka GNUstep
7 Name:           gnustep-base
8 Version:        1.9.2
9 Release:        1
10 License:        LGPL/GPL
11 Group:          Libraries
12 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
13 # Source0-md5:  b1fe102145f32aa05ebff41ffd7b9fd0
14 Source1:        %{name}.init
15 Patch0:         %{name}-link.patch
16 URL:            http://www.gnustep.org/
17 BuildRequires:  ffcall-devel
18 BuildRequires:  gcc-objc
19 BuildRequires:  gmp-devel
20 %{?with_doc:BuildRequires:      gnustep-base-devel >= 1.8.0}
21 %{?with_doc:BuildRequires:      docbook-dtd41-sgml}
22 BuildRequires:  gnustep-make-devel >= 1.8.0
23 BuildRequires:  libxml2-devel >= 2.3.0
24 BuildRequires:  openssl-devel >= 0.9.7d
25 BuildRequires:  zlib-devel
26 Requires(post,preun):   grep
27 Requires(post,preun):   /sbin/chkconfig
28 Requires(post,postun):  /sbin/ldconfig
29 Requires:       gnustep-make >= 1.8.0
30 # with gdomap in /etc/services
31 Requires:       setup >= 2.4.3
32 Conflicts:      gnustep-core
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _prefix         /usr/%{_lib}/GNUstep
36
37 %define         libcombo        gnu-gnu-gnu
38 %define         gsos            linux-gnu
39 %ifarch %{ix86}
40 %define         gscpu           ix86
41 %else
42 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
43 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
44 %endif
45
46 %description
47 The GNUstep Base Library is a library of general-purpose,
48 non-graphical Objective C objects. For example, it includes classes
49 for strings, object collections, byte streams, typed coders,
50 invocations, notifications, notification dispatchers, moments in time,
51 network ports, remote object messaging support (distributed objects),
52 event loops, and random number generators.
53
54 %description -l pl
55 Podstawowa biblioteka GNUstep jest bibliotek± innych ni¿ graficzne
56 obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
57 stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
58 sieci, obiektów rozproszonych, pêtli zdarzeñ, generatorów liczb
59 losowych.
60
61 %package devel
62 Summary:        GNUstep Base headers
63 Summary(pl):    Pliki nag³ówkowe podstawowej biblioteki GNUstep
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       ffcall-devel
67 Requires:       gcc-objc
68 Requires:       gmp-devel
69 Requires:       gnustep-make-devel >= 1.8.0
70 Requires:       libxml2-devel
71 Requires:       zlib-devel
72 Conflicts:      gnustep-core
73
74 %description devel
75 Header files required to build applications against the GNUstep Base
76 library.
77
78 %description devel -l pl
79 Pliki nag³ówkowe potrzebne do budowania aplikacji u¿ywaj±cych
80 podstawowej biblioteki GNUstep.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85
86 %build
87 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
88 # gnustep can use one of 3 ways of getting argc,argv,env:
89 # - /proc (default on Linux) - gnustep programs won't run in procless system
90 # - fake-main hack (main is secretly renamed and wrapped)
91 # - pass-arguments (program must call NSProcessInfo initialize)
92 %configure \
93         --enable-pass-arguments
94
95 %{__make} \
96         messages=yes
97
98 %if %{with doc}
99 # requires already installed gnustep-base
100 %{__make} -C Documentation
101 %{__make} -C Documentation/manual
102 %endif
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
107 %{__make} install \
108         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT \
109         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
110
111 %if %{with doc}
112 %{__make} -C Documentation install \
113         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
114 %{__make} -C Documentation/manual install \
115         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
116 # not (yet?) supported by rpm-compress-doc
117 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
118         -type f -a ! -name '*.html' -a ! -name '*.gz' | xargs gzip -9nf
119 %endif
120
121 install -d $RPM_BUILD_ROOT%{_initrddir}
122 sed -e "s!@TOOLSARCHDIR@!%{_prefix}/System/Tools/%{gscpu}/%{gsos}!" %{SOURCE1} \
123         > $RPM_BUILD_ROOT%{_initrddir}/gnustep
124
125 echo 'GMT' > $RPM_BUILD_ROOT%{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post
131 umask 022
132 if ! grep -q '%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}' \
133     /etc/ld.so.conf ; then
134         echo "%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}" >> /etc/ld.so.conf
135 fi
136 /sbin/ldconfig
137 /sbin/chkconfig --add gnustep
138 if [ -f /var/lock/subsys/gnustep ]; then
139         /etc/rc.d/init.d/gnustep restart 1>&2
140 else
141         echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
142 fi
143
144 %preun
145 if [ "$1" = "0" ]; then
146         if [ -f /var/lock/subsys/gnustep ]; then
147                 /etc/rc.d/init.d/gnustep stop 1>&2
148         fi
149         /sbin/chkconfig --del gnustep
150 fi
151
152 %postun
153 if [ "$1" = "0" ]; then
154         umask 022
155         grep -v "^%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
156                 > /etc/ld.so.conf.tmp
157         mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
158         /sbin/ldconfig
159 fi
160
161 %triggerpostun -- gnustep-base < 1.7.0
162 umask 022
163 grep -v "^%{_prefix}/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
164         > /etc/ld.so.conf.tmp
165 mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
166 /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc ChangeLog*
171 %attr(754,root,root) %{_initrddir}/gnustep
172
173 %dir %{_prefix}/System/Library/Bundles/SSL.bundle
174 %{_prefix}/System/Library/Bundles/SSL.bundle/Resources
175 %attr(755,root,root) %{_prefix}/System/Library/Bundles/SSL.bundle/%{gscpu}
176
177 %docdir %{_prefix}/System/Library/Documentation
178 %if %{with doc}
179 %dir %{_prefix}/System/Library/Documentation/Developer/Base
180 %{_prefix}/System/Library/Documentation/Developer/Base/ReleaseNotes
181 %endif
182 %dir %{_prefix}/System/Library/Documentation/man/man8
183 %{_prefix}/System/Library/Documentation/man/man1/*.1*
184 %{_prefix}/System/Library/Documentation/man/man8/*.8*
185
186 %dir %{_prefix}/System/Library/DTDs
187 %{_prefix}/System/Library/DTDs/*.dtd
188
189 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base
190 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/English.lproj
191 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/French.lproj
192 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/German.lproj
193 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Italian.lproj
194 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/TraditionalChinese.lproj
195 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages
196 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Locale.*
197 %lang(nl) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
198 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/English
199 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/French
200 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/German
201 %lang(hu) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
202 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Italian
203 %lang(ru) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Russian
204 %lang(sk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Slovak
205 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/TraditionalChinese
206 %lang(uk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/UkraineRussian
207 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSCharacterSets
208 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones
209 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUmakefile
210 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUstep_zones
211 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/README
212 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/abbreviations
213 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/regions
214 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones
215 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/*.m
216 %config(noreplace) %verify(not size mtime md5) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
217
218 %dir %{_prefix}/System/Library/Libraries/%{gscpu}
219 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}
220 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}
221 %attr(755,root,root) %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
222
223 %dir %{_prefix}/System/Tools/%{gscpu}
224 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}
225 # is suid necessary here??? it runs as daemon...
226 #%attr(4755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
227 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
228 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}
229 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
230
231 %files devel
232 %defattr(644,root,root,755)
233 %if %{with doc}
234 %docdir %{_prefix}/System/Library/Documentation
235 %{_prefix}/System/Library/Documentation/Developer/Base/General
236 %{_prefix}/System/Library/Documentation/Developer/Base/ProgrammingManual
237 %{_prefix}/System/Library/Documentation/Developer/Base/Reference
238 %{_prefix}/System/Library/Documentation/Developer/BaseAdditions
239 %{_prefix}/System/Library/Documentation/Developer/CodingStandards
240 %{_prefix}/System/Library/Documentation/info/*.info*
241 %endif
242
243 %{_prefix}/System/Library/Headers/%{libcombo}/Foundation
244 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepBase
245 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep
246 %{_prefix}/System/Library/Headers/%{libcombo}/%{gscpu}/%{gsos}/*.h
247
248 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
249 %dir %{_prefix}/System/Library/Makefiles/Additional
250 %{_prefix}/System/Library/Makefiles/Additional/base.make
This page took 0.078613 seconds and 3 git commands to generate.