]> git.pld-linux.org Git - packages/gnustep-base.git/blob - gnustep-base.spec
- updated to 1.10.1, pass-arguments patch is back (updated)
[packages/gnustep-base.git] / gnustep-base.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # don't generate documentation (bootstrap build w/o gnustep-base)
4 #
5 Summary:        GNUstep Base library package
6 Summary(pl):    Podstawowa biblioteka GNUstep
7 Name:           gnustep-base
8 Version:        1.10.1
9 Release:        1
10 License:        LGPL/GPL
11 Group:          Libraries
12 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
13 # Source0-md5:  94eaac8feb8d5ae95194a37cedc27544
14 Source1:        %{name}.init
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-pass-arguments.patch
17 URL:            http://www.gnustep.org/
18 BuildRequires:  ffcall-devel
19 BuildRequires:  gcc-objc
20 BuildRequires:  gmp-devel
21 %{?with_doc:BuildRequires:      gnustep-base-devel >= 1.8.0}
22 %{?with_doc:BuildRequires:      docbook-dtd41-sgml}
23 BuildRequires:  gnustep-make-devel >= 1.10.0
24 BuildRequires:  libxml2-devel >= 2.3.0
25 BuildRequires:  openssl-devel >= 0.9.7d
26 BuildRequires:  zlib-devel
27 Requires(post,preun):   grep
28 Requires(post,preun):   /sbin/chkconfig
29 Requires(post,postun):  /sbin/ldconfig
30 Requires:       gnustep-make >= 1.10.0
31 # with gdomap in /etc/services
32 Requires:       setup >= 2.4.3
33 Conflicts:      gnustep-core
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _prefix         /usr/%{_lib}/GNUstep
37
38 %define         libcombo        gnu-gnu-gnu
39 %define         gsos            linux-gnu
40 %ifarch %{ix86}
41 %define         gscpu           ix86
42 %else
43 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
44 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
45 %endif
46
47 %description
48 The GNUstep Base Library is a library of general-purpose,
49 non-graphical Objective C objects. For example, it includes classes
50 for strings, object collections, byte streams, typed coders,
51 invocations, notifications, notification dispatchers, moments in time,
52 network ports, remote object messaging support (distributed objects),
53 event loops, and random number generators.
54
55 %description -l pl
56 Podstawowa biblioteka GNUstep jest bibliotek± innych ni¿ graficzne
57 obiektów ogólnego przeznaczenia dla Objective C. Zawiera np. klasy dla
58 stringów, kolekcji, strumieni, koderów typów, powiadamiania, portów
59 sieci, obiektów rozproszonych, pêtli zdarzeñ, generatorów liczb
60 losowych.
61
62 %package devel
63 Summary:        GNUstep Base headers
64 Summary(pl):    Pliki nag³ówkowe podstawowej biblioteki GNUstep
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       ffcall-devel
68 Requires:       gcc-objc
69 Requires:       gmp-devel
70 Requires:       gnustep-make-devel >= 1.8.0
71 Requires:       libxml2-devel
72 Requires:       zlib-devel
73 Conflicts:      gnustep-core
74
75 %description devel
76 Header files required to build applications against the GNUstep Base
77 library.
78
79 %description devel -l pl
80 Pliki nag³ówkowe potrzebne do budowania aplikacji u¿ywaj±cych
81 podstawowej biblioteki GNUstep.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %build
89 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
90 # gnustep can use one of 3 ways of getting argc,argv,env:
91 # - /proc (default on Linux) - gnustep programs won't run in procless system
92 # - fake-main hack (main is secretly renamed and wrapped)
93 # - pass-arguments (program must call NSProcessInfo initialize)
94 %configure \
95         --enable-pass-arguments
96
97 %{__make} \
98         messages=yes
99
100 %if %{with doc}
101 export LD_LIBRARY_PATH=`pwd`/Source/obj
102 # requires already installed gnustep-base
103 %{__make} -C Documentation
104 %{__make} -C Documentation/manual
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
110 %{__make} install \
111         INSTALL_ROOT_DIR=$RPM_BUILD_ROOT \
112         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
113
114 %if %{with doc}
115 %{__make} -C Documentation install \
116         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
117 %{__make} -C Documentation/manual install \
118         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System
119 # not (yet?) supported by rpm-compress-doc
120 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation \
121         -type f -a ! -name '*.html' -a ! -name '*.gz' -a ! -name '*.jpg' -a ! -name '*.css' | xargs gzip -9nf
122 %endif
123
124 install -d $RPM_BUILD_ROOT%{_initrddir}
125 sed -e "s!@TOOLSARCHDIR@!%{_prefix}/System/Tools/%{gscpu}/%{gsos}!" %{SOURCE1} \
126         > $RPM_BUILD_ROOT%{_initrddir}/gnustep
127
128 echo 'GMT' > $RPM_BUILD_ROOT%{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 umask 022
135 if ! grep -q '%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}' \
136     /etc/ld.so.conf ; then
137         echo "%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}" >> /etc/ld.so.conf
138 fi
139 /sbin/ldconfig
140 /sbin/chkconfig --add gnustep
141 if [ -f /var/lock/subsys/gnustep ]; then
142         /etc/rc.d/init.d/gnustep restart 1>&2
143 else
144         echo "Run \"/etc/rc.d/init.d/gnustep start\" to start gnustep services."
145 fi
146
147 %preun
148 if [ "$1" = "0" ]; then
149         if [ -f /var/lock/subsys/gnustep ]; then
150                 /etc/rc.d/init.d/gnustep stop 1>&2
151         fi
152         /sbin/chkconfig --del gnustep
153 fi
154
155 %postun
156 if [ "$1" = "0" ]; then
157         umask 022
158         grep -v "^%{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
159                 > /etc/ld.so.conf.tmp
160         mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
161         /sbin/ldconfig
162 fi
163
164 %triggerpostun -- gnustep-base < 1.7.0
165 umask 022
166 grep -v "^%{_prefix}/Libraries/%{gscpu}/%{gsos}/%{libcombo}$" /etc/ld.so.conf \
167         > /etc/ld.so.conf.tmp
168 mv -f /etc/ld.so.conf.tmp /etc/ld.so.conf
169 /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc ChangeLog*
174 %attr(754,root,root) %{_initrddir}/gnustep
175
176 %dir %{_prefix}/System/Library/Bundles/SSL.bundle
177 %{_prefix}/System/Library/Bundles/SSL.bundle/Resources
178 %attr(755,root,root) %{_prefix}/System/Library/Bundles/SSL.bundle/%{gscpu}
179
180 %docdir %{_prefix}/System/Library/Documentation
181 %if %{with doc}
182 %{_prefix}/System/Library/Documentation/*.jpg
183 %{_prefix}/System/Library/Documentation/index.html
184 %{_prefix}/System/Library/Documentation/style.css
185 %dir %{_prefix}/System/Library/Documentation/Developer/Base
186 %{_prefix}/System/Library/Documentation/Developer/Base/ReleaseNotes
187 %endif
188 %dir %{_prefix}/System/Library/Documentation/man/man8
189 %{_prefix}/System/Library/Documentation/man/man1/*.1*
190 %{_prefix}/System/Library/Documentation/man/man8/*.8*
191
192 %dir %{_prefix}/System/Library/DTDs
193 %{_prefix}/System/Library/DTDs/*.dtd
194 %{_prefix}/System/Library/DTDs/*.rnc
195
196 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base
197 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/*.plist
198 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/English.lproj
199 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/French.lproj
200 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/German.lproj
201 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Italian.lproj
202 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/TraditionalChinese.lproj
203 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages
204 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Locale.*
205 %lang(nl) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
206 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/English
207 %lang(fr) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/French
208 %lang(de) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/German
209 %lang(hu) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
210 %lang(it) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Italian
211 %lang(ru) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Russian
212 %lang(sk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/Slovak
213 %lang(zh_TW) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/TraditionalChinese
214 %lang(uk) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/Languages/UkraineRussian
215 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSCharacterSets
216 %dir %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones
217 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUmakefile
218 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/GNUstep_zones
219 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/README
220 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/abbreviations
221 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/regions
222 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones
223 %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/*.m
224 %config(noreplace) %verify(not size mtime md5) %{_prefix}/System/Library/Libraries/Resources/gnustep-base/NSTimeZones/localtime
225
226 %dir %{_prefix}/System/Library/Libraries/%{gscpu}
227 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}
228 %dir %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}
229 %attr(755,root,root) %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so.*
230
231 %dir %{_prefix}/System/Tools/%{gscpu}
232 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}
233 # is suid necessary here??? it runs as daemon...
234 #%attr(4755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
235 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/gdomap
236 %dir %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}
237 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
238
239 %files devel
240 %defattr(644,root,root,755)
241 %if %{with doc}
242 %docdir %{_prefix}/System/Library/Documentation
243 %{_prefix}/System/Library/Documentation/Developer/Base/General
244 %{_prefix}/System/Library/Documentation/Developer/Base/ProgrammingManual
245 %{_prefix}/System/Library/Documentation/Developer/Base/Reference
246 %{_prefix}/System/Library/Documentation/Developer/BaseAdditions
247 %{_prefix}/System/Library/Documentation/Developer/CodingStandards
248 %{_prefix}/System/Library/Documentation/Developer/Tools
249 %{_prefix}/System/Library/Documentation/info/*.info*
250 %endif
251
252 %{_prefix}/System/Library/Headers/%{libcombo}/Foundation
253 %{_prefix}/System/Library/Headers/%{libcombo}/GNUstepBase
254 %{_prefix}/System/Library/Headers/%{libcombo}/gnustep
255 %{_prefix}/System/Library/Headers/%{libcombo}/%{gscpu}/%{gsos}/*.h
256
257 %{_prefix}/System/Library/Libraries/%{gscpu}/%{gsos}/%{libcombo}/lib*.so
258 %dir %{_prefix}/System/Library/Makefiles/Additional
259 %{_prefix}/System/Library/Makefiles/Additional/base.make
This page took 0.08126 seconds and 3 git commands to generate.