]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- massive attack: adding Source-md5
[packages/gnustep-back.git] / gnustep-back.spec
1 Summary:        The GNUstep backend bundle
2 Summary(pl):    Pakiet backendowy GNUstep
3 Name:           gnustep-back
4 Version:        0.8.5
5 Release:        1
6 License:        LGPL/GPL
7 Vendor:         The GNUstep Project
8 Group:          X11/Libraries
9 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
10 # Source0-md5:  9020f254f584ed176221321218857b55
11 Patch0:         %{name}-art-freetype213.patch
12 Patch1:         %{name}-xdps-fix.patch
13 URL:            http://www.gnustep.org/
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  WindowMaker-devel
16 BuildRequires:  XFree86-devel
17 BuildRequires:  XFree86-DPS-devel
18 BuildRequires:  freetype-devel >= 2.1.3
19 BuildRequires:  gnustep-gui-devel
20 BuildRequires:  libart_lgpl-devel
21 BuildRequires:  xft-devel
22 Requires:       OpenGL
23 Requires:       gnustep-gui
24 Obsoletes:      gnustep-xgps
25 Conflicts:      gnustep-core
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/lib/GNUstep
29
30 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
31
32 %define         libcombo        gnu-gnu-gnu
33 %define         gsos            linux-gnu
34 %ifarch %{ix86}
35 %define         gscpu           ix86
36 %else
37 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
38 %define         gscpu           %{_target_cpu}
39 %endif
40
41 %description
42 This is a backend for the GNUstep gui Library which allows you to use
43 the GNUstep gui Library on an X Windows System (other backends will
44 be added later to allow you to use the GNUstep gui Library in other
45 windowing environments).
46
47 This package contains common part and xlib graphics backend.
48
49 %description -l pl
50 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
51 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
52 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
53 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
54
55 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
56
57 %package art
58 Summary:        GNUstep graphics backend - art
59 Summary(pl):    Graficzny backend GNUstep - art
60 Group:          X11/Libraries
61 Requires:       %{name} = %{version}
62 Conflicts:      gnustep-core
63
64 %description art
65 GNUstep graphics backend - art.
66
67 %description art -l pl
68 Graficzny backend GNUstep - art.
69
70 %package xdps
71 Summary:        GNUstep graphics backend - xdps
72 Summary(pl):    Graficzny backend GNUstep - xdps
73 Group:          X11/Libraries
74 Requires:       %{name} = %{version}
75 Obsoletes:      gnustep-xdps
76 Conflicts:      gnustep-core
77
78 %description xdps
79 GNUstep graphics backend - xdps.
80
81 %description xdps -l pl
82 Graficzny backend GNUstep - xdps.
83
84 %package devel
85 Summary:        Headers for GNUstep backends
86 Summary(pl):    Pliki nag³ówkowe backendów GNUstep
87 Group:          X11/Development/Libraries
88 Requires:       %{name} = %{version}
89 Requires:       XFree86-devel
90 Requires:       gnustep-gui-devel
91 Requires:       xft-devel
92 Obsoletes:      gnustep-xdps-devel
93 Obsoletes:      gnustep-xgps-devel
94 Conflicts:      gnustep-core
95
96 %description devel
97 This package contains development headers for GNUstep backends. It
98 includes also files specific for all x11 graphic backends (xlib,
99 art, xdps).
100
101 %description devel -l pl
102 Ten pakiet zawiera pliki nag³ówkowe dla backendów GNUstep, w tym pliki
103 specyficzne dla wszystkich backendów graficznych dla x11 (xlib, art,
104 xdps).
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 . %{_prefix}/System/Makefiles/GNUstep.sh
113 for g in art xdps xlib ; do
114 if [ "$g" = "xlib" ]; then
115         INC='--with-include-flags=-I/usr/include/freetype2'
116         NAME="back"
117 else
118         INC=
119         NAME="back-$g"
120 fi
121 %configure \
122         --enable-graphics=$g \
123         --with-name=$NAME \
124         $INC
125
126 %{__make} \
127         messages=yes
128 cp -f back.make back-$g.make
129 # preserve timestamp of config.h
130 cp -pf config.h config-$g.h
131 done
132
133 %{__make} -C Documentation
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 . %{_prefix}/System/Makefiles/GNUstep.sh
138
139 for g in art xdps xlib ; do
140 if [ "$g" = "xlib" ]; then
141         NAME="back"
142 else
143         NAME="back-$g"
144 fi
145 # hack - restore timestamps to prevent rebuilding
146 cp -pf config-$g.h config.h
147 cp -pf config.h Source/%{gscpu}/%{gsos}/config.h
148 touch config.status -r config.h
149 %{__make} install \
150         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
151         BUILD_GRAPHICS="$g" \
152         BACKEND_NAME="$NAME"
153 done
154
155 %{__make} install -C Documentation \
156         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
157 # not (yet?) supported by rpm-compress-doc
158 find $RPM_BUILD_ROOT%{_prefix}/System/Documentation -type f | xargs gzip -9nf
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc ChangeLog
169 %{_prefix}/System/Documentation/Developer/Back
170
171 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
172 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
173 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
174
175 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
176
177 %files art
178 %defattr(644,root,root,755)
179 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
180 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
181 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
182
183 %files xdps
184 %defattr(644,root,root,755)
185 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
186 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
187 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
188
189 %files devel
190 %defattr(644,root,root,755)
191 %{_prefix}/System/Headers/gnustep/gsc
192 %{_prefix}/System/Headers/gnustep/x11
193
194 %{_prefix}/System/Headers/gnustep/xlib
195 %{_prefix}/System/Headers/gnustep/art
196 %{_prefix}/System/Headers/gnustep/xdps
This page took 0.14984 seconds and 4 git commands to generate.