]> git.pld-linux.org Git - packages/gnustep-back.git/blob - gnustep-back.spec
- destdir install fix
[packages/gnustep-back.git] / gnustep-back.spec
1 #
2 # Conditional build:
3 %bcond_without art      # don't build art backend
4 #
5 Summary:        The GNUstep backend bundle
6 Summary(pl):    Pakiet backendowy GNUstep
7 Name:           gnustep-back
8 Version:        0.9.4
9 Release:        1
10 License:        LGPL/GPL
11 Vendor:         The GNUstep Project
12 Group:          X11/Libraries
13 Source0:        ftp://ftp.gnustep.org/pub/gnustep/core/%{name}-%{version}.tar.gz
14 # Source0-md5:  9bbd37749e8bdd355533bdf5d1d08050
15 Patch0:         %{name}-freetype.patch
16 URL:            http://www.gnustep.org/
17 BuildRequires:  OpenGL-devel
18 BuildRequires:  XFree86-devel
19 BuildRequires:  XFree86-DPS-devel
20 BuildRequires:  cairo-devel
21 %{?with_art:BuildRequires:      freetype-devel >= 2.1.4}
22 BuildRequires:  gnustep-gui-devel >= %{version}
23 %{?with_art:BuildRequires:      libart_lgpl-devel}
24 BuildRequires:  pkgconfig
25 BuildRequires:  xft-devel
26 Requires:       OpenGL
27 Requires:       gnustep-gui >= %{version}
28 Obsoletes:      gnustep-back-devel
29 Obsoletes:      gnustep-xgps
30 Conflicts:      gnustep-core
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _prefix         /usr/%{_lib}/GNUstep
34
35 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
36
37 %define         libcombo        gnu-gnu-gnu
38 %define         gsos            linux-gnu
39 %ifarch %{ix86}
40 %define         gscpu           ix86
41 %else
42 # also s/alpha.*/alpha/, but we use only "alpha" arch for now
43 %define         gscpu           %(echo %{_target_cpu} | sed -e 's/amd64/x86_64/;s/ppc/powerpc/')
44 %endif
45
46 %description
47 This is a backend for the GNUstep gui Library which allows you to use
48 the GNUstep gui Library on an X Window System (other backends will
49 be added later to allow you to use the GNUstep gui Library in other
50 windowing environments).
51
52 This package contains common part and xlib graphics backend.
53
54 %description -l pl
55 To jest backend dla biblioteki GNUstep GUI, pozwalaj±cy na u¿ywanie
56 biblioteki graficznego interfejsu u¿ytkownika GNUstep pod systemem X
57 Window (inne backendy, pozwalaj±ce na u¿ywanie biblioteki GNUstep GUI
58 w innych ¶rodowiskach okienkowych, zostan± dodane pó¼niej).
59
60 Ten pakiet zawiera czê¶æ wspóln± i backend graficzny xlib.
61
62 %package art
63 Summary:        GNUstep graphics backend - art
64 Summary(pl):    Graficzny backend GNUstep - art
65 Group:          X11/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       freetype >= 2.1.4
68 Conflicts:      gnustep-core
69
70 %description art
71 GNUstep graphics backend - art.
72
73 %description art -l pl
74 Graficzny backend GNUstep - art.
75
76 %package cairo
77 Summary:        GNUstep graphics backend - cairo
78 Summary(pl):    Graficzny backend GNUstep - cairo
79 Group:          X11/Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description cairo
83 GNUstep graphics backend - cairo.
84
85 %description cairo -l pl
86 Graficzny backend GNUstep - cairo.
87
88 %package xdps
89 Summary:        GNUstep graphics backend - xdps
90 Summary(pl):    Graficzny backend GNUstep - xdps
91 Group:          X11/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 Obsoletes:      gnustep-xdps
94 Conflicts:      gnustep-core
95
96 %description xdps
97 GNUstep graphics backend - xdps.
98
99 %description xdps -l pl
100 Graficzny backend GNUstep - xdps.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 # prepare the trees (for art, cairo, xdps, xlib backends)
107 echo * > files.list
108 %if %{with art}
109 install -d back-art 
110 cp -a `cat files.list` back-art
111 %endif
112 install -d back-cairo
113 cp -a `cat files.list` back-cairo
114 install -d back-xdps
115 cp -a `cat files.list` back-xdps
116 ln -sf . back-xlib
117
118 %build
119 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
120
121 for g in %{?with_art:art} cairo xdps xlib ; do
122 cd back-$g
123 if [ "$g" = "xlib" ]; then
124         INC='--with-include-flags=-I/usr/include/freetype2'
125         NAME="back"
126 else
127         INC=
128         NAME="back-$g"
129 fi
130 %configure \
131         --enable-graphics=$g \
132         --with-name=$NAME \
133         $INC
134
135 %{__make} \
136         messages=yes
137 cd ..
138 done
139
140 %{__make} -C Documentation
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 . %{_prefix}/System/Library/Makefiles/GNUstep.sh
145
146 for g in %{?with_art:art} cairo xdps xlib ; do
147 if [ "$g" = "xlib" ]; then
148         NAME="back"
149 else
150         NAME="back-$g"
151 fi
152 %{__make} install -C back-$g \
153         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
154         BUILD_GRAPHICS="$g" \
155         BACKEND_NAME="$NAME"
156 done
157
158 %{__make} install -C Documentation \
159         GNUSTEP_INSTALLATION_DIR=$RPM_BUILD_ROOT%{_prefix}/System \
160
161 # not (yet?) supported by rpm-compress-doc
162 find $RPM_BUILD_ROOT%{_prefix}/System/Library/Documentation -type f \
163         ! -name '*.gz' | xargs gzip -9nf
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %post   -p /sbin/ldconfig
169 %postun -p /sbin/ldconfig
170
171 %files
172 %defattr(644,root,root,755)
173 %doc ChangeLog
174 %docdir %{_prefix}/System/Library/Documentation
175 %{_prefix}/System/Library/Documentation/Developer/Back
176 %{_prefix}/System/Library/Documentation/man/man1/gpbs.1*
177
178 %dir %{_prefix}/System/Library/Bundles/libgnustep-back.bundle
179 %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/Resources
180 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back.bundle/%{gscpu}
181
182 %attr(755,root,root) %{_prefix}/System/Tools/%{gscpu}/%{gsos}/%{libcombo}/*
183
184 %if %{with art}
185 %files art
186 %defattr(644,root,root,755)
187 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle
188 %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/Resources
189 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-art.bundle/%{gscpu}
190 %endif
191
192 %files cairo
193 %defattr(644,root,root,755)
194 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle
195 %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/Resources
196 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-cairo.bundle/%{gscpu}
197
198 %files xdps
199 %defattr(644,root,root,755)
200 %dir %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle
201 %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/Resources
202 %attr(755,root,root) %{_prefix}/System/Library/Bundles/libgnustep-back-xdps.bundle/%{gscpu}
This page took 0.056165 seconds and 3 git commands to generate.