]> git.pld-linux.org Git - SPECS.git/blob - gnucobol.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / gnucobol.spec
1 Summary:        GnuCOBOL translator/compiler
2 Summary(pl.UTF-8):      Translator/kompilator GnuCOBOL
3 Name:           gnucobol
4 Version:        3.2
5 Release:        1
6 License:        LGPL v3+ (library), GPL v3+ (compiler)
7 Group:          Development/Languages
8 Source0:        https://ftp.gnu.org/gnu/gnucobol/%{name}-%{version}.tar.lz
9 # Source0-md5:  0b943fd5ad464dcf76f3d2e719f19e4c
10 Patch0:         %{name}-info.patch
11 URL:            https://gnucobol.sourceforge.io/
12 BuildRequires:  db-devel >= 4.1
13 BuildRequires:  gmp-devel >= 4.1.2
14 BuildRequires:  json-c-devel >= 0.12
15 BuildRequires:  libxml2-devel >= 2.0
16 BuildRequires:  lzip
17 BuildRequires:  ncurses-devel >= 5.2
18 BuildRequires:  pkgconfig
19 BuildRequires:  tar >= 1:1.22
20 Requires:       %{name}-devel = %{version}-%{release}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 GnuCOBOL is a free (like both in "free speech" and in "free beer")
25 COBOL compiler, formerly known as OpenCOBOL. It implements a
26 substantial part of the COBOL 85, COBOL 2002 and COBOL 2014 standards,
27 as well as many extensions included in other COBOL compilers.
28
29 GnuCOBOL translates COBOL into C and compiles the translated code
30 using the native C compiler on various platforms, including
31 Unix/Linux, Mac OS X, and Microsoft Windows.
32
33 %description -l pl.UTF-8
34 GnuCOBOL to wolnodostępny (zarówno wolny, jak i darmowy) kompilator
35 języka COBOL, wcześniej znany jako OpenCOBOL. Implementuje znaczącą
36 część standardów COBOL 85, COBOL 2002 i COBOL 2014, a także wiele
37 rozszerzeń włącznych do innych kompilatorów języka.
38
39 GnuCOBOL tłumaczy COBOL do języka C i kompiluje przetłumaczony kod
40 przy użyciu natywnego kompilatora C na różnych platformach, w tym
41 Unix/Linux, Mac OS X i Microsoft Windows.
42
43 %package libs
44 Summary:        GnuCOBOL runtime library
45 Summary(pl.UTF-8):      Biblioteka uruchomieniowa GnuCOBOL-a
46 License:        LGPL v3+
47 Group:          Libraries
48 Requires:       gmp >= 4.1.2
49 Requires:       ncurses >= 5.2
50
51 %description libs
52 GnuCOBOL runtime library.
53
54 %description libs -l pl.UTF-8
55 Biblioteka uruchomieniowa GnuCOBOL-a.
56
57 %package devel
58 Summary:        Header files for GnuCOBOL library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GnuCOBOL-a
60 License:        LGPL v3+
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63
64 %description devel
65 Header files for GnuCOBOL library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki GnuCOBOL-a.
69
70 %package static
71 Summary:        GnuCOBOL static library
72 Summary(pl.UTF-8):      Biblioteka statyczna GnuCOBOL-a
73 License:        LGPL v3+
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 GnuCOBOL static library.
79
80 %description static -l pl.UTF-8
81 Biblioteka statyczna GnuCOBOL-a.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 %configure \
89         --with-curses=ncurses \
90         --with-db \
91         --with-json=json-c \
92         --with-math=gmp
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 chmod 755 $RPM_BUILD_ROOT%{_libdir}/gnucobol/*.so
102
103 %find_lang %{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/postshell
109 -/usr/sbin/fix-info-dir -c %{_infodir}
110
111 %postun -p /sbin/postshell
112 -/usr/sbin/fix-info-dir -c %{_infodir}
113
114 %post   libs -p /sbin/ldconfig
115 %postun libs -p /sbin/ldconfig
116
117 %files -f %{name}.lang
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README THANKS TODO
120 %attr(755,root,root) %{_bindir}/cobc
121 %{_datadir}/gnucobol
122 %{_infodir}/gnucobol.info*
123 %{_mandir}/man1/cobc.1*
124
125 %files libs
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/cobcrun
128 %attr(755,root,root) %{_libdir}/libcob.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libcob.so.4
130 %dir %{_libdir}/gnucobol
131 %attr(755,root,root) %{_libdir}/gnucobol/CBL_OC_DUMP.so
132 %{_mandir}/man1/cobcrun.1*
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/cob-config
137 %attr(755,root,root) %{_libdir}/libcob.so
138 %{_libdir}/libcob.la
139 %{_includedir}/libcob.h
140 %{_includedir}/libcob
141 %{_mandir}/man1/cob-config.1*
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libcob.a
This page took 0.142639 seconds and 3 git commands to generate.