]> git.pld-linux.org Git - SPECS.git/blob - gnomemm.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / gnomemm.spec
1 Summary:        C++ interface to GNOME libraries
2 Summary(pl.UTF-8):      Interfejs w C++ do bibliotek GNOME
3 Name:           gnomemm
4 Version:        1.2.2
5 Release:        3
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://dl.sourceforge.net/gtkmm/%{name}-%{version}.tar.gz
9 # Source0-md5:  2a45f162a68cd4b42881fb72a1dc528e
10 Patch0:         %{name}-ac_fix.patch
11 Patch1:         %{name}-am_fix.patch
12 Patch2:         %{name}-procbar_fix.patch
13 URL:            http://gtkmm.sourceforge.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  esound-devel
17 BuildRequires:  gnome-libs-devel
18 BuildRequires:  gtkmm1-devel
19 BuildRequires:  imlib-devel
20 BuildRequires:  libtool
21 BuildRequires:  zlib-devel
22 Requires:       cpp
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Gnomemm (gnome--) is a C++ interface to GNOME libraries. If you want
27 to run GNOME programs written in C++ you need gnomemm.
28
29 %description -l pl.UTF-8
30 Gnomemm (gnome--) jest interfejsem do bibliotek GNOME dla C++. Jeśli
31 chcesz uruchamiać programy GNOME napisane w C++ będziesz potrzebował
32 tych bibliotek.
33
34 %package devel
35 Summary:        Header files and some examples for gnomemm (gnome--)
36 Summary(pl.UTF-8):      Pliki nagłówkowe i przykłady dla gnomemm (gnome--)
37 Group:          X11/Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       gnome-libs-devel
40 Requires:       gtk+-devel
41 Requires:       gtkmm1-devel
42
43 %description devel
44 If you are going to write GNOME programs in C++ you will need this
45 package. It contains all header files, libraries and some examples.
46
47 %description devel -l pl.UTF-8
48 Jeśli zamierzasz pisać programy GNOME w C++ będziesz potrzebował tego
49 pakietu. Zawiera on niezbędne nagłówki, biblioteki i trochę
50 przykładów.
51
52 %package static
53 Summary:        gnomemm static libraries
54 Summary(pl.UTF-8):      Biblioteki statyczne gnomemm
55 Group:          X11/Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Gnomemm static libraries.
60
61 %description static -l pl.UTF-8
62 Biblioteki statyczne gnomemm.
63
64 %prep
65 %setup -q
66 #%patch0 -p1
67 #%patch1
68 %patch2
69
70 %build
71 #rm -f missing
72 #%{__libtoolize}
73 #aclocal -I %{_aclocaldir}/gnome
74 #%{__autoconf}
75 #%{__automake}
76 CXXFLAGS="%{rpmcflags} -fno-exceptions"
77 %configure2_13 \
78         --enable-static=yes
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 cp -dpr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}
90
91 # --- start examples ---
92 cat $RPM_BUILD_ROOT%{_examplesdir}/%{name}/examples.conf.in \
93         | sed 's/@SHELL@/\/bin\/sh/g' \
94         | sed 's/@CFLAGS@/%{rpmcflags}/g' \
95         | sed 's/@CPPFLAGS@/`gnome-config --cflags gnome`/g' \
96         | sed 's/@CXXFLAGS@/%{rpmcflags}/g' \
97         | sed 's/@CXX@/c++/g' \
98         | sed 's/@CXXLD@/c++/g' \
99         | sed 's/@GTKMM_CFLAGS@/`gtkmm-config --cflags`/g' \
100         | sed 's/@GTKMM_LIBS@/`gtkmm-config --libs`/g' \
101         | sed 's/@GNOME_INCLUDEDIR@/`gnome-config --cflags gnome`/g' \
102         | sed 's/@GNOMEUI_LIBS@ @GNOME_LIBDIR@/`gnome-config --libs gnome gnomeui`/g' \
103         | sed 's/@LIBTOOL@/$(SHELL) \/usr\/bin\/libtool/g' \
104         | sed 's/..\/..\/src\/gnome--\/libgnomemm.la/\/usr\/X11R6\/lib\/libgnomemm.la/g' \
105         | sed 's/top_builddir = ..\/../top_builddir = ./g' \
106         > $RPM_BUILD_ROOT%{_examplesdir}/%{name}/examples.conf
107 # --- end examples ---
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libgnomemm*.so.*.*
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc README ChangeLog AUTHORS NEWS
122 %attr(755,root,root) %{_libdir}/lib*.so
123 %{_libdir}/lib*.la
124 %{_libdir}/gnomemmConf.sh
125
126 %{_examplesdir}/%{name}
127
128 %{_includedir}/*.h
129 %{_includedir}/gnome--
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/lib*.a
This page took 0.442963 seconds and 3 git commands to generate.