]> git.pld-linux.org Git - packages/gnome-vfs2.git/blob - gnome-vfs2.spec
- release 2 - lets try if provides gnome-vfs2-vfolder-menu will allow to
[packages/gnome-vfs2.git] / gnome-vfs2.spec
1 #
2 # Conditional build:
3 %bcond_without  hal     # don't use hal
4 #
5 Summary:        GNOME2 - virtual file system
6 Summary(pl):    GNOME2 - wirtualny system plików
7 Name:           gnome-vfs2
8 Version:        2.10.1
9 Release:        2
10 License:        LGPL v2+
11 Group:          Applications
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-vfs/2.10/gnome-vfs-%{version}.tar.bz2
13 # Source0-md5:  88b520e5de748a310a2aef62fc095c8b
14 Source1:        %{name}-defaults.list
15 Patch0:         %{name}-defaults-path.patch
16 Patch1:         %{name}-no_g_mime.patch
17 URL:            http://www.gnome.org/
18 BuildRequires:  GConf2-devel >= 2.10.0
19 BuildRequires:  ORBit2-devel >= 1:2.12.1
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel
23 BuildRequires:  cdparanoia-III-devel
24 %{?with_hal:BuildRequires:      dbus-glib-devel >= 0.23}
25 BuildRequires:  docbook-dtd412-xml >= 1.0-10
26 BuildRequires:  fam-devel
27 BuildRequires:  flex
28 BuildRequires:  gettext-devel
29 BuildRequires:  glib2-devel >= 1:2.6.2
30 BuildRequires:  gnome-common >= 2.8.0
31 BuildRequires:  gnome-doc-tools
32 BuildRequires:  gtk+2-devel >= 2:2.6.2
33 BuildRequires:  gtk-doc >= 1.1
34 %{?with_hal:BuildRequires:      hal-devel >= 0.4.7}
35 BuildRequires:  heimdal-devel
36 BuildRequires:  howl-devel >= 0.9.10
37 BuildRequires:  intltool >= 0.30
38 BuildRequires:  libbonobo-devel >= 2.8.1
39 BuildRequires:  libsmbclient-devel >= 3.0
40 BuildRequires:  libtool >= 2:1.5.14
41 BuildRequires:  libxml2-devel >= 2.6.0
42 BuildRequires:  openssl-devel >= 0.9.7d
43 BuildRequires:  perl-base
44 BuildRequires:  pkgconfig
45 BuildRequires:  popt-devel
46 BuildRequires:  rpm-build >= 4.1-10
47 BuildRequires:  rpmbuild(macros) >= 1.197
48 BuildRequires:  zlib-devel
49 Requires(post): /sbin/ldconfig
50 Requires(post,preun):   GConf2
51 %{?with_hal:Requires:   hal-libs >= 0.4.7}
52 Requires:       howl-libs >= 0.9.10
53 Requires:       libbonobo >= 2.8.1
54 Requires:       shared-mime-info >= 0.15
55 Obsoletes:      gnome-vfs-extras
56 Obsoletes:      gnome-vfs2-vfolder-menu
57 Provides:       gnome-vfs2-vfolder-menu
58 Conflicts:      gnome-vfs2-module-menu <= 0.8-1
59 Conflicts:      libgnome < 2.5.1
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 GNOME2 Virtual File System library.
64
65 %description -l pl
66 Biblioteka Wirtualnego Systemu Plików GNOME2.
67
68 %package devel
69 Summary:        gnome-vfs2 - header files
70 Summary(pl):    gnome-vfs2 - pliki nag³ówkowe
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       GConf2-devel >= 2.10.0
74 Requires:       gtk-doc-common
75 Requires:       howl-devel >= 0.9.10
76 Requires:       libbonobo-devel >= 2.8.1
77 Requires:       openssl-devel >= 0.9.7d
78
79 %description devel
80 This package contains header files for gnome-vfs2 library.
81
82 %description devel -l pl
83 Pakiet ten zawiera pliki nag³ówkowe biblioteki gnome-vfs2.
84
85 %package static
86 Summary:        gnome-vfs2 - static libraries
87 Summary(pl):    gnome-vfs2 - biblioteki statyczne
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 This package contains static gnome-vfs2 libraries.
93
94 %description static -l pl
95 Pakiet ten zawiera biblioteki statyczne gnome-vfs2.
96
97 %prep
98 %setup -q -n gnome-vfs-%{version}
99 %patch0 -p1
100 %patch1 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 %configure \
108         --enable-gtk-doc \
109         --with-html-dir=%{_gtkdocdir} \
110         --disable-schemas-install \
111         --enable-ipv6 \
112 %if %{with hal}
113         --enable-hal
114 %else
115         --disable-hal
116 %endif
117 %{__make} CFLAGS="%{rpmcflags} -DMOUNT_ARGUMENT=\\\"-s\\\""
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT%{_desktopdir}
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT \
125         m4dir=%{_aclocaldir} \
126         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
127
128 # no static modules
129 rm -f $RPM_BUILD_ROOT%{_libdir}/{gnome-vfs-2.0/modules,bonobo/monikers}/*.{la,a}
130 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/*/filesystems/*.{la,a}
131
132 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
133
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/defaults.list
135
136 %find_lang gnome-vfs-2.0
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 /sbin/ldconfig
143 %gconf_schema_install desktop_default_applications.schemas
144 %gconf_schema_install desktop_gnome_url_handlers.schemas
145 %gconf_schema_install system_dns_sd.schemas
146 %gconf_schema_install system_http_proxy.schemas
147 %gconf_schema_install system_smb.schemas
148
149 %preun
150 %gconf_schema_uninstall desktop_default_applications.schemas
151 %gconf_schema_uninstall desktop_gnome_url_handlers.schemas
152 %gconf_schema_uninstall system_dns_sd.schemas
153 %gconf_schema_uninstall system_http_proxy.schemas
154 %gconf_schema_uninstall system_smb.schemas
155
156 %postun -p /sbin/ldconfig
157
158 %files -f gnome-vfs-2.0.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog NEWS README
161 %{_sysconfdir}/gnome-vfs-2.0
162 %{_sysconfdir}/gconf/schemas/*
163 %attr(755,root,root) %{_bindir}/gnomevfs-*
164 %attr(755,root,root) %{_libdir}/gnome-vfs-daemon
165 %attr(755,root,root) %{_libdir}/*.so.*.*
166 %dir %{_libdir}/gnome-vfs-2.0
167 %dir %{_libdir}/gnome-vfs-2.0/modules
168 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/*.so
169 %{_libdir}/bonobo/servers/*
170 %attr(755,root,root) %{_libdir}/bonobo/monikers/*.so
171 %{_desktopdir}/*.list
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/*.so
176 %{_libdir}/*.la
177 %{_includedir}/gnome-vfs-2.0
178 %{_includedir}/gnome-vfs-module-2.0
179 %{_libdir}/gnome-vfs-2.0/include
180 %{_pkgconfigdir}/*.pc
181 %{_gtkdocdir}/gnome-vfs-2.0
182
183 %files static
184 %defattr(644,root,root,755)
185 %{_libdir}/lib*.a
This page took 0.035255 seconds and 4 git commands to generate.