]> git.pld-linux.org Git - packages/gnome-speech.git/blob - gnome-speech.spec
- disable java by default
[packages/gnome-speech.git] / gnome-speech.spec
1
2 # TODO:
3 #       build other speech plugins?
4 #
5 %bcond_with     java            # build java subpackage
6
7 Summary:        GNOME Speech - text-to-speech convertion
8 Summary(pl):    GNOME Speech - przekszta³canie tekstu na mowê
9 Name:           gnome-speech
10 Version:        0.3.2
11 Release:        2
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/0.3/%{name}-%{version}.tar.bz2
15 # Source0-md5:  d1c3ad83c3c6f42db0f8ad3cb61c4671
16 Patch0:         %{name}-am.patch
17 Patch1:         %{name}-jar_dir.patch
18 URL:            http://developer.gnome.org/projects/gap/
19 BuildRequires:  ORBit2-devel >= 1:2.7.6
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gnome-common
23 BuildRequires:  gtk-doc >= 0.6
24 %if %{with java}
25 BuildRequires:  jar
26 BuildRequires:  java
27 BuildRequires:  java-access-bridge
28 %endif
29 BuildRequires:  libbonobo-devel >= 2.4.0
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 Requires:       festival >= 1.4.2
33 Provides:       gnome_speech
34 Obsoletes:      gnome_speech
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 GNOME Speech purpose is to provide a simple general API for producing
39 text-to-speech output.
40
41 %description -l pl
42 Celem GNOME Speech jest udostêpnienie prostego, ogólnego API do
43 przekszta³cania tekstu na mowê.
44
45 %package devel
46 Summary:        Development files for gnome_speech
47 Summary(pl):    Pliki programistyczne dla gnome_speech
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       libbonobo-devel >= 2.4.0
51 Provides:       gnome_speech-devel
52 Obsoletes:      gnome_speech-devel
53
54 %description devel
55 GNOME Speech files needed for development.
56
57 %description devel -l pl
58 Pliki GNOME Speech potrzebne do programowania.
59
60 %package static
61 Summary:        Static gnome-speech library
62 Summary(pl):    Statyczna biblioteka gnome-speech
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static gnome-speech library.
68
69 %description static -l pl
70 Statyczna biblioteka gnome-speech.
71
72 %package java
73 Summary:        Java classes for gnome-speech
74 Summary(pl):    Klasy Java dla gnome-speech
75 Group:          Development/Libraries
76
77 %description java
78 Java classes for gnome-speech.
79
80 %description java -l pl
81 Klasy Java dla gnome-speech.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
91 %{__autoheader}
92 %{__automake}
93 %{__autoconf}
94 %configure \
95         --enable-static \
96         --enable-gtk-doc \
97         %{?with_java:--with-jab-dir=/usr/share/java}
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         orbittypelibdir=%{_libdir}/orbit-2.0 \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # no *.la for orbit modules
109 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.{la,a}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/festival-synthesis-driver
120 %attr(755,root,root) %{_bindir}/test-speech
121 %attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
122 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so*
123 %{_libdir}/bonobo/servers/*.server
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libgnomespeech.so
128 %{_libdir}/libgnomespeech.la
129 %{_includedir}/gnome-speech-1.0
130 %{_datadir}/idl/gnome-speech-1.0
131 %{_pkgconfigdir}/*.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/lib*.a
136
137 %if %{with java}
138 %files java
139 %defattr(644,root,root,755)
140 %{_datadir}/java/*.jar
141 %endif
This page took 0.088559 seconds and 4 git commands to generate.