]> git.pld-linux.org Git - packages/gnome-speech.git/blob - gnome-speech.spec
- updated to 0.4.10
[packages/gnome-speech.git] / gnome-speech.spec
1 # TODO:
2 # - build other speech plugins?
3 #
4 # Conditional build:
5 %bcond_without  java            # don't build java subpackage
6 #
7 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
8 %undefine       with_java
9 %endif
10 Summary:        GNOME Speech - text-to-speech convertion
11 Summary(pl.UTF-8):      GNOME Speech - przekształcanie tekstu na mowę
12 Name:           gnome-speech
13 Version:        0.4.10
14 Release:        1
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-speech/0.4/%{name}-%{version}.tar.bz2
18 # Source0-md5:  2ec7b7e2b01dd28299bd20fd40668bc5
19 Patch0:         %{name}-jar_dir.patch
20 URL:            http://developer.gnome.org/projects/gap/
21 BuildRequires:  ORBit2-devel >= 1:2.14.7
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  espeak-devel
25 BuildRequires:  gnome-common >= 2.12.0
26 BuildRequires:  gtk-doc >= 1.7
27 %if %{with java}
28 BuildRequires:  jar
29 BuildRequires:  java
30 BuildRequires:  java-access-bridge >= 1.18.0
31 %endif
32 BuildRequires:  libbonobo-devel >= 2.17.92
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 Requires:       festival >= 1.4.2
36 Provides:       gnome_speech
37 Obsoletes:      gnome_speech
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 GNOME Speech purpose is to provide a simple general API for producing
42 text-to-speech output.
43
44 %description -l pl.UTF-8
45 Celem GNOME Speech jest udostępnienie prostego, ogólnego API do
46 przekształcania tekstu na mowę.
47
48 %package devel
49 Summary:        Development files for gnome_speech
50 Summary(pl.UTF-8):      Pliki programistyczne dla gnome_speech
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       libbonobo-devel >= 2.17.92
54 Provides:       gnome_speech-devel
55 Obsoletes:      gnome_speech-devel
56
57 %description devel
58 GNOME Speech files needed for development.
59
60 %description devel -l pl.UTF-8
61 Pliki GNOME Speech potrzebne do programowania.
62
63 %package static
64 Summary:        Static gnome-speech library
65 Summary(pl.UTF-8):      Statyczna biblioteka gnome-speech
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static gnome-speech library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka gnome-speech.
74
75 %package java
76 Summary:        Java classes for gnome-speech
77 Summary(pl.UTF-8):      Klasy Java dla gnome-speech
78 Group:          Development/Libraries
79
80 %description java
81 Java classes for gnome-speech.
82
83 %description java -l pl.UTF-8
84 Klasy Java dla gnome-speech.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoheader}
94 %{__automake}
95 %{__autoconf}
96 %configure \
97         --enable-static \
98         --enable-gtk-doc \
99         --with-speech-dispatcher \
100         %{?with_java:--with-jab-dir=%{_javadir}}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         orbittypelibdir=%{_libdir}/orbit-2.0 \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # no *.la for orbit modules
111 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.{la,a}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/espeak-synthesis-driver
122 %attr(755,root,root) %{_bindir}/festival-synthesis-driver
123 %attr(755,root,root) %{_bindir}/speechd-synthesis-driver
124 %attr(755,root,root) %{_bindir}/test-speech
125 %attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
126 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so*
127 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
128 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
129 %{_libdir}/bonobo/servers/GNOME_Speech_SynthDriver_Speech_Dispatcher.server
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libgnomespeech.so
134 %{_libdir}/libgnomespeech.la
135 %{_includedir}/gnome-speech-1.0
136 %{_datadir}/idl/gnome-speech-1.0
137 %{_pkgconfigdir}/*.pc
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*.a
142
143 %if %{with java}
144 %files java
145 %defattr(644,root,root,755)
146 %{_javadir}/*.jar
147 %endif
This page took 0.064396 seconds and 3 git commands to generate.