]> git.pld-linux.org Git - packages/gnome-speech.git/blob - gnome-speech.spec
- up to 0.4.25
[packages/gnome-speech.git] / gnome-speech.spec
1 # TODO:
2 # - build other speech plugins? (freetts, proprietary: viavoice, loquendo, dectalk, swift, theta, eloquence)
3 #
4 # Conditional build:
5 %bcond_without  festival        # Festival plugin
6 %bcond_without  java            # java subpackage
7 %bcond_without  static_libs     # static library
8
9 # requires Java >= 1.4 < 10 (idlj removed in Java 11, javah in Java 10)
10 %define         use_jdk         openjdk8
11
12 Summary:        GNOME Speech - text-to-speech convertion
13 Summary(pl.UTF-8):      GNOME Speech - przekształcanie tekstu na mowę
14 Name:           gnome-speech
15 Version:        0.4.25
16 Release:        1
17 License:        LGPL v2+
18 Group:          Libraries
19 Source0:        https://download.gnome.org/sources/gnome-speech/0.4/%{name}-%{version}.tar.bz2
20 # Source0-md5:  89cbc23fc131c33396c0346085759f63
21 Patch0:         %{name}-jar_dir.patch
22 Patch1:         %{name}-common.patch
23 URL:            https://www.gnome.org/
24 BuildRequires:  ORBit2-devel >= 1:2.14.7
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  espeak-devel
28 BuildRequires:  gnome-common >= 2.18.0
29 BuildRequires:  gtk-doc >= 1.8
30 %if %{with java}
31 BuildRequires:  java-access-bridge >= 1.18.0
32 %buildrequires_jdk
33 %endif
34 BuildRequires:  libbonobo >= 2.18.0
35 BuildRequires:  libbonobo-devel >= 2.18.0
36 BuildRequires:  libtool
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(macros) >= 2.021
39 Requires:       gnome-speech-driver
40 Provides:       gnome_speech
41 Obsoletes:      gnome_speech < 0.2.2
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GNOME Speech purpose is to provide a simple general API for producing
46 text-to-speech output.
47
48 %description -l pl.UTF-8
49 Celem GNOME Speech jest udostępnienie prostego, ogólnego API do
50 przekształcania tekstu na mowę.
51
52 %package driver-espeak
53 Summary:        Espeak TTS Speech Driver
54 Summary(pl.UTF-8):      Sterownik mowy ESpeak TTS
55 Group:          Libraries
56 Requires:       espeak
57 Provides:       gnome-speech-driver
58
59 %description driver-espeak
60 Provides text to speech services using the Espeak Speech Synthesis
61 System.
62
63 %description driver-espeak -l pl.UTF-8
64 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
65 użyciu systemu syntezy mowy Espeak.
66
67 %package driver-festival
68 Summary:        Festival TTS Speech Driver
69 Summary(pl.UTF-8):      Sterownik mowy Festival TTS
70 Group:          Libraries
71 Requires:       festival
72 Provides:       gnome-speech-driver
73
74 %description driver-festival
75 Provides the text to speech services using the Festival Speech
76 Synthesis System.
77
78 %description driver-festival -l pl.UTF-8
79 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
80 użyciu systemu syntezy mowy Festival.
81
82 %package driver-speech-dispatcher
83 Summary:        Speech Dispatcher driver
84 Summary(pl.UTF-8):      Sterownik mowy Speech Dispatcher
85 Group:          Libraries
86 Provides:       gnome-speech-driver
87
88 %description driver-speech-dispatcher
89 Provides the text to speech services using Speech Dispatcher.
90
91 %description driver-speech-dispatcher -l pl.UTF-8
92 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
93 użyciu systemu Speech Dispatcher.
94
95 %package devel
96 Summary:        Development files for gnome_speech
97 Summary(pl.UTF-8):      Pliki programistyczne dla gnome_speech
98 Group:          Development/Libraries
99 Requires:       %{name} = %{version}-%{release}
100 Requires:       libbonobo-devel >= 2.18.0
101 Provides:       gnome_speech-devel
102 Obsoletes:      gnome_speech-devel < 0.2.2
103
104 %description devel
105 GNOME Speech files needed for development.
106
107 %description devel -l pl.UTF-8
108 Pliki GNOME Speech potrzebne do programowania.
109
110 %package static
111 Summary:        Static gnome-speech library
112 Summary(pl.UTF-8):      Statyczna biblioteka gnome-speech
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 Static gnome-speech library.
118
119 %description static -l pl.UTF-8
120 Statyczna biblioteka gnome-speech.
121
122 %package java
123 Summary:        Java classes for gnome-speech
124 Summary(pl.UTF-8):      Klasy Java dla gnome-speech
125 Group:          Development/Languages/Java
126 Requires:       jpackage-utils
127
128 %description java
129 Java classes for gnome-speech.
130
131 %description java -l pl.UTF-8
132 Klasy Java dla gnome-speech.
133
134 %prep
135 %setup -q
136 %patch0 -p1
137 %patch1 -p1
138
139 %build
140 %{__libtoolize}
141 %{__aclocal}
142 %{__autoheader}
143 %{__automake}
144 %{__autoconf}
145 %configure \
146         --enable-gtk-doc \
147         %{?with_static_libs:--enable-static} \
148         --with-festival%{!?with_festival:=no} \
149         %{?with_java:--with-jab-dir=%{_javadir}} \
150         --with-java-home=%{java_home} \
151         --with-speech-dispatcher
152
153 %{__make} \
154         espeak_LIBDIR=%{_libdir}
155
156 %install
157 rm -rf $RPM_BUILD_ROOT
158
159 %{__make} install \
160         orbittypelibdir=%{_libdir}/orbit-2.0 \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 # no *.la for orbit modules
164 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
165 %if %{with static_libs}
166 %{__rm} $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.a
167 %endif
168 # obsoleted by pkg-config
169 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgnomespeech.la
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/test-speech
180 %attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libgnomespeech.so.7
182 %attr(755,root,root) %{_libdir}/orbit-2.0/GNOME_Speech_module.so
183
184 %files driver-espeak
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_bindir}/espeak-synthesis-driver
187 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
188
189 %if %{with festival}
190 %files driver-festival
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/festival-synthesis-driver
193 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
194 %endif
195
196 %files driver-speech-dispatcher
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/speechd-synthesis-driver
199 %{_libdir}/bonobo/servers/GNOME_Speech_SynthDriver_Speech_Dispatcher.server
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/libgnomespeech.so
204 %{_includedir}/gnome-speech-1.0
205 %{_datadir}/idl/gnome-speech-1.0
206 %{_pkgconfigdir}/gnome-speech-1.0.pc
207
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libgnomespeech.a
211
212 %if %{with java}
213 %files java
214 %defattr(644,root,root,755)
215 %{_javadir}/*.jar
216 %endif
This page took 0.073952 seconds and 3 git commands to generate.