]> git.pld-linux.org Git - packages/gnome-speech.git/blob - gnome-speech.spec
BR: libbonobo for idl files; rel 6
[packages/gnome-speech.git] / gnome-speech.spec
1 # TODO:
2 # - build other speech plugins?
3 #
4 # Conditional build:
5 %bcond_without  festival        # don't build Festival plugin
6 %bcond_without  java            # don't build java subpackage
7 #
8 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
9 %undefine       with_java
10 %endif
11 Summary:        GNOME Speech - text-to-speech convertion
12 Summary(pl.UTF-8):      GNOME Speech - przekształcanie tekstu na mowę
13 Name:           gnome-speech
14 Version:        0.4.23
15 Release:        6
16 License:        LGPL
17 Group:          Libraries
18 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-speech/0.4/%{name}-%{version}.tar.bz2
19 # Source0-md5:  54041cf87f7de56dd081848e86a08d4c
20 Patch0:         %{name}-jar_dir.patch
21 URL:            http://developer.gnome.org/projects/gap/
22 BuildRequires:  ORBit2-devel >= 1:2.14.7
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  espeak-devel
26 BuildRequires:  gnome-common >= 2.18.0
27 BuildRequires:  gtk-doc >= 1.8
28 %if %{with java}
29 BuildRequires:  java-access-bridge >= 1.18.0
30 BuildRequires:  jdk
31 %endif
32 BuildRequires:  libbonobo >= 2.18.0
33 BuildRequires:  libbonobo-devel >= 2.18.0
34 BuildRequires:  libtool
35 BuildRequires:  pkgconfig
36 Requires:       gnome-speech-driver
37 Provides:       gnome_speech
38 Obsoletes:      gnome_speech
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 GNOME Speech purpose is to provide a simple general API for producing
43 text-to-speech output.
44
45 %description -l pl.UTF-8
46 Celem GNOME Speech jest udostępnienie prostego, ogólnego API do
47 przekształcania tekstu na mowę.
48
49 %package driver-espeak
50 Summary:        Espeak TTS Speech Driver
51 Summary(pl.UTF-8):      Sterownik mowy ESpeak TTS
52 Group:          Libraries
53 Requires:       espeak
54 Provides:       gnome-speech-driver
55
56 %description driver-espeak
57 Provides text to speech services using the Espeak Speech Synthesis
58 System.
59
60 %description driver-espeak -l pl.UTF-8
61 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
62 użyciu systemu syntezy mowy Espeak.
63
64 %package driver-festival
65 Summary:        Festival TTS Speech Driver
66 Summary(pl.UTF-8):      Sterownik mowy Festival TTS
67 Group:          Libraries
68 Requires:       festival
69 Provides:       gnome-speech-driver
70
71 %description driver-festival
72 Provides the text to speech services using the Festival Speech
73 Synthesis System.
74
75 %description driver-festival -l pl.UTF-8
76 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
77 użyciu systemu syntezy mowy Festival.
78
79 %package driver-speech-dispatcher
80 Summary:        Speech Dispatcher driver
81 Summary(pl.UTF-8):      Sterownik mowy Speech Dispatcher
82 Group:          Libraries
83 Provides:       gnome-speech-driver
84
85 %description driver-speech-dispatcher
86 Provides the text to speech services using Speech Dispatcher.
87
88 %description driver-speech-dispatcher -l pl.UTF-8
89 Ten pakiet udostępnia usługę przekształcania tekstu na mowę przy
90 użyciu systemu Speech Dispatcher.
91
92 %package devel
93 Summary:        Development files for gnome_speech
94 Summary(pl.UTF-8):      Pliki programistyczne dla gnome_speech
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       libbonobo-devel >= 2.18.0
98 Provides:       gnome_speech-devel
99 Obsoletes:      gnome_speech-devel
100
101 %description devel
102 GNOME Speech files needed for development.
103
104 %description devel -l pl.UTF-8
105 Pliki GNOME Speech potrzebne do programowania.
106
107 %package static
108 Summary:        Static gnome-speech library
109 Summary(pl.UTF-8):      Statyczna biblioteka gnome-speech
110 Group:          Development/Libraries
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description static
114 Static gnome-speech library.
115
116 %description static -l pl.UTF-8
117 Statyczna biblioteka gnome-speech.
118
119 %package java
120 Summary:        Java classes for gnome-speech
121 Summary(pl.UTF-8):      Klasy Java dla gnome-speech
122 Group:          Development/Languages/Java
123 Requires:       jpackage-utils
124
125 %description java
126 Java classes for gnome-speech.
127
128 %description java -l pl.UTF-8
129 Klasy Java dla gnome-speech.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134
135 %build
136 %{__libtoolize}
137 %{__aclocal}
138 %{__autoheader}
139 %{__automake}
140 %{__autoconf}
141 %configure \
142         --enable-static \
143         --enable-gtk-doc \
144         --with%{!?with_festival:out}-festival \
145         --with-speech-dispatcher \
146         %{?with_java:--with-jab-dir=%{_javadir}}
147 %{__make} \
148         espeak_LIBDIR=%{_libdir}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         orbittypelibdir=%{_libdir}/orbit-2.0 \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 # no *.la for orbit modules
158 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.{la,a}
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/test-speech
169 %attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libgnomespeech.so.?
171 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so*
172
173 %files driver-espeak
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/espeak-synthesis-driver
176 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Espeak.server
177
178 %if %{with festival}
179 %files driver-festival
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_bindir}/festival-synthesis-driver
182 %{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Festival.server
183 %endif
184
185 %files driver-speech-dispatcher
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/speechd-synthesis-driver
188 %{_libdir}/bonobo/servers/GNOME_Speech_SynthDriver_Speech_Dispatcher.server
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libgnomespeech.so
193 %{_libdir}/libgnomespeech.la
194 %{_includedir}/gnome-speech-1.0
195 %{_datadir}/idl/gnome-speech-1.0
196 %{_pkgconfigdir}/*.pc
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/libgnomespeech.a
201
202 %if %{with java}
203 %files java
204 %defattr(644,root,root,755)
205 %{_javadir}/*.jar
206 %endif
This page took 0.062464 seconds and 3 git commands to generate.