]> git.pld-linux.org Git - packages/gnome-speech.git/blob - gnome-speech.spec
04c9f3ba37a8f4fa4382c5b4db5c51b0f92acd44
[packages/gnome-speech.git] / gnome-speech.spec
1
2 # TODO:
3 #       build other speech plugins?
4 #
5 %bcond_with     java            # build java subpackage
6
7 Summary:        GNOME Speech - text-to-speech convertion
8 Summary(pl):    GNOME Speech - przekszta³canie tekstu na mowê
9 Name:           gnome-speech
10 Version:        0.3.7
11 Release:        1
12 License:        LGPL
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-speech/0.3/%{name}-%{version}.tar.bz2
15 # Source0-md5:  0afa367c75288357fa3b8e274e72584d
16 Patch0:         %{name}-jar_dir.patch
17 URL:            http://developer.gnome.org/projects/gap/
18 BuildRequires:  ORBit2-devel >= 1:2.12.1
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  gnome-common >= 2.8.0
22 BuildRequires:  gtk-doc >= 1.3
23 %if %{with java}
24 BuildRequires:  jar
25 BuildRequires:  java
26 BuildRequires:  java-access-bridge
27 %endif
28 BuildRequires:  libbonobo-devel >= 2.8.1
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 Requires:       festival >= 1.4.2
32 Provides:       gnome_speech
33 Obsoletes:      gnome_speech
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 GNOME Speech purpose is to provide a simple general API for producing
38 text-to-speech output.
39
40 %description -l pl
41 Celem GNOME Speech jest udostêpnienie prostego, ogólnego API do
42 przekszta³cania tekstu na mowê.
43
44 %package devel
45 Summary:        Development files for gnome_speech
46 Summary(pl):    Pliki programistyczne dla gnome_speech
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       libbonobo-devel >= 2.8.1
50 Provides:       gnome_speech-devel
51 Obsoletes:      gnome_speech-devel
52
53 %description devel
54 GNOME Speech files needed for development.
55
56 %description devel -l pl
57 Pliki GNOME Speech potrzebne do programowania.
58
59 %package static
60 Summary:        Static gnome-speech library
61 Summary(pl):    Statyczna biblioteka gnome-speech
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static gnome-speech library.
67
68 %description static -l pl
69 Statyczna biblioteka gnome-speech.
70
71 %package java
72 Summary:        Java classes for gnome-speech
73 Summary(pl):    Klasy Java dla gnome-speech
74 Group:          Development/Libraries
75
76 %description java
77 Java classes for gnome-speech.
78
79 %description java -l pl
80 Klasy Java dla gnome-speech.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85
86 %build
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoheader}
90 %{__automake}
91 %{__autoconf}
92 %configure \
93         --enable-static \
94         --enable-gtk-doc \
95         %{?with_java:--with-jab-dir=%{_datadir}/java}
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         orbittypelibdir=%{_libdir}/orbit-2.0 \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # no *.la for orbit modules
106 rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.{la,a}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/festival-synthesis-driver
117 %attr(755,root,root) %{_bindir}/test-speech
118 %attr(755,root,root) %{_libdir}/libgnomespeech.so.*.*.*
119 %attr(755,root,root) %{_libdir}/orbit-2.0/*.so*
120 %{_libdir}/bonobo/servers/*.server
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libgnomespeech.so
125 %{_libdir}/libgnomespeech.la
126 %{_includedir}/gnome-speech-1.0
127 %{_datadir}/idl/gnome-speech-1.0
128 %{_pkgconfigdir}/*.pc
129
130 %files static
131 %defattr(644,root,root,755)
132 %{_libdir}/lib*.a
133
134 %if %{with java}
135 %files java
136 %defattr(644,root,root,755)
137 %{_datadir}/java/*.jar
138 %endif
This page took 0.054085 seconds and 2 git commands to generate.