]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- enable systemd support by default (fallbak to ConsoleKit on runtime)
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  systemd # rely on systemd for session tracking instead of ConsoleKit
4 #
5 Summary:        Window manager and application launcher for GNOME
6 Name:           gnome-shell
7 Version:        3.4.0
8 Release:        2
9 License:        GPL v2+
10 Group:          X11/Window Managers
11 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.4/%{name}-%{version}.tar.xz
12 # Source0-md5:  0f0a063dfe10a399b4280396cd79ae80
13 URL:            http://live.gnome.org/GnomeShell
14 BuildRequires:  NetworkManager-devel >= 0.8.999
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  clutter-devel >= 1.9.16
18 BuildRequires:  dbus-glib-devel
19 BuildRequires:  evolution-data-server-devel >= 3.1.90
20 BuildRequires:  folks-devel >= 0.6.1
21 BuildRequires:  gcr-devel >= 3.3.90
22 BuildRequires:  gettext-devel >= 0.17
23 BuildRequires:  gjs-devel >= 1.31.10
24 BuildRequires:  glib2-devel >= 1:2.31.6
25 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
26 BuildRequires:  gnome-desktop-devel >= 3.1.90
27 BuildRequires:  gnome-menus-devel >= 3.1.90
28 BuildRequires:  gobject-introspection-devel >= 0.10.1
29 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
30 BuildRequires:  gstreamer-devel >= 0.10.21
31 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
32 BuildRequires:  gtk+3-devel >= 3.3.9
33 BuildRequires:  intltool >= 0.40
34 BuildRequires:  json-glib-devel >= 0.13.90
35 BuildRequires:  libcanberra-devel
36 BuildRequires:  libcroco-devel >= 0.6.2
37 BuildRequires:  libgnome-keyring-devel
38 BuildRequires:  libsoup-devel
39 BuildRequires:  libtool >= 2:2.2.6
40 BuildRequires:  libxml2-devel
41 BuildRequires:  mutter-devel >= 3.4.0
42 BuildRequires:  pkgconfig >= 1:0.22
43 BuildRequires:  polkit-devel >= 0.100
44 BuildRequires:  pulseaudio-devel
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  rpmbuild(macros) >= 1.601
47 BuildRequires:  startup-notification-devel >= 0.11
48 %{?with_systemd:BuildRequires:  systemd-devel}
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  telepathy-glib-devel >= 0.17.5
51 BuildRequires:  telepathy-logger-devel >= 0.2.4
52 BuildRequires:  xorg-lib-libXfixes-devel
53 BuildRequires:  xz
54 Requires(post,postun):  glib2 >= 1:2.26.0
55 Requires:       caribou >= 0.3.5
56 Requires:       evolution-data-server >= 3.1.90
57 Requires:       gjs >= 1.31.10
58 Requires:       glib2 >= 1:2.31.6
59 Requires:       gnome-bluetooth-libs >= 3.1.0
60 Requires:       gnome-menus >= 3.1.90
61 Requires:       gnome-settings-daemon >= 3.1.90
62 Requires:       gsettings-desktop-schemas >= 3.1.90
63 Requires:       gtk+3 >= 3.3.9
64 Requires:       mutter >= 3.4.0
65 Requires:       nautilus >= 3.2.0
66 Requires:       telepathy-logger >= 0.2.4
67 Suggests:       gnome-contacts >= 3.2.0
68 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
69 Provides:       gdm-wm = 3.4.0
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %description
73 GNOME Shell is the defining technology of the GNOME 3 desktop user
74 experience. It provides core interface functions like switching to
75 windows and launching applications. GNOME Shell takes advantage of the
76 capabilities of modern graphics hardware and introduces innovative
77 user interface concepts to provide a delightful and easy to use
78 experience.
79
80 %package apidocs
81 Summary:        GNOME Shell API documentation
82 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
83 Group:          Documentation
84 Requires:       gtk-doc-common
85
86 %description apidocs
87 This package provides GNOME Shell API documentation.
88
89 %description apidocs -l pl.UTF-8
90 Ten pakiet dostarcza dokumentację API GNOME Shell.
91
92 %package -n browser-plugin-%{name}
93 Summary:        gnome-shell plugin for WWW browsers
94 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglądarek WWW
95 Group:          X11/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       browser-plugins >= 2.0
98 Requires:       browser-plugins(%{_target_base_arch})
99 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
100 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
101 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
102 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
103
104 %description -n browser-plugin-%{name}
105 gnome-shell plugin for WWW browsers.
106
107 %description -n browser-plugin-%{name} -l pl.UTF-8
108 Wtyczka gnome-shell do przeglądarek WWW.
109
110 %prep
111 %setup -q
112
113 %build
114 %{__intltoolize}
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --with-ca-certificates=/etc/certs/ca-certificates.crt \
122         --enable-gtk-doc \
123         --disable-silent-rules \
124         --disable-static \
125         %{__enable_disable systemd systemd} \
126         --with-html-dir=%{_gtkdocdir}
127 %{__make} -j1
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
132
133 %{__make} install \
134         INSTALL="install -p" \
135         install_sh="install -p" \
136         DESTDIR=$RPM_BUILD_ROOT \
137         mozillalibdir=%{_browserpluginsdir}
138
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/*.la \
140         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %glib_compile_schemas
149
150 %postun
151 if [ "$1" = "0" ]; then
152         %glib_compile_schemas
153 fi
154
155 %post -n browser-plugin-%{name}
156 %update_browser_plugins
157
158 %postun -n browser-plugin-%{name}
159 if [ "$1" = 0 ]; then
160         %update_browser_plugins
161 fi
162
163 %files -f %{name}.lang
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_bindir}/gnome-shell
166 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
167 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
168 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
169 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
170 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
171 %dir %{_libdir}/gnome-shell
172 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
173 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-js.so
174 %{_libdir}/gnome-shell/Gvc-1.0.typelib
175 %{_libdir}/gnome-shell/Shell-0.1.typelib
176 %{_libdir}/gnome-shell/ShellJS-0.1.typelib
177 %{_libdir}/gnome-shell/St-1.0.typelib
178 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
179 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
180 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
181 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
182 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
183 %{_datadir}/gnome-shell
184 %{_desktopdir}/gnome-shell.desktop
185 %{_desktopdir}/gnome-shell-extension-prefs.desktop
186 %{_mandir}/man1/gnome-shell.1*
187
188 %files apidocs
189 %defattr(644,root,root,755)
190 %{_gtkdocdir}/shell
191 %{_gtkdocdir}/st
192
193 %files -n browser-plugin-%{name}
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.049478 seconds and 4 git commands to generate.