]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- merged from DEVEL
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.0.0.1
4 Release:        1
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.0/%{name}-%{version}.tar.bz2
8 # Source0-md5:  f84fd69633f883926b9a0f1bd3c42024
9 URL:            http://live.gnome.org/GnomeShell
10 BuildRequires:  GConf2-devel
11 BuildRequires:  NetworkManager-devel >= 0.8.995
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.10
14 BuildRequires:  clutter-devel >= 1.6.0
15 BuildRequires:  dbus-glib-devel
16 BuildRequires:  evolution-data-server-devel >= 2.91.90
17 BuildRequires:  gettext-devel
18 BuildRequires:  gjs-devel >= 0.7.11
19 BuildRequires:  glib2-devel >= 1:2.28.0
20 BuildRequires:  gnome-bluetooth-devel >= 2.91.5
21 BuildRequires:  gnome-desktop-devel >= 2.91.93
22 BuildRequires:  gnome-menus-devel
23 BuildRequires:  gobject-introspection-devel >= 0.10.1
24 BuildRequires:  gsettings-desktop-schemas-devel >= 2.91.91
25 BuildRequires:  gstreamer-devel >= 0.10.21
26 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
27 BuildRequires:  gtk+3-devel >= 3.0.0
28 BuildRequires:  intltool >= 0.26
29 BuildRequires:  libcanberra-devel
30 BuildRequires:  libcroco-devel
31 BuildRequires:  libtool >= 2:2.2.6
32 BuildRequires:  libxml2-devel
33 BuildRequires:  mutter-devel >= 3.0.0
34 BuildRequires:  pkgconfig >= 1:0.22
35 BuildRequires:  polkit-devel >= 0.100
36 BuildRequires:  pulseaudio-devel
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.601
39 BuildRequires:  startup-notification-devel
40 BuildRequires:  telepathy-glib-devel >= 0.13.12
41 BuildRequires:  telepathy-logger-devel >= 0.2.4
42 BuildRequires:  xorg-lib-libXfixes-devel
43 # for libmozjs.so
44 BuildRequires:  xulrunner-libs
45 Requires(post,postun):  glib2 >= 1:2.26.0
46 Requires(post,preun):   GConf2
47 Requires:       gnome-bluetooth-libs >= 2.91.91-2
48 Requires:       gnome-settings-daemon >= 2.91.8
49 Requires:       gsettings-desktop-schemas >= 0.1.7
50 Requires:       mutter >= 3.0.0
51 %requires_eq    xulrunner-libs
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 GNOME Shell is the defining technology of the GNOME 3 desktop user
56 experience. It provides core interface functions like switching to
57 windows and launching applications. GNOME Shell takes advantage of the
58 capabilities of modern graphics hardware and introduces innovative
59 user interface concepts to provide a delightful and easy to use
60 experience.
61
62 %prep
63 %setup -q
64
65 %build
66 %{__intltoolize}
67 %{__libtoolize}
68 %{__aclocal}
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
73 %configure \
74         --disable-schemas-install \
75         --disable-silent-rules \
76         --disable-static
77 %{__make} -j1
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
86 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
87 #!/bin/sh
88 LD_LIBRARY_PATH=%{_libdir}/xulrunner
89 export LD_LIBRARY_PATH
90 exec %{_bindir}/gnome-shell.bin "${@}"
91 EOF
92 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
93
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la
95
96 %find_lang %{name}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 %gconf_schema_install gnome-shell.schemas
103 %glib_compile_schemas
104
105 %preun
106 %gconf_schema_uninstall gnome-shell.schemas
107
108 %postun
109 if [ "$1" = "0" ]; then
110         %glib_compile_schemas
111 fi
112
113 %files -f %{name}.lang
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_bindir}/gnome-shell
116 %attr(755,root,root) %{_bindir}/gnome-shell.bin
117 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
118 %attr(755,root,root) %{_libdir}/gnome-shell-calendar-server
119 %attr(755,root,root) %{_libdir}/gnome-shell-perf-helper
120 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
121 %dir %{_libdir}/gnome-shell
122 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
123 %{_libdir}/gnome-shell/Gdm-1.0.typelib
124 %{_libdir}/gnome-shell/Gvc-1.0.typelib
125 %{_libdir}/gnome-shell/Shell-0.1.typelib
126 %{_libdir}/gnome-shell/St-1.0.typelib
127 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
128 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
129 %{_datadir}/gnome-shell
130 %{_desktopdir}/gnome-shell.desktop
131 %{_mandir}/man1/gnome-shell.1*
This page took 0.044933 seconds and 4 git commands to generate.