]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- S: gnome-icon-theme-symbolic
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.0.2
4 Release:        3
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.0/%{name}-%{version}.tar.bz2
8 # Source0-md5:  ea5194dc27301ca7ee00a97f5f3ab625
9 URL:            http://live.gnome.org/GnomeShell
10 BuildRequires:  GConf2-devel
11 BuildRequires:  NetworkManager-devel >= 0.8.999
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.10
14 BuildRequires:  clutter-devel >= 1.6.0
15 BuildRequires:  dbus-glib-devel
16 BuildRequires:  evolution-data-server-devel >= 3.0.0
17 BuildRequires:  gettext-devel
18 BuildRequires:  gjs-devel >= 0.7.11
19 BuildRequires:  glib2-devel >= 1:2.28.0
20 BuildRequires:  gnome-bluetooth-devel >= 3.0.0
21 BuildRequires:  gnome-desktop-devel >= 3.0.0
22 BuildRequires:  gnome-menus-devel
23 BuildRequires:  gobject-introspection-devel >= 0.10.1
24 BuildRequires:  gsettings-desktop-schemas-devel >= 3.0.0
25 BuildRequires:  gstreamer-devel >= 0.10.21
26 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
27 BuildRequires:  gtk+3-devel >= 3.0.0
28 BuildRequires:  intltool >= 0.26
29 BuildRequires:  libcanberra-devel
30 BuildRequires:  libcroco-devel
31 BuildRequires:  libtool >= 2:2.2.6
32 BuildRequires:  libxml2-devel
33 BuildRequires:  mutter-devel >= 3.0.1
34 BuildRequires:  pkgconfig >= 1:0.22
35 BuildRequires:  polkit-devel >= 0.100
36 BuildRequires:  pulseaudio-devel
37 BuildRequires:  rpm-pythonprov
38 BuildRequires:  rpmbuild(macros) >= 1.601
39 BuildRequires:  startup-notification-devel
40 BuildRequires:  telepathy-glib-devel >= 0.14.0
41 BuildRequires:  telepathy-logger-devel >= 0.2.4
42 BuildRequires:  xorg-lib-libXfixes-devel
43 # for libmozjs.so
44 BuildRequires:  xulrunner-libs
45 Requires(post,postun):  glib2 >= 1:2.26.0
46 Requires(post,preun):   GConf2
47 Requires:       gnome-bluetooth-libs >= 3.0.0
48 Requires:       gnome-settings-daemon >= 3.0.0
49 Requires:       gsettings-desktop-schemas >= 0.1.7
50 Requires:       mutter >= 3.0.1
51 %requires_eq    xulrunner-libs
52 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 %description
56 GNOME Shell is the defining technology of the GNOME 3 desktop user
57 experience. It provides core interface functions like switching to
58 windows and launching applications. GNOME Shell takes advantage of the
59 capabilities of modern graphics hardware and introduces innovative
60 user interface concepts to provide a delightful and easy to use
61 experience.
62
63 %prep
64 %setup -q
65
66 %build
67 %{__intltoolize}
68 %{__libtoolize}
69 %{__aclocal} -I m4
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
74 %configure \
75         --disable-schemas-install \
76         --disable-silent-rules \
77         --disable-static
78 %{__make} -j1
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
87 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
88 #!/bin/sh
89 LD_LIBRARY_PATH=%{_libdir}/xulrunner
90 export LD_LIBRARY_PATH
91 exec %{_bindir}/gnome-shell.bin "${@}"
92 EOF
93 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
94
95 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la
96
97 %find_lang %{name}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 %gconf_schema_install gnome-shell.schemas
104 %glib_compile_schemas
105
106 %preun
107 %gconf_schema_uninstall gnome-shell.schemas
108
109 %postun
110 if [ "$1" = "0" ]; then
111         %glib_compile_schemas
112 fi
113
114 %files -f %{name}.lang
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/gnome-shell
117 %attr(755,root,root) %{_bindir}/gnome-shell.bin
118 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
119 %attr(755,root,root) %{_libdir}/gnome-shell-calendar-server
120 %attr(755,root,root) %{_libdir}/gnome-shell-perf-helper
121 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
122 %dir %{_libdir}/gnome-shell
123 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
124 %{_libdir}/gnome-shell/Gdm-1.0.typelib
125 %{_libdir}/gnome-shell/Gvc-1.0.typelib
126 %{_libdir}/gnome-shell/Shell-0.1.typelib
127 %{_libdir}/gnome-shell/St-1.0.typelib
128 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
129 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
130 %{_datadir}/gnome-shell
131 %{_desktopdir}/gnome-shell.desktop
132 %{_mandir}/man1/gnome-shell.1*
This page took 0.072417 seconds and 4 git commands to generate.