]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 3.2.0; merged from DEVEL
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.2.0
4 Release:        1
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
8 # Source0-md5:  684d7620f1dfd144b2d97ab970daa1ad
9 URL:            http://live.gnome.org/GnomeShell
10 BuildRequires:  GConf2-devel
11 BuildRequires:  NetworkManager-devel >= 0.8.999
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  clutter-devel >= 1.7.5
15 BuildRequires:  dbus-glib-devel
16 BuildRequires:  evolution-data-server-devel >= 3.1.90
17 BuildRequires:  folks-devel >= 0.6.1
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gjs-devel >= 1.29.18
20 BuildRequires:  glib2-devel >= 1:2.29.10
21 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
22 BuildRequires:  gnome-desktop-devel >= 3.1.90
23 BuildRequires:  gnome-menus-devel >= 3.1.90
24 BuildRequires:  gobject-introspection-devel >= 0.10.1
25 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
26 BuildRequires:  gstreamer-devel >= 0.10.21
27 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
28 BuildRequires:  gtk+3-devel >= 3.0.0
29 BuildRequires:  intltool >= 0.40
30 BuildRequires:  json-glib-devel >= 0.13.90
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libcroco-devel >= 0.6.2
33 BuildRequires:  libgnome-keyring-devel
34 BuildRequires:  libsoup-devel
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  libxml2-devel
37 BuildRequires:  mutter-devel >= 3.2.0
38 BuildRequires:  pkgconfig >= 1:0.22
39 BuildRequires:  polkit-devel >= 0.100
40 BuildRequires:  pulseaudio-devel
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.601
43 BuildRequires:  startup-notification-devel >= 0.11
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  telepathy-glib-devel >= 0.15.5
46 BuildRequires:  telepathy-logger-devel >= 0.2.4
47 BuildRequires:  xorg-lib-libXfixes-devel
48 # for libmozjs.so
49 BuildRequires:  xulrunner-libs
50 BuildRequires:  xz
51 Requires(post,postun):  glib2 >= 1:2.26.0
52 Requires(post,preun):   GConf2
53 Requires:       caribou >= 0.3.5
54 Requires:       evolution-data-server >= 3.1.90
55 Requires:       gnome-bluetooth-libs >= 3.1.0
56 Requires:       gnome-settings-daemon >= 3.1.90
57 Requires:       gsettings-desktop-schemas >= 3.1.90
58 Requires:       mutter >= 3.1.91.1
59 %requires_eq    xulrunner-libs
60 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 GNOME Shell is the defining technology of the GNOME 3 desktop user
65 experience. It provides core interface functions like switching to
66 windows and launching applications. GNOME Shell takes advantage of the
67 capabilities of modern graphics hardware and introduces innovative
68 user interface concepts to provide a delightful and easy to use
69 experience.
70
71 %package -n browser-plugin-%{name}
72 Summary:        gnome-shell plugin for WWW browsers
73 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglÄ…darek WWW
74 Group:          X11/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       browser-plugins >= 2.0
77 Requires:       browser-plugins(%{_target_base_arch})
78 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
79 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
80 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
81 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
82
83 %description -n browser-plugin-%{name}
84 gnome-shell plugin for WWW browsers.
85
86 %description -n browser-plugin-%{name} -l pl.UTF-8
87 Wtyczka gnome-shell do przeglÄ…darek WWW.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__intltoolize}
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
100 %configure \
101         --with-ca-certificates=/etc/certs/ca-certificates.crt \
102         --disable-schemas-install \
103         --disable-silent-rules \
104         --disable-static
105 %{__make} -j1
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT \
113         mozillalibdir=%{_browserpluginsdir}
114
115 # TODO use rpath at link time instead of this hack
116 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
117 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
118 #!/bin/sh
119 LD_LIBRARY_PATH=%{_libdir}/xulrunner
120 export LD_LIBRARY_PATH
121 exec %{_bindir}/gnome-shell.bin "$@"
122 EOF
123 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
124
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la \
126         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 %gconf_schema_install gnome-shell.schemas
135 %glib_compile_schemas
136
137 %preun
138 %gconf_schema_uninstall gnome-shell.schemas
139
140 %postun
141 if [ "$1" = "0" ]; then
142         %glib_compile_schemas
143 fi
144
145 %post -n browser-plugin-%{name}
146 %update_browser_plugins
147
148 %postun -n browser-plugin-%{name}
149 if [ "$1" = 0 ]; then
150         %update_browser_plugins
151 fi
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/gnome-shell
156 %attr(755,root,root) %{_bindir}/gnome-shell.bin
157 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
158 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
159 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
160 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
161 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
162 %dir %{_libdir}/gnome-shell
163 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
164 %{_libdir}/gnome-shell/Gvc-1.0.typelib
165 %{_libdir}/gnome-shell/Shell-0.1.typelib
166 %{_libdir}/gnome-shell/St-1.0.typelib
167 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
168 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
169 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
170 %{_datadir}/gnome-shell
171 %{_desktopdir}/gnome-shell.desktop
172 %{_mandir}/man1/gnome-shell.1*
173
174 %files -n browser-plugin-%{name}
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.0765 seconds and 4 git commands to generate.