]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- R: nautilus, S: gnome-contacts
[packages/gnome-shell.git] / gnome-shell.spec
1 Summary:        Window manager and application launcher for GNOME
2 Name:           gnome-shell
3 Version:        3.2.1
4 Release:        3
5 License:        GPL v2+
6 Group:          X11/Window Managers
7 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.2/%{name}-%{version}.tar.xz
8 # Source0-md5:  9519921d31d8c43d054dbc11e1f0733b
9 URL:            http://live.gnome.org/GnomeShell
10 BuildRequires:  GConf2-devel
11 BuildRequires:  NetworkManager-devel >= 0.8.999
12 BuildRequires:  autoconf >= 2.63
13 BuildRequires:  automake >= 1:1.11
14 BuildRequires:  clutter-devel >= 1.7.5
15 BuildRequires:  dbus-glib-devel
16 BuildRequires:  evolution-data-server-devel >= 3.1.90
17 BuildRequires:  folks-devel >= 0.6.1
18 BuildRequires:  gettext-devel >= 0.17
19 BuildRequires:  gjs-devel >= 1.29.18
20 BuildRequires:  glib2-devel >= 1:2.29.10
21 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
22 BuildRequires:  gnome-desktop-devel >= 3.1.90
23 BuildRequires:  gnome-menus-devel >= 3.1.90
24 BuildRequires:  gobject-introspection-devel >= 0.10.1
25 BuildRequires:  gsettings-desktop-schemas-devel >= 3.1.90
26 BuildRequires:  gstreamer-devel >= 0.10.21
27 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.21
28 BuildRequires:  gtk+3-devel >= 3.0.0
29 BuildRequires:  intltool >= 0.40
30 BuildRequires:  json-glib-devel >= 0.13.90
31 BuildRequires:  libcanberra-devel
32 BuildRequires:  libcroco-devel >= 0.6.2
33 BuildRequires:  libgnome-keyring-devel
34 BuildRequires:  libsoup-devel
35 BuildRequires:  libtool >= 2:2.2.6
36 BuildRequires:  libxml2-devel
37 BuildRequires:  mutter-devel >= 3.2.1
38 BuildRequires:  pkgconfig >= 1:0.22
39 BuildRequires:  polkit-devel >= 0.100
40 BuildRequires:  pulseaudio-devel
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  rpmbuild(macros) >= 1.601
43 BuildRequires:  startup-notification-devel >= 0.11
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  telepathy-glib-devel >= 0.15.5
46 BuildRequires:  telepathy-logger-devel >= 0.2.4
47 BuildRequires:  xorg-lib-libXfixes-devel
48 # for libmozjs.so
49 BuildRequires:  xulrunner-libs
50 BuildRequires:  xz
51 Requires(post,postun):  glib2 >= 1:2.26.0
52 Requires(post,preun):   GConf2
53 Requires:       caribou >= 0.3.5
54 Requires:       evolution-data-server >= 3.1.90
55 Requires:       gnome-bluetooth-libs >= 3.1.0
56 Requires:       gnome-menus >= 3.1.90
57 Requires:       gnome-settings-daemon >= 3.1.90
58 Requires:       gsettings-desktop-schemas >= 3.1.90
59 Requires:       mutter >= 3.2.1
60 Requires:       nautilus >= 3.2.0
61 Requires:       telepathy-logger >= 0.2.4
62 %requires_eq    xulrunner-libs
63 Suggests:       gnome-contacts >= 3.2.0
64 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
65 Provides:       gdm-wm = 3.2.1-1
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 GNOME Shell is the defining technology of the GNOME 3 desktop user
70 experience. It provides core interface functions like switching to
71 windows and launching applications. GNOME Shell takes advantage of the
72 capabilities of modern graphics hardware and introduces innovative
73 user interface concepts to provide a delightful and easy to use
74 experience.
75
76 %package -n browser-plugin-%{name}
77 Summary:        gnome-shell plugin for WWW browsers
78 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglÄ…darek WWW
79 Group:          X11/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       browser-plugins >= 2.0
82 Requires:       browser-plugins(%{_target_base_arch})
83 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
84 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
85 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
86 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
87
88 %description -n browser-plugin-%{name}
89 gnome-shell plugin for WWW browsers.
90
91 %description -n browser-plugin-%{name} -l pl.UTF-8
92 Wtyczka gnome-shell do przeglÄ…darek WWW.
93
94 %prep
95 %setup -q
96
97 %build
98 %{__intltoolize}
99 %{__libtoolize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 export LD_LIBRARY_PATH=%{_libdir}/xulrunner
105 %configure \
106         --with-ca-certificates=/etc/certs/ca-certificates.crt \
107         --disable-schemas-install \
108         --disable-silent-rules \
109         --disable-static
110 %{__make} -j1
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/extensions
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         mozillalibdir=%{_browserpluginsdir}
119
120 # TODO use rpath at link time instead of this hack
121 mv $RPM_BUILD_ROOT%{_bindir}/gnome-shell{,.bin}
122 cat > $RPM_BUILD_ROOT%{_bindir}/gnome-shell <<'EOF'
123 #!/bin/sh
124 LD_LIBRARY_PATH=%{_libdir}/xulrunner
125 export LD_LIBRARY_PATH
126 exec %{_bindir}/gnome-shell.bin "$@"
127 EOF
128 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/gnome-shell
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/libgnome-shell.la \
131         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
132
133 %find_lang %{name}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 %gconf_schema_install gnome-shell.schemas
140 %glib_compile_schemas
141
142 %preun
143 %gconf_schema_uninstall gnome-shell.schemas
144
145 %postun
146 if [ "$1" = "0" ]; then
147         %glib_compile_schemas
148 fi
149
150 %post -n browser-plugin-%{name}
151 %update_browser_plugins
152
153 %postun -n browser-plugin-%{name}
154 if [ "$1" = 0 ]; then
155         %update_browser_plugins
156 fi
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/gnome-shell
161 %attr(755,root,root) %{_bindir}/gnome-shell.bin
162 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
163 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
164 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
165 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
166 %{_sysconfdir}/gconf/schemas/gnome-shell.schemas
167 %dir %{_libdir}/gnome-shell
168 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
169 %{_libdir}/gnome-shell/Gvc-1.0.typelib
170 %{_libdir}/gnome-shell/Shell-0.1.typelib
171 %{_libdir}/gnome-shell/St-1.0.typelib
172 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
173 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
174 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
175 %{_datadir}/gnome-shell
176 %{_desktopdir}/gnome-shell.desktop
177 %{_mandir}/man1/gnome-shell.1*
178
179 %files -n browser-plugin-%{name}
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.072226 seconds and 4 git commands to generate.