]> git.pld-linux.org Git - packages/gnome-shell.git/blob - gnome-shell.spec
- updated to 3.6.0
[packages/gnome-shell.git] / gnome-shell.spec
1 #
2 # Conditional build:
3 %bcond_without  systemd # by default use systemd for session tracking instead of ConsoleKit (fallback to ConsoleKit on runtime)
4 #
5 Summary:        Window manager and application launcher for GNOME
6 Name:           gnome-shell
7 Version:        3.6.0
8 Release:        1
9 License:        GPL v2+
10 Group:          X11/Window Managers
11 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gnome-shell/3.6/%{name}-%{version}.tar.xz
12 # Source0-md5:  cf6b87fd37329573c322b384c1593e17
13 URL:            http://live.gnome.org/GnomeShell
14 BuildRequires:  NetworkManager-devel >= 0.8.999
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  clutter-devel >= 1.11.11
18 BuildRequires:  dbus-glib-devel
19 BuildRequires:  evolution-data-server-devel >= 3.5.3
20 BuildRequires:  gcr-devel >= 3.3.90
21 BuildRequires:  gettext-devel >= 0.17
22 BuildRequires:  gjs-devel >= 1.33.2
23 BuildRequires:  glib2-devel >= 1:2.31.6
24 BuildRequires:  gnome-bluetooth-devel >= 3.1.0
25 BuildRequires:  gnome-desktop-devel >= 3.5.1
26 BuildRequires:  gnome-menus-devel >= 3.5.3
27 BuildRequires:  gobject-introspection-devel >= 0.10.1
28 BuildRequires:  gsettings-desktop-schemas-devel >= 3.5.4
29 BuildRequires:  gstreamer-devel >= 1.0.0
30 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
31 BuildRequires:  gtk+3-devel >= 3.3.9
32 BuildRequires:  gtk-doc >= 1.15
33 BuildRequires:  intltool >= 0.40
34 BuildRequires:  json-glib-devel >= 0.13.90
35 BuildRequires:  libcanberra-devel
36 BuildRequires:  libcroco-devel >= 0.6.2
37 BuildRequires:  libgnome-keyring-devel
38 BuildRequires:  libsoup-devel
39 BuildRequires:  libtool >= 2:2.2.6
40 BuildRequires:  libxml2-devel
41 BuildRequires:  mutter-devel >= 3.6.0
42 BuildRequires:  pkgconfig >= 1:0.22
43 BuildRequires:  polkit-devel >= 0.100
44 BuildRequires:  pulseaudio-devel
45 BuildRequires:  rpm-pythonprov
46 BuildRequires:  rpmbuild(macros) >= 1.601
47 BuildRequires:  startup-notification-devel >= 0.11
48 %{?with_systemd:BuildRequires:  systemd-devel}
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  telepathy-glib-devel >= 0.17.5
51 BuildRequires:  telepathy-logger-devel >= 0.2.4
52 BuildRequires:  xorg-lib-libXfixes-devel
53 BuildRequires:  xz
54 Requires(post,postun):  glib2 >= 1:2.26.0
55 Requires:       at-spi2-atk >= 2.4.0
56 Requires:       caribou >= 0.3.5
57 Requires:       evolution-data-server >= 3.5.3
58 Requires:       gjs >= 1.33.2
59 Requires:       glib2 >= 1:2.31.6
60 Requires:       gnome-bluetooth-libs >= 3.1.0
61 Requires:       gnome-menus >= 3.5.3
62 Requires:       gnome-settings-daemon >= 3.1.90
63 Requires:       gsettings-desktop-schemas >= 3.5.4
64 Requires:       gtk+3 >= 3.3.9
65 Requires:       mutter >= 3.6.0
66 Requires:       nautilus >= 3.2.0
67 Requires:       telepathy-logger >= 0.2.4
68 Requires:       telepathy-mission-control
69 Suggests:       gnome-contacts >= 3.2.0
70 Suggests:       gnome-icon-theme-symbolic >= 3.0.0
71 Provides:       gdm-wm = 3.6.0
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 GNOME Shell is the defining technology of the GNOME 3 desktop user
76 experience. It provides core interface functions like switching to
77 windows and launching applications. GNOME Shell takes advantage of the
78 capabilities of modern graphics hardware and introduces innovative
79 user interface concepts to provide a delightful and easy to use
80 experience.
81
82 %package apidocs
83 Summary:        GNOME Shell API documentation
84 Summary(pl.UTF-8):      Dokumentacja API GNOME Shell
85 Group:          Documentation
86 Requires:       gtk-doc-common
87
88 %description apidocs
89 This package provides GNOME Shell API documentation.
90
91 %description apidocs -l pl.UTF-8
92 Ten pakiet dostarcza dokumentację API GNOME Shell.
93
94 %package -n browser-plugin-%{name}
95 Summary:        gnome-shell plugin for WWW browsers
96 Summary(pl.UTF-8):      Wtyczka gnome-shell do przeglądarek WWW
97 Group:          X11/Libraries
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       browser-plugins >= 2.0
100 Requires:       browser-plugins(%{_target_base_arch})
101 Provides:       mozilla-firefox-plugin-gnome-shell = %{version}-%{release}
102 Provides:       mozilla-plugin-gnome-shell = %{version}-%{release}
103 Obsoletes:      mozilla-firefox-plugin-gnome-shell < %{version}-%{release}
104 Obsoletes:      mozilla-plugin-gnome-shell < %{version}-%{release}
105
106 %description -n browser-plugin-%{name}
107 gnome-shell plugin for WWW browsers.
108
109 %description -n browser-plugin-%{name} -l pl.UTF-8
110 Wtyczka gnome-shell do przeglądarek WWW.
111
112 %prep
113 %setup -q
114
115 %build
116 %{__intltoolize}
117 %{__libtoolize}
118 %{__aclocal} -I m4
119 %{__autoconf}
120 %{__autoheader}
121 %{__automake}
122 %configure \
123         --with-ca-certificates=/etc/certs/ca-certificates.crt \
124         --enable-gtk-doc \
125         --disable-silent-rules \
126         --disable-static \
127         %{__enable_disable systemd systemd} \
128         --with-html-dir=%{_gtkdocdir}
129 %{__make} -j1
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 install -d $RPM_BUILD_ROOT%{_datadir}/gnome-shell/{extensions,search-providers}
134
135 %{__make} install \
136         INSTALL="install -p" \
137         install_sh="install -p" \
138         DESTDIR=$RPM_BUILD_ROOT \
139         mozillalibdir=%{_browserpluginsdir}
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-shell/*.la \
142         $RPM_BUILD_ROOT%{_browserpluginsdir}/*.la
143
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 %glib_compile_schemas
151
152 %postun
153 if [ "$1" = "0" ]; then
154         %glib_compile_schemas
155 fi
156
157 %post -n browser-plugin-%{name}
158 %update_browser_plugins
159
160 %postun -n browser-plugin-%{name}
161 if [ "$1" = 0 ]; then
162         %update_browser_plugins
163 fi
164
165 %files -f %{name}.lang
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/gnome-shell
168 %attr(755,root,root) %{_bindir}/gnome-shell-extension-prefs
169 %attr(755,root,root) %{_bindir}/gnome-shell-extension-tool
170 %attr(755,root,root) %{_bindir}/gnome-shell-perf-tool
171 %attr(755,root,root) %{_libexecdir}/gnome-shell-calendar-server
172 %attr(755,root,root) %{_libexecdir}/gnome-shell-hotplug-sniffer
173 %attr(755,root,root) %{_libexecdir}/gnome-shell-perf-helper
174 %dir %{_libdir}/gnome-shell
175 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell.so
176 %attr(755,root,root) %{_libdir}/gnome-shell/libgnome-shell-js.so
177 %{_libdir}/gnome-shell/Gvc-1.0.typelib
178 %{_libdir}/gnome-shell/Shell-0.1.typelib
179 %{_libdir}/gnome-shell/ShellJS-0.1.typelib
180 %{_libdir}/gnome-shell/St-1.0.typelib
181 %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
182 %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
183 %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
184 %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
185 %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
186 %{_datadir}/gnome-shell
187 %{_desktopdir}/evolution-calendar.desktop
188 %{_desktopdir}/gnome-shell.desktop
189 %{_desktopdir}/gnome-shell-extension-prefs.desktop
190 %{_mandir}/man1/gnome-shell.1*
191
192 %files apidocs
193 %defattr(644,root,root,755)
194 %{_gtkdocdir}/shell
195 %{_gtkdocdir}/st
196
197 %files -n browser-plugin-%{name}
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_browserpluginsdir}/libgnome-shell-browser-plugin.so
This page took 0.069073 seconds and 3 git commands to generate.