]> git.pld-linux.org Git - packages/gmp.git/blob - gmp.spec
- "s-/usr/lib/-%{_libdir}-"
[packages/gmp.git] / gmp.spec
1 Summary:        GNU arbitrary precision library
2 Summary(pl):    Biblioteka arytmetyczna GNU
3 Name:           gmp
4 Version:        2.0.2
5 Release:        10
6 Copyright:      LGPL 
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 URL:            http://www.matematik.su.se/~tege/gmp/
10 Source:         ftp://ftp.gnu.org/pub/gnu/%{name}-%{version}.tar.gz
11 Patch0:         gmp-shared.patch
12 Patch1:         http://www.matematik.su.se/~tege/gmp/mpf-conversions.diff.gz
13 Patch2:         http://www.matematik.su.se/~tege/gmp/gmp2.0.2p2.txt
14 Patch3:         http://www.matematik.su.se/~tege/gmp/gmp2.0.2p3.txt
15 Patch4:         http://www.matematik.su.se/~tege/gmp/gmp2.0.2p4.txt
16 Patch5:         http://www.matematik.su.se/~tege/gmp/gmp2.0.2p5.txt
17 Patch6:         http://www.matematik.su.se/~tege/gmp/gmp2.0.2p6.txt
18 Patch7:         http://www.matematik.su.se/~tege/gmp/gmp2.0.2p7.txt
19 Patch8:         gmp-powerpc.patch
20 Patch9:         gmp-info.patch
21 BuildRoot:      /tmp/%{name}-%{version}-root
22
23 %description
24 This is the GNU arbitrary precision library. Linking against it gives access
25 to functions for handling arbitrarily large numbers with either a high level
26 or a low level interface.
27
28 %description -l pl
29
30 Pakiet zawiera bibliotekê arytmetyczn± wysokiej precyzji. Daje ona dostêp do
31 szerokiego grona szybkich funkcji arytmetycznych dzia³aj±cych na liczbach
32 ca³kowitych, rzeczywistych i zmiennoprzecinkowych.
33
34 %package devel
35 Summary:        GNU Arbitrary Precision header files, static libraries, and documentation.
36 Summary(pl):    Pliki nag³ówkowe i dokumentacja.
37 Group:          Libraries
38 PreReq:         /sbin/install-info
39
40 %description devel
41 These are the static libraries, header files, and documentation for using
42 the GNU arbitrary precision library in your own programs. With these, you
43 can create your own own programs that use this library.
44
45 %description -l pl devel
46 Pliko nag³ówkowe i dokumentacji do gmp. Dziêki temu pakietowi bêdziesz
47 móg³ tworzyæ w³asne programy z wykorzystaniem bblioteki arbitralnej z GNU.
48
49 %package static
50 Summary:        GNU Arbitrary Precision static library.
51 Summary(pl):    Biblioteka statyczna.
52 Group:          Libraries
53 Requires:       %{name} = %{version} 
54
55 %description static
56 Static library
57
58 %description -l pl static
59 Biblioteka statyczna.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65 cd mpq
66 %patch2 -p0
67 cd ../mpn
68 %patch3 -p0
69 cd ../mpz/tests
70 %patch4 -p0
71 cd ../..
72 %patch5 -p1
73 cd mpq
74 %patch6 -p0
75 cd ../mpz
76 %patch7 -p0
77 cd ..
78 %patch8 -p1
79 %patch9 -p1
80
81 %build
82 ./configure %{_target} \
83         --prefix=/usr
84 make CC="gcc" CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s"
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 make install \
90         prefix=$RPM_BUILD_ROOT/usr
91
92 install mpn/gmp-mparam.h ${RPM_BUILD_ROOT}/usr/include/
93
94 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
95
96 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/gmp.info*
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %post devel
102 /sbin/install-info %{_infodir}/gmp.info.gz /usr/info/dir
103
104 %preun devel
105 if [ "$1" = 0 ]; then
106         /sbin/install-info --delete %{_infodir}/gmp.info.gz /etc/info-dir
107 fi
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/lib*.so.*.*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %doc SPEED NEWS README
119 %attr(755,root,root) %{_libdir}/lib*.so
120 /usr/include/*
121 %{_infodir}/gmp.info*
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/lib*.a
126
127 %changelog
128 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
129   [2.0.2-10]
130 - standarized {un}registering info pages (added gmp-info.patch),
131 - /sbin/ldconfig is now runed as -p parameter in %post{un},
132 - added static subpackage,
133 - added stripping shared libraries.
134
135 * Sat Mar 14 1999 David Kuestler <kuestler@zeta.org.au>
136 - Patch for PowerPC ( Power Mac )
137
138 * Thu Feb 18 1999 Toshio Kuratomi <badger@prtr-13.ucsc.edu>
139 - Add bugfix patches from gmp homepage. (These are supposed to go into
140   gmp-2.0.3 when it is finally released.)
141 - Change the files section to use %attr tags (now buildable by non-root)
142 - Add a Prefix: tag.
143 - Change the Copyright to LGPL.
144 - Change the URL to the gmp homepage.
145
146 * Thu Feb 11 1999 Michael Johnson <johnsonm@redhat.com>
147 - include the private header file gmp-mparam.h because several
148   apps seem to assume that they are building against the gmp
149   source tree and require it.  Sigh.
150
151 * Tue Jan 12 1999 Michael K. Johnson <johnsonm@redhat.com>
152 - libtoolize to work on arm
153
154 * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
155 - yet another touch of the spec file
156
157 * Wed Sep  2 1998 Michael Fulbright <msf@redhat.com>
158 - looked over before inclusion in RH 5.2
159
160 * Sat May 24 1998 Dick Porter <dick@cymru.net>
161 - Patch Makefile.in, not Makefile
162 - Don't specify i586, let configure decide the arch
163
164 * Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
165 - started with package from Toshio Kuratomi <toshiok@cats.ucsc.edu>
166 - cleaned up file list
167 - fixed up install-info support
This page took 0.046574 seconds and 4 git commands to generate.