]> git.pld-linux.org Git - SPECS.git/blob - gmerlin-avdecoder.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / gmerlin-avdecoder.spec
1 # NOTE: internal gsm610 lib is significantly modified
2 #
3 # Conditional build:
4 %bcond_without  apidocs         # without doc
5 %bcond_without  smb             # SMB support
6 %bcond_with     vdpau           # VDPAU support
7 #
8 Summary:        Multiformat media decoding library
9 Summary(pl.UTF-8):      Biblioteka dekodująca wiele formatów multimedialnych
10 Name:           gmerlin-avdecoder
11 Version:        1.2.0
12 Release:        16
13 License:        GPL v2+
14 Group:          Libraries
15 Source0:        http://downloads.sourceforge.net/gmerlin/%{name}-%{version}.tar.gz
16 # Source0-md5:  37b19266b098d9d05bb05ebef138ffbd
17 Patch0:         %{name}-cflags.patch
18 Patch1:         %{name}-ffmpeg-0.8.patch
19 Patch2:         %{name}-link.patch
20 Patch3:         %{name}-am.patch
21 Patch4:         %{name}-ffmpeg2.patch
22 Patch5:         ffmpeg3.patch
23 Patch6:         ffmpeg4.patch
24 URL:            http://gmerlin.sourceforge.net/avdec_frame.html
25 BuildRequires:  a52dec-libs-devel >= 0.7.4
26 BuildRequires:  autoconf >= 2.50
27 BuildRequires:  automake >= 1:1.8.5
28 %{?with_apidocs:BuildRequires:  doxygen}
29 BuildRequires:  faad2-devel >= 2.0
30 # avcodec build >= 3412992, avformat build >= 3415808, libpostproc >= 51.0.0, libswscale >= 0.5.0
31 BuildRequires:  ffmpeg-devel >= 0.7
32 BuildRequires:  flac-devel >= 1.2.0
33 BuildRequires:  gavl-devel >= 1.4.0
34 BuildRequires:  gettext-tools
35 BuildRequires:  gmerlin-devel >= 1.2.0
36 BuildRequires:  libcdio-devel >= 0.76
37 BuildRequires:  libdts-devel >= 0.0.2
38 # requires DVDREAD_VERSION >= 905; in case of 4.x series it's 4.2.0-1 (as in Th)
39 BuildRequires:  libdvdread-devel >= 0.9.5
40 BuildRequires:  libmad-devel >= 0.15.0
41 BuildRequires:  libmpcdec-devel >= 1.1
42 BuildRequires:  libmpeg2-devel >= 0.4.0
43 BuildRequires:  libogg-devel >= 1:1.1
44 BuildRequires:  libpng-devel >= 1.2.2
45 %{?with_smb:BuildRequires:      libsmbclient-devel >= 3.0.0}
46 BuildRequires:  libtheora-devel >= 1.0.0
47 BuildRequires:  libtiff-devel >= 3.5.0
48 BuildRequires:  libtool
49 BuildRequires:  libvdpau-devel
50 BuildRequires:  libvorbis-devel >= 1:1.0
51 BuildRequires:  mjpegtools-devel >= 1.9.0
52 BuildRequires:  openjpeg-devel >= 1.3
53 BuildRequires:  pkgconfig >= 1:0.9.0
54 BuildRequires:  schroedinger-devel >= 1.0.5
55 BuildRequires:  speex-devel >= 1.0.4
56 BuildRequires:  xorg-lib-libX11-devel >= 1.0.0
57 BuildRequires:  xorg-lib-libXext-devel
58 BuildRequires:  zlib-devel
59 Requires:       a52dec-libs >= 0.7.4
60 Requires:       faad2-libs >= 2.0
61 Requires:       ffmpeg-libs >= 0.7
62 Requires:       flac >= 1.2.0
63 Requires:       gavl >= 1.4.0
64 Requires:       libcdio >= 0.76
65 Requires:       libdts >= 0.0.2
66 Requires:       libdvdread >= 0.9.5
67 Requires:       libmad >= 0.15.0
68 Requires:       libmpcdec >= 1.1
69 Requires:       libmpeg2 >= 0.4.0
70 Requires:       libogg >= 1:1.1
71 Requires:       libpng >= 1.2.2
72 %{?with_smb:Requires:   libsmbclient >= 3.0.0}
73 Requires:       libtheora >= 1.0.0
74 Requires:       libtiff >= 3.5.0
75 Requires:       libvorbis >= 1:1.0
76 Requires:       mjpegtools-libs >= 1.9.0
77 Requires:       openjpeg >= 1.3
78 Requires:       schroedinger >= 1.0.5
79 Requires:       speex >= 1.0.4
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         specflags       -fomit-frame-pointer -ffast-math
83
84 %description
85 General purpose media decoding library. It is one of the most complete
86 general purpose media decoding libraries. The supported formats and
87 codecs span a wide range of applications from consumer level (mp3,
88 divx etc.) to high end production formats like 32 bit PCM and some
89 professional uncompressed video codecs.
90
91 %description -l pl.UTF-8
92 Ogólnego przeznaczenia biblioteka dekodująca multimedia. Jest to jedna
93 z najbardziej kompletnych bibliotek tego typu. Obsługiwane formaty
94 obejmują wiele zastosowań od poziomu konsumenckiego (mp3, divx itp.)
95 do formatów wysokiej jakości produkcji, jak 32-bitowy PCM i różne
96 profesjonalne kodeki obrazu bez kompresji.
97
98 %package devel
99 Summary:        Header files for gmerlin_avdec library
100 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gmerlin_avdec
101 Group:          Development/Libraries
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       a52dec-libs-devel >= 0.7.4
104 Requires:       faad2-devel >= 2.0
105 Requires:       ffmpeg-devel >= 0.7
106 Requires:       flac-devel >= 1.2.0
107 Requires:       gavl-devel >= 1.4.0
108 Requires:       libcdio-devel >= 0.76
109 Requires:       libdts-devel >= 0.0.2
110 Requires:       libdvdread-devel >= 0.9.5
111 Requires:       libmad-devel >= 0.15.0
112 Requires:       libmpcdec-devel >= 1.1
113 Requires:       libmpeg2-devel >= 0.4.0
114 Requires:       libogg-devel >= 1:1.1
115 Requires:       libpng-devel >= 1.2.2
116 %{?with_smb:Requires:   libsmbclient-devel >= 3.0.0}
117 Requires:       libtheora-devel >= 1.0.0
118 Requires:       libtiff-devel >= 3.5.0
119 Requires:       libvdpau-devel
120 Requires:       libvorbis-devel >= 1:1.0
121 Requires:       mjpegtools-devel >= 1.9.0
122 Requires:       openjpeg-devel >= 1.3
123 Requires:       schroedinger-devel >= 1.0.5
124 Requires:       speex-devel >= 1.0.4
125 Requires:       xorg-lib-libX11-devel >= 1.0.0
126 Requires:       xorg-lib-libXext-devel
127 Requires:       zlib-devel
128
129 %description devel
130 Header files for gmerlin_avdec library.
131
132 %description devel -l pl.UTF-8
133 Pliki nagłówkowe biblioteki gmerlin_avdec.
134
135 %package static
136 Summary:        Static gmerlin_avdec library
137 Summary(pl.UTF-8):      Statyczna biblioteka gmerlin_avdec
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140
141 %description static
142 Static gmerlin_avdec library.
143
144 %description static -l pl.UTF-8
145 Statyczna biblioteka gmerlin_avdec.
146
147 %package -n gmerlin-plugin-avdec
148 Summary:        avdec plugins for Gmerlin library
149 Summary(pl.UTF-8):      Wtyczki avdec dla biblioteki Gmerlin
150 Group:          Libraries
151 Requires:       %{name} = %{version}-%{release}
152 Requires:       gmerlin >= 1.2.0
153
154 %description -n gmerlin-plugin-avdec
155 avdec plugins for Gmerlin library.
156
157 %description -n gmerlin-plugin-avdec -l pl.UTF-8
158 Wtyczki avdec dla biblioteki Gmerlin.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165 %patch3 -p1
166 %patch4 -p1
167 %patch5 -p1
168 %patch6 -p1
169
170 %build
171 %{__libtoolize}
172 %{__aclocal} -I m4
173 %{__autoconf}
174 %{__autoheader}
175 %{__automake}
176 %configure \
177         %{!?with_smb:--disable-samba} \
178         %{!?with_vdpau:--disable-vdpau} \
179         --enable-static \
180         %{!?with_apidocs:--without-doxygen} \
181         --with-cpuflags=none
182 %{__make}
183
184 %install
185 rm -rf $RPM_BUILD_ROOT
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 # .la kept for now - .pc is missing proper {Libs,Requires}.private
191 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgmerlin_avdec.la
192 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gmerlin/plugins/*.{la,a}
193 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/share/doc/%{name}/apiref
194
195 %find_lang %{name}
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %post   -p /sbin/ldconfig
201 %postun -p /sbin/ldconfig
202
203 %files -f %{name}.lang
204 %defattr(644,root,root,755)
205 %doc AUTHORS NEWS README
206 %attr(755,root,root) %{_bindir}/bgavdemux
207 %attr(755,root,root) %{_bindir}/bgavdump
208 %attr(755,root,root) %{_libdir}/libgmerlin_avdec.so.*.*.*
209 %attr(755,root,root) %ghost %{_libdir}/libgmerlin_avdec.so.1
210
211 %files devel
212 %defattr(644,root,root,755)
213 %{?with_apidocs:%doc doc/apiref}
214 %attr(755,root,root) %{_libdir}/libgmerlin_avdec.so
215 %{_libdir}/libgmerlin_avdec.la
216 # NOTE: dir shared with gmerlin-devel
217 %dir %{_includedir}/gmerlin
218 %{_includedir}/gmerlin/avdec.h
219 %{_includedir}/gmerlin/bgav_version.h
220 %{_includedir}/gmerlin/bgavdefs.h
221 %{_pkgconfigdir}/gmerlin_avdec.pc
222
223 %files static
224 %defattr(644,root,root,755)
225 %{_libdir}/libgmerlin_avdec.a
226
227 %files -n gmerlin-plugin-avdec
228 %defattr(644,root,root,755)
229 # no reason for separate packages:
230 # all plugins make use of just libgmerlin_avcodec (external libs not linked directly)
231 %attr(755,root,root) %{_libdir}/gmerlin/plugins/i_avdec.so
232 %attr(755,root,root) %{_libdir}/gmerlin/plugins/i_dvb.so
233 %attr(755,root,root) %{_libdir}/gmerlin/plugins/i_dvd.so
234 %attr(755,root,root) %{_libdir}/gmerlin/plugins/i_vcd.so
This page took 0.360716 seconds and 3 git commands to generate.