]> git.pld-linux.org Git - SPECS.git/blob - glyphy.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / glyphy.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        High-quality glyph rendering library using OpenGL ES2 shaders
6 Summary(pl.UTF-8):      Biblioteka wysokiej jakości renderowania glifów przy użyciu shaderów OpenGL ES2
7 Name:           glyphy
8 Version:        0.2.0
9 %define snap    20151002
10 %define gitref  71390c5baccbe2bcba19171d1e31732a49c35fa3
11 %define rel     1
12 Release:        0.%{snap}.%{rel}
13 License:        Apache v2.0
14 Group:          Libraries
15 Source0:        https://github.com/behdad/glyphy/archive/%{gitref}/%{name}-%{snap}.tar.gz
16 # Source0-md5:  295ee71482abf9b3c4798d6955bc0b6a
17 Patch0:         %{name}-default-font.patch
18 URL:            http://glyphy.org/
19 BuildRequires:  OpenGL-devel
20 BuildRequires:  OpenGL-glut-devel
21 BuildRequires:  autoconf >= 2.64
22 BuildRequires:  automake >= 1:1.11.1
23 BuildRequires:  freetype-devel >= 2
24 BuildRequires:  glew-devel
25 BuildRequires:  libtool >= 2:2.2
26 BuildRequires:  pkgconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 GLyphy is a signed-distance-field (SDF) text renderer using OpenGL ES2
31 shading language.
32
33 %description -l pl.UTF-8
34 GLyphy to biblioteka renderująca tekst metodą SDF (signed distance
35 field) przy użyciu języka cieniującego OpenGL ES2.
36
37 %package devel
38 Summary:        Header files for GLyphy library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GLyphy
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       freetype-devel >= 2
43
44 %description devel
45 Header files for GLyphy library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki GLyphy.
49
50 %package static
51 Summary:        Static GLyphy library
52 Summary(pl.UTF-8):      Statyczna biblioteka GLyphy
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static GLyphy library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka GLyphy.
61
62 %prep
63 %setup -q -n %{name}-%{gitref}
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         DEFAULT_FONT="%{_fontsdir}/TTF/DejaVuSans.ttf" \
74         --disable-silent-rules \
75         %{?with_static_libs:--enable-static}
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 # obsoleted by pkg-config
85 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libglyphy.la
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS COPYING NEWS README.md
96 %attr(755,root,root) %{_libdir}/libglyphy.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libglyphy.so.0
98 %{_datadir}/glyphy
99
100 %files devel
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/libglyphy.so
103 %{_includedir}/glyphy
104 %{_pkgconfigdir}/glyphy.pc
105
106 %if %{with static_libs}
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libglyphy.a
110 %endif
This page took 0.115307 seconds and 3 git commands to generate.