]> git.pld-linux.org Git - SPECS.git/blob - gjdoc.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / gjdoc.spec
1 #
2 # Conditional build:
3 %bcond_with     native  # build native library
4 #
5 Summary:        Documentation generation framework for Java source files
6 Summary(pl.UTF-8):      Szkielet do generowania dokumentacji dla plików źródłowych w Javie
7 Name:           gjdoc
8 Version:        0.7.9
9 Release:        3
10 License:        GPL v2+
11 Group:          Development/Languages/Java
12 Source0:        http://ftp.gnu.org/gnu/classpath/%{name}-%{version}.tar.gz
13 # Source0-md5:  24cade2efe22d5adefcbabb21f094803
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-launcher.patch
16 Patch2:         %{name}-link.patch
17 URL:            http://www.gnu.org/software/classpath/cp-tools/
18 BuildRequires:  antlr >= 2.7.5-3
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 # Some versions of gcj are known to produce bad bytecode.
22 # At least bug 19921 is known to affect gjdoc (in Feb 2005).
23 BuildRequires:  gcc-java >= 5:4.0.0-0.20050416.1
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  texinfo
26 Requires:       jpackage-utils
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # circular dependency with lib-gnu-classpath-tools (void gnu::classpath::tools::gjdoc::Main::main(JArray<java::lang::String*>*))
30 %define         skip_post_check_so      lib-com-sun-javadoc.so.*
31
32 # some -W flags are not valid for Java, filter them out to avoid warnings (which break libtool configure)
33 %define         gcjflags        %(echo %{rpmcflags} | sed -e 's/ -Wformat[^ ]*//g')
34
35 %description
36 Gjdoc is a documentation framework for generating documentation in
37 various formats from Java source files. It is both a drop-in
38 replacement for the traditional command line tool `javadoc' and
39 provides an interface for inspection of and generation of different
40 output for Java source packages, classes, methods and fields.
41
42 Gjdoc's current version implements all features of the traditional
43 javadoc tool up to version 1.4. With the exception of two
44 unimplemented options (-nocomment and -serialwarn) it should be fully
45 command-line compatible, and it provides a compatible Doclet API
46 (com.sun.javadoc).
47
48 However, in contrast to Javadoc, `gjdoc' does not perfom syntax
49 checking on the supplied sources. If necessary, use a real compiler
50 like `gcj -fsyntax-only` or `jikes +B' for checking the sources
51 beforehand.
52
53 %description -l pl.UTF-8
54 gjdoc to szkielet służący do generowania dokumentacji w różnych
55 formatach z plików źródłowych w Javie. Jest to zarówno zamiennik
56 tradycyjnego polecenia javadoc, jak i interfejs do inspekcji i
57 generowania różnych formatów wyjściowych dla pakietów źródłowych,
58 klas, metod i pól w Javie.
59
60 Aktualna wersja gjdoc implementuje wszystkie możliwości tradycyjnego
61 narzędzia javadoc do wersji 1.4. Z wyjątkiem dwóch nieudokumentowanych
62 opcji (-nocomment i -serialwarn) powinna być w pełni zgodna co do
63 linii poleceń i dostarcza kompatybilne Doclet API (com.sun.javadoc).
64
65 Jednak, w porównaniu do Javadoc, gjdoc nie sprawdza składni źródeł. W
66 razie potrzeby źródła można sprawdzić przedtem prawdziwym
67 kompilatorem, np. "gcj -fsyntax-only" lub "jikes +B".
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74
75 %build
76 %{__libtoolize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         GCJFLAGS="%{gcjflags}" \
82         --with-antlr-jar=%{_javadir}/antlr.jar \
83         --enable-native%{!?with_native:=no} \
84         --enable-shared \
85         --disable-static
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{lib-com-sun-javadoc,lib-com-sun-tools-doclets-Taglet,lib-gnu-classpath-tools-gjdoc}.{la,so}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post
101 %{?with_native:/sbin/ldconfig}
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
103
104 %postun
105 %{?with_native:/sbin/ldconfig}
106 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README
111 %attr(755,root,root) %{_bindir}/gjdoc
112 %if %{with native}
113 %attr(755,root,root) %{_libdir}/lib-com-sun-javadoc.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/lib-com-sun-javadoc.so.0
115 %attr(755,root,root) %{_libdir}/lib-com-sun-tools-doclets-Taglet.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/lib-com-sun-tools-doclets-Taglet.so.0
117 %attr(755,root,root) %{_libdir}/lib-gnu-classpath-tools-gjdoc.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/lib-gnu-classpath-tools-gjdoc.so.0
119 %endif
120 %{_infodir}/gjdoc.info*
121 %{_javadir}/com-sun-javadoc-%{version}.jar
122 %{_javadir}/com-sun-tools-doclets-Taglet-%{version}.jar
123 %{_javadir}/gnu-classpath-tools-gjdoc-%{version}.jar
124 %{_mandir}/man1/gjdoc.1*
This page took 0.545526 seconds and 3 git commands to generate.