]> git.pld-linux.org Git - SPECS.git/blob - ghc-terminfo.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / ghc-terminfo.spec
1 %define         pkgname terminfo
2 Summary:        Haskell bindings to the terminfo library
3 Name:           ghc-%{pkgname}
4 Version:        0.3.2.5
5 Release:        2
6 License:        BSD
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  7ef09acfac9f6fc499ed3bb804ae2ab3
10 URL:            http://hackage.haskell.org/package/terminfo/
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  gmp-devel
13 BuildRequires:  ncurses-devel
14 BuildRequires:  rpmbuild(macros) >= 1.608
15 %requires_eq    ghc
16 Requires:       ncurses-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 # debuginfo is not useful for ghc
20 %define         _enable_debug_packages  0
21
22 %description
23 This library provides an interface to the terminfo database (via
24 bindings to the curses library). Terminfo allows POSIX systems to
25 interact with a variety of terminals using a standard set of
26 capabilities.
27
28 %package doc
29 Summary:        HTML documentation for %{pkgname}
30 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
31 Group:          Documentation
32
33 %description doc
34 HTML documentation for %{pkgname}.
35
36 %description doc -l pl.UTF-8
37 Dokumentacja w formacie HTML dla %{pkgname}.
38
39 %prep
40 %setup -q -n %{pkgname}-%{version}
41
42 %build
43 runhaskell Setup.lhs configure -v2 \
44         --prefix=%{_prefix} \
45         --libdir=%{_libdir} \
46         --libexecdir=%{_libexecdir} \
47         --docdir=%{_docdir}/%{name}-%{version} \
48         --configure-option="--with-curses-includes=/usr/include/ncursesw"
49
50 runhaskell Setup.lhs build
51 runhaskell Setup.lhs haddock --executables
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
56
57 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
58
59 # work around automatic haddock docs installation
60 %{__rm} -rf %{name}-%{version}-doc
61 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html %{name}-%{version}-doc
62 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
63
64 runhaskell Setup.lhs register \
65         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %ghc_pkg_recache
72
73 %postun
74 %ghc_pkg_recache
75
76 %files
77 %defattr(644,root,root,755)
78 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
79 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
80
81 %files doc
82 %defattr(644,root,root,755)
83 %doc %{name}-%{version}-doc/*
This page took 0.451736 seconds and 3 git commands to generate.