]> git.pld-linux.org Git - SPECS.git/blob - ghc-mono-traversable.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ghc-mono-traversable.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname mono-traversable
6 Summary:        Type classes for mapping, folding, and traversing monomorphic containers
7 Name:           ghc-%{pkgname}
8 Version:        1.0.15.1
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 #Source0Download: http://hackage.haskell.org/package/mono-traversable
13 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  b321689d333f9c61c9350dcb813ba6fc
15 URL:            http://hackage.haskell.org/package/mono-traversable
16 BuildRequires:  ghc >= 6.12.3
17 BuildRequires:  ghc-base >= 4.10
18 BuildRequires:  ghc-bytestring >= 0.9
19 BuildRequires:  ghc-containers >= 0.5.8
20 BuildRequires:  ghc-hashable
21 BuildRequires:  ghc-split >= 0.2
22 BuildRequires:  ghc-text >= 0.11
23 BuildRequires:  ghc-transformers >= 0.3
24 BuildRequires:  ghc-unordered-containers >= 0.2
25 BuildRequires:  ghc-vector >= 0.10
26 BuildRequires:  ghc-vector-algorithms >= 0.6
27 %if %{with prof}
28 BuildRequires:  ghc-prof
29 BuildRequires:  ghc-base-prof >= 4.10
30 BuildRequires:  ghc-bytestring-prof >= 0.9
31 BuildRequires:  ghc-containers-prof >= 0.5.8
32 BuildRequires:  ghc-hashable-prof
33 BuildRequires:  ghc-split-prof >= 0.2
34 BuildRequires:  ghc-text-prof >= 0.11
35 BuildRequires:  ghc-transformers-prof >= 0.3
36 BuildRequires:  ghc-unordered-containers-prof >= 0.2
37 BuildRequires:  ghc-vector-prof >= 0.10
38 BuildRequires:  ghc-vector-algorithms-prof >= 0.6
39 %endif
40 BuildRequires:  rpmbuild(macros) >= 1.608
41 %requires_eq    ghc
42 Requires(post,postun):  /usr/bin/ghc-pkg
43 Requires:       ghc-base >= 4.10
44 Requires:       ghc-bytestring >= 0.9
45 Requires:       ghc-containers >= 0.5.8
46 Requires:       ghc-hashable
47 Requires:       ghc-split >= 0.2
48 Requires:       ghc-text >= 0.11
49 Requires:       ghc-transformers >= 0.3
50 Requires:       ghc-unordered-containers >= 0.2
51 Requires:       ghc-vector >= 0.10
52 Requires:       ghc-vector-algorithms >= 0.6
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # debuginfo is not useful for ghc
56 %define         _enable_debug_packages  0
57
58 # don't compress haddock files
59 %define         _noautocompressdoc      *.haddock
60
61 %description
62 Type classes for mapping, folding, and traversing monomorphic and
63 polymorphic containers. Haskell is good at operating over polymorphic
64 containers such as a list [a]. A monomorphic container is one such as
65 Text which has a type Text that does not expose a type variable for
66 the underlying characters.
67
68 %package prof
69 Summary:        Profiling %{pkgname} library for GHC
70 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 BuildRequires:  ghc-base-prof >= 4.10
74 BuildRequires:  ghc-bytestring-prof >= 0.9
75 BuildRequires:  ghc-containers-prof >= 0.5.8
76 BuildRequires:  ghc-hashable-prof
77 BuildRequires:  ghc-split-prof >= 0.2
78 BuildRequires:  ghc-text-prof >= 0.11
79 BuildRequires:  ghc-transformers-prof >= 0.3
80 BuildRequires:  ghc-unordered-containers-prof >= 0.2
81 BuildRequires:  ghc-vector-prof >= 0.10
82 BuildRequires:  ghc-vector-algorithms-prof >= 0.6
83
84 %description prof
85 Profiling %{pkgname} library for GHC.  Should be installed when
86 GHC's profiling subsystem is needed.
87
88 %description prof -l pl.UTF-8
89 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
90 kiedy potrzebujemy systemu profilującego z GHC.
91
92 %prep
93 %setup -q -n %{pkgname}-%{version}
94
95 %build
96 runhaskell Setup.hs configure -v2 \
97         %{?with_prof:--enable-library-profiling} \
98         --prefix=%{_prefix} \
99         --libdir=%{_libdir} \
100         --libexecdir=%{_libexecdir} \
101         --docdir=%{_docdir}/%{name}-%{version}
102
103 runhaskell Setup.hs build
104 runhaskell Setup.hs haddock --executables
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
109
110 runhaskell Setup.hs copy --destdir=$RPM_BUILD_ROOT
111
112 # work around automatic haddock docs installation
113 %{__rm} -rf %{name}-%{version}-doc
114 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
115 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
116
117 runhaskell Setup.hs register \
118         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 %ghc_pkg_recache
125
126 %postun
127 %ghc_pkg_recache
128
129 %files
130 %defattr(644,root,root,755)
131 %doc ChangeLog.md LICENSE README.md %{name}-%{version}-doc/html
132 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
133 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
134 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.so
135 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
136 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
137
138 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.hi
139 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.dyn_hi
140 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data
141 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.hi
142 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.dyn_hi
143 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/MonoTraversable
144 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/MonoTraversable/*.hi
145 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/MonoTraversable/*.dyn_hi
146
147 %if %{with prof}
148 %files prof
149 %defattr(644,root,root,755)
150 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
151 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.p_hi
152 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/*.p_hi
153 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Data/MonoTraversable/*.p_hi
154 %endif
This page took 0.888364 seconds and 3 git commands to generate.