]> git.pld-linux.org Git - SPECS.git/blob - ghc-ltk.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / ghc-ltk.spec
1 %define         pkgname ltk
2 Summary:        UI Framework used by leksah
3 Name:           ghc-%{pkgname}
4 Version:        0.12.1.0
5 Release:        0.1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://hackage.haskell.org/packages/archive/%{pkgname}/%{version}/%{pkgname}-%{version}.tar.gz
9 # Source0-md5:  2528d8813ffdcbf49f648e5a1ccdacb9
10 URL:            http://hackage.haskell.org/package/ltk/
11 BuildRequires:  ghc >= 6.12.3
12 BuildRequires:  ghc-prof
13 BuildRequires:  ghc-glib
14 BuildRequires:  ghc-gtk
15 BuildRequires:  rpmbuild(macros) >= 1.608
16 %requires_eq    ghc
17 Requires(post,postun):  /usr/bin/ghc-pkg
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 # debuginfo is not useful for ghc
21 %define         _enable_debug_packages  0
22
23 # don't compress haddoc files
24 %define         _noautocompressdoc      *.haddock
25
26 %description
27 UI Framework used by leksah .
28
29 %package prof
30 Summary:        Profiling %{pkgname} library for GHC
31 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC.
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description prof
36 Profiling %{pkgname} library for GHC.  Should be installed when
37 GHC's profiling subsystem is needed.
38
39 %description prof -l pl.UTF-8
40 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
41 kiedy potrzebujemy systemu profilującego z GHC.
42
43 %prep
44 %setup -q -n %{pkgname}-%{version}
45
46 %build
47 runhaskell Setup.lhs configure -v2 --enable-library-profiling \
48         --prefix=%{_prefix} \
49         --libdir=%{_libdir} \
50         --libexecdir=%{_libexecdir} \
51         --docdir=%{_docdir}/%{name}-%{version}
52
53 runhaskell Setup.lhs build
54 runhaskell Setup.lhs haddock --executables
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
59
60 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
61
62 # work around automatic haddock docs installation
63 rm -rf %{name}-%{version}-doc
64 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
65
66 runhaskell Setup.lhs register \
67         --gen-pkg-config=$RPM_BUILD_ROOT/%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %ghc_pkg_recache
74
75 %postun
76 %ghc_pkg_recache
77
78 %files
79 %defattr(644,root,root,755)
80 %doc NEWS
81 %doc %{name}-%{version}-doc/*
82 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
83 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
84 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.o
85 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*.a
86 %exclude %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
87
88 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE
89 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.hi
90
91 %files prof
92 %defattr(644,root,root,755)
93 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/*_p.a
94 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/PACKAGE/*.p_hi
This page took 0.947159 seconds and 3 git commands to generate.