]> git.pld-linux.org Git - SPECS.git/blob - ghc-highlighting-kate.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / ghc-highlighting-kate.spec
1 #
2 # Conditional build:
3 %bcond_without  prof    # profiling library
4 #
5 %define         pkgname highlighting-kate
6 Summary:        Syntax highlighting
7 Summary(pl.UTF-8):      Podświetlanie składni
8 Name:           ghc-%{pkgname}
9 Version:        0.5.5.1
10 Release:        1
11 License:        BSD
12 Group:          Development/Languages
13 #Source0Download: http://hackage.haskell.org/package/highlighting-kate
14 Source0:        http://hackage.haskell.org/package/%{pkgname}-%{version}/%{pkgname}-%{version}.tar.gz
15 # Source0-md5:  f29f4356fbee734c06dbbe18d332f61a
16 URL:            http://hackage.haskell.org/package/highlighting-kate
17 BuildRequires:  ghc >= 6.12.3
18 BuildRequires:  ghc-base >= 3
19 BuildRequires:  ghc-base < 5
20 BuildRequires:  ghc-blaze-html >= 0.4.2
21 BuildRequires:  ghc-blaze-html < 0.7
22 BuildRequires:  ghc-containers
23 BuildRequires:  ghc-filepath
24 BuildRequires:  ghc-mtl
25 BuildRequires:  ghc-parsec
26 BuildRequires:  ghc-pcre-light
27 %if %{with prof}
28 BuildRequires:  ghc-prof >= 6.12.3
29 BuildRequires:  ghc-base-prof >= 3
30 BuildRequires:  ghc-base-prof < 5
31 BuildRequires:  ghc-blaze-html-prof >= 0.4.2
32 BuildRequires:  ghc-blaze-html-prof < 0.7
33 BuildRequires:  ghc-containers-prof
34 BuildRequires:  ghc-filepath-prof
35 BuildRequires:  ghc-mtl-prof
36 BuildRequires:  ghc-parsec-prof
37 BuildRequires:  ghc-pcre-light-prof
38 %endif
39 BuildRequires:  rpmbuild(macros) >= 1.608
40 Requires(post,postun):  /usr/bin/ghc-pkg
41 %requires_eq    ghc
42 Requires:       ghc-base >= 3
43 Requires:       ghc-base < 5
44 Requires:       ghc-blaze-html >= 0.4.2
45 Requires:       ghc-blaze-html < 0.7
46 Requires:       ghc-containers
47 Requires:       ghc-filepath
48 Requires:       ghc-mtl
49 Requires:       ghc-parsec
50 Requires:       ghc-pcre-light
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 # debuginfo is not useful for ghc
54 %define         _enable_debug_packages  0
55
56 # don't compress haddock files
57 %define         _noautocompressdoc      *.haddock
58
59 %description
60 highlighting-kate is a syntax highlighting library with support for
61 nearly one hundred languages. The syntax parsers are automatically
62 generated from Kate syntax descriptions (<http://kate-editor.org/>),
63 so any syntax supported by Kate can be added. An (optional)
64 command-line program is provided, along with a utility for generating
65 new parsers from Kate XML syntax descriptions.
66
67 %description -l pl.UTF-8
68 highlighting-kate to biblioteka do podświetlania składni z obsługą
69 prawie setki języków. Analizatory składni są automatycznie generowane
70 z opisów składni edytora Kate (<http://kate-editor.org/>), więc można
71 dodać dowolną składnię obsługiwaną przez Kate. Dostępny jest
72 (opcjonalny) działający z linii poleceń program wraz z narzędziem do
73 generowania nowych analizatorów z XML-owych opisów składni edytora
74 Kate.
75
76 %package prof
77 Summary:        Profiling %{pkgname} library for GHC
78 Summary(pl.UTF-8):      Biblioteka profilująca %{pkgname} dla GHC
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       ghc-base-prof >= 3
82 Requires:       ghc-base-prof < 5
83 Requires:       ghc-blaze-html-prof >= 0.4.2
84 Requires:       ghc-blaze-html-prof < 0.7
85 Requires:       ghc-containers-prof
86 Requires:       ghc-filepath-prof
87 Requires:       ghc-mtl-prof
88 Requires:       ghc-parsec-prof
89 Requires:       ghc-pcre-light-prof
90
91 %description prof
92 Profiling %{pkgname} library for GHC. Should be installed when
93 GHC's profiling subsystem is needed.
94
95 %description prof -l pl.UTF-8
96 Biblioteka profilująca %{pkgname} dla GHC. Powinna być zainstalowana
97 kiedy potrzebujemy systemu profilującego z GHC.
98
99 %package doc
100 Summary:        HTML documentation for ghc %{pkgname} package
101 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}
102 Group:          Documentation
103
104 %description doc
105 HTML documentation for ghc %{pkgname} package.
106
107 %description doc -l pl.UTF-8
108 Dokumentacja w formacie HTML dla pakietu ghc %{pkgname}.
109
110 %prep
111 %setup -q -n %{pkgname}-%{version}
112
113 %build
114 runhaskell Setup.lhs configure -v2 \
115         %{?with_prof:--enable-library-profiling} \
116         --prefix=%{_prefix} \
117         --libdir=%{_libdir} \
118         --libexecdir=%{_libexecdir} \
119         --docdir=%{_docdir}/%{name}-%{version}
120
121 runhaskell Setup.lhs build
122 runhaskell Setup.lhs haddock --executables
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d
127
128 runhaskell Setup.lhs copy --destdir=$RPM_BUILD_ROOT
129
130 # work around automatic haddock docs installation
131 %{__rm} -rf %{name}-%{version}-doc
132 cp -a $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version} %{name}-%{version}-doc
133 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
134
135 runhaskell Setup.lhs register \
136         --gen-pkg-config=$RPM_BUILD_ROOT%{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 %ghc_pkg_recache
143
144 %postun
145 %ghc_pkg_recache
146
147 %files
148 %defattr(644,root,root,755)
149 %doc README
150 %{_libdir}/%{ghcdir}/package.conf.d/%{pkgname}.conf
151 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}
152 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/HShighlighting-kate-%{version}.o
153 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHShighlighting-kate-%{version}.a
154 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Paths_highlighting_kate.hi
155 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text
156 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting
157 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate.hi
158 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate
159 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/*.hi
160 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Format
161 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Format/*.hi
162 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Syntax
163 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Syntax/*.hi
164
165
166 %if %{with prof}
167 %files prof
168 %defattr(644,root,root,755)
169 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/libHShighlighting-kate-%{version}_p.a
170 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Paths_highlighting_kate.p_hi
171 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate.p_hi
172 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate
173 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/*.p_hi
174 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Format
175 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Format/*.p_hi
176 %dir %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Syntax
177 %{_libdir}/%{ghcdir}/%{pkgname}-%{version}/Text/Highlighting/Kate/Syntax/*.p_hi
178 %endif
179
180 %files doc
181 %defattr(644,root,root,755)
182 %doc %{name}-%{version}-doc/*
This page took 0.049898 seconds and 3 git commands to generate.