]> git.pld-linux.org Git - packages/geoclue2.git/blob - geoclue2.spec
- updated to 2.4.12
[packages/geoclue2.git] / geoclue2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A modular geoinformation service
6 Summary(pl.UTF-8):      Modularna usługa geoinformacyjna
7 Name:           geoclue2
8 Version:        2.4.12
9 Release:        1
10 License:        GPL v2+ (programs), LGPL v2.1+ (library)
11 Group:          Applications
12 Source0:        https://www.freedesktop.org/software/geoclue/releases/2.4/geoclue-%{version}.tar.xz
13 # Source0-md5:  469bfcebef36723b34aaa5816de93e18
14 URL:            https://geoclue.freedesktop.org/
15 BuildRequires:  ModemManager-devel >= 1.6
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  avahi-devel >= 0.6.10
19 BuildRequires:  avahi-glib-devel >= 0.6.10
20 BuildRequires:  glib2-devel >= 1:2.44.0
21 BuildRequires:  gnome-common
22 BuildRequires:  gobject-introspection-devel >= 0.10
23 BuildRequires:  gtk-doc >= 1.0
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  json-glib-devel >= 0.14
26 BuildRequires:  libnotify-devel
27 BuildRequires:  libsoup-devel >= 2.42
28 BuildRequires:  libtool >= 2:2.2
29 BuildRequires:  pkgconfig >= 1:0.22
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  yelp-tools
32 BuildRequires:  xz
33 Requires:       %{name}-libs = %{version}-%{release}
34 Requires:       avahi-libs >= 0.6.10
35 Requires:       avahi-glib >= 0.6.10
36 Requires:       dbus
37 Requires:       json-glib >= 0.14
38 Requires:       libsoup >= 2.42
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Geoclue is a modular geoinformation service built on top of the D-Bus
43 messaging system. The goal of the Geoclue project is to make creating
44 location-aware applications as simple as possible.
45
46 %description -l pl.UTF-8
47 Geoclue to modularna usługa geoinformacyjna zbudowana w oparciu o
48 system komunikacji D-Bus. Celem projektu jest jak największe
49 ułatwienie tworzenia aplikacji uwzględniających lokalizację.
50
51 %package libs
52 Summary:        Library to interact with Geoclue service
53 Summary(pl.UTF-8):      Biblioteka do współpracy z usługą Geoclue
54 License:        LGPL v2.1+
55 Group:          Libraries
56 Requires:       glib2 >= 1:2.44.0
57
58 %description libs
59 Library to interact with Geoclue service.
60
61 %description libs -l pl.UTF-8
62 Biblioteka do współpracy z usługą Geoclue.
63
64 %package devel
65 Summary:        Development package for geoclue2
66 Summary(pl.UTF-8):      Pakiet programistyczny geoclue2
67 License:        LGPL v2.1+
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       glib2-devel >= 1:2.44.0
71
72 %description devel
73 Header files for development with geoclue2.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe do programowania z użyciem geoclue2.
77
78 %package static
79 Summary:        Static geoclue2 library
80 Summary(pl.UTF-8):      Statyczna biblioteka geoclue2
81 License:        LGPL v2.1+
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static geoclue2 library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka geoclue2.
90
91 %package -n vala-geoclue2
92 Summary:        Vala API for geoclue2 library
93 Summary(pl.UTF-8):      Interfejs języka Vala do biblioteki geoclue2
94 License:        LGPL v2.1+
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description -n vala-geoclue2
99 Vala API for geoclue2 library.
100
101 %description -n vala-geoclue2 -l pl.UTF-8
102 Interfejs języka Vala do biblioteki geoclue2.
103
104 %prep
105 %setup -q -n geoclue-%{version}
106
107 %build
108 %{__intltoolize}
109 %{__libtoolize}
110 %{__aclocal} -I m4
111 %{__autoconf}
112 %{__autoheader}
113 %{__automake}
114 %configure \
115         --enable-demo-agent \
116         --disable-silent-rules \
117         %{?with_static_libs:--enable-static} \
118         --with-systemdsystemunitdir=%{systemdunitdir}
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 # obsoleted by pkg-config
129 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgeoclue-2.la
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   libs -p /sbin/ldconfig
135 %postun libs -p /sbin/ldconfig
136
137 %files
138 %defattr(644,root,root,755)
139 %doc NEWS README
140 %attr(755,root,root) %{_libexecdir}/geoclue
141 %dir %{_sysconfdir}/geoclue
142 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/geoclue/geoclue.conf
143 %{systemdunitdir}/geoclue.service
144 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.conf
145 /etc/dbus-1/system.d/org.freedesktop.GeoClue2.Agent.conf
146 %{_datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service
147 # demos
148 /etc/xdg/autostart/geoclue-demo-agent.desktop
149 %dir %{_libexecdir}/geoclue-2.0
150 %dir %{_libexecdir}/geoclue-2.0/demos
151 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/agent
152 %attr(755,root,root) %{_libexecdir}/geoclue-2.0/demos/where-am-i
153 %{_desktopdir}/geoclue-demo-agent.desktop
154 %{_desktopdir}/geoclue-where-am-i.desktop
155
156 %files libs
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libgeoclue-2.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgeoclue-2.so.0
160 %{_libdir}/girepository-1.0/Geoclue-2.0.typelib
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libgeoclue-2.so
165 %{_includedir}/libgeoclue-2.0
166 %{_datadir}/gir-1.0/Geoclue-2.0.gir
167 %{_pkgconfigdir}/geoclue-2.0.pc
168 %{_pkgconfigdir}/libgeoclue-2.0.pc
169 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.xml
170 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Agent.xml
171 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Client.xml
172 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Location.xml
173 %{_datadir}/dbus-1/interfaces/org.freedesktop.GeoClue2.Manager.xml
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libgeoclue-2.a
179 %endif
180
181 %files -n vala-geoclue2
182 %defattr(644,root,root,755)
183 %{_datadir}/vala/vapi/libgeoclue-2.0.deps
184 %{_datadir}/vala/vapi/libgeoclue-2.0.vapi
This page took 0.101336 seconds and 4 git commands to generate.