]> git.pld-linux.org Git - packages/gentoo.git/blob - gentoo.spec
- initial version.
[packages/gentoo.git] / gentoo.spec
1 %define name    gentoo
2 %define version 0.11.4
3 %define release 1
4 %define serial  2
5
6 Summary:        gentoo is a Gtk+ file manager for Linux.
7 Name:           %{name}
8 Version:        %{version}
9 Release:        %{release}
10 Serial:         %{serial}
11 Copyright:      GPL
12 Group:          X11/Utilities
13 URL:            http://www.obsession.se/gentoo
14 Vendor:         Emil Brink <emil@obsession.se>
15 Source:         ftp://ftp.obsession.se/gentoo/%{name}-%{version}.tar.gz
16 Patch:          %{name}-makefile.patch
17 Distribution:   Freshmeat RPMs
18 Packager:       Ryan Weaver <ryanw@infohwy.com>
19 Requires:       gtk+ >= 1.2.0
20 BuildRoot:      /tmp/%{name}-%{version}
21
22 %description
23 gentoo is a file manager for Linux written from scratch in pure C. It
24 uses the GTK+ toolkit for all of its interface needs. gentoo provides
25 100%% GUI configurability; no need to edit config files by hand and re-
26 start the program. gentoo supports identifying the type of various
27 files (using extension, regular expressions, and/or the 'file' command),
28 and can display files of different types with different colors and icons.
29         gentoo borrows some of its look and feel from the classic Amiga
30 file manager "Directory OPUS"(TM) (written by Jonathan Potter).
31
32 %prep
33 %setup -q
34 %patch -p1
35
36 %build
37 make
38
39 %install
40 if [ -e $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
41
42 install -d $RPM_BUILD_ROOT/usr/bin
43 install -d $RPM_BUILD_ROOT/usr/lib/gentoo/icons
44 install -d $RPM_BUILD_ROOT/usr/man/man1
45
46 install -s -m 755 gentoo        $RPM_BUILD_ROOT/usr/bin
47 install -m 644 gentoorc-example $RPM_BUILD_ROOT/usr/lib/gentoo
48 install -m 644 gentoorc-example $RPM_BUILD_ROOT/usr/lib/gentoo/gentoorc
49 install -m 644 icons/*          $RPM_BUILD_ROOT/usr/lib/gentoo/icons
50 install -m 644 docs/gentoo.1x   $RPM_BUILD_ROOT/usr/man/man1
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root)
57 %doc docs BUGS COPYING FIXES-0.11 FIXES-0.9 INSTALL README
58 %doc README.gtkrc gentoogtkrc-example gentoorc-example
59 /usr/bin/gentoo
60 /usr/lib/gentoo
61 /usr/man/man1/gentoo.1x
62
63 %changelog
64 * Tue Apr  6 1999 Ryan Weaver <ryanw@infohwy.com>
65   [gentoo-0.11.4-1]
66 - 0.11.4
67 - Statusbar now shows the amount of free space for the filesystem
68   the current pane's directory is in. Note that the call that makes
69   this possible (statfs(2) on Linux, statvfs(2) on e.g. Solaris and
70   Irix) seems to be somewhat unstandardized. There might be trouble.
71 - Fixed a problem with nesting modal dialogs. Noticable when e.g.
72   Rename caused an overwrite confirmation to occur.
73 - Fixed a related dialog problem; now, if you close the Rename
74   dialog with the Overwrite confirm window still open, nothing evil
75   will happen.
76 - Did numerous clean-ups in the main "gentoo.h" header file, moving
77   many type definitions into separate C files, thus reducing coupling.
78 - Removed a useless dialog (the "child_dialog" module).
79 - Discovered what I suppose is a compiler bug in gcc 2.8.1; when
80   compiling gentoo with optimization level 2 (-O2), a supposedly
81   harmless statement in the dialog module will cause a segfault...
82 - When you write a path, the keyboard events no longer trigger
83   commands. This is better. Reported by J. Hanson <johan@tiq.com>.
84 - Added a freeze/thaw pair to the textviewer used for command output
85   capturing, resulting in way better performance and no flickering.
86 - Removed the (nonfunctional) "Print" button from the text viewer,
87   slightly changing the button layout in the process.
88 - Slowed down the animation of the busy indicator (used by the
89   Information and GetSize commands) a bit. It made me nervous. :)
90 - The hex text viewing (used by ViewHex & ViewTextOrHex) code was
91   *very* memory-inefficient (it always loaded the entire file, but
92   only looked at 16 bytes at a time). Now it reads 16 bytes at a
93   time, thus using constant buffer space (and running slower).
94 - ViewTextOrHex now correctly reports the error if it fails to
95   open a file for reading. Er, ViewText & ViewHex don't (yet).
96 - Designed and implemented a system for keeping track of each
97   command's individual configuration options. The options them-
98   selves have been around for quite a while, but they haven't been
99   configurable (without editing source, that is). Now they appear
100   on the "Command Options" page in the configuration window, and
101   are loaded and saved along with the rest of the config. Neat.
102     Please read "docs/scratch/command_options.txt" to learn what
103   different options do.
104
105 * Tue Mar 30 1999 Ryan Weaver <ryanw@infohwy.com>
106   [gentoo-0.11.3-1]
107 - Damn! That command sequence selection dialog just didn't work.
108   Typical, since I spent about 3 hrs banging on it before releasing
109   0.11.2. Perhaps I should have tested it. Reported by J. Minnberg.
110 - Eh, seems I broke the main "gentoo.h" include file, too. Fixed.
111 - Fixed a minor error (typo) in the cmdgrab module.
112 - package is FHS 2.0 compliant,
113 - spec file rewritten for PLD use,
114 - based on spec written by Ryan Weaver <ryanw@infohwy.com>.
This page took 0.0642 seconds and 4 git commands to generate.