]> git.pld-linux.org Git - packages/gentoo.git/blob - gentoo.spec
- updated to 0.11.5,
[packages/gentoo.git] / gentoo.spec
1 Summary:        gentoo is a Gtk+ file manager for Linux.
2 Summary(pl):    gentoo jest opartym na Gtk+ zarz±dc± plików pod Linuxa.
3 Name:           gentoo
4 Version:        0.11.5
5 Release:        2
6 Copyright:      GPL
7 Group:          X11/Utilities
8 Group(pl):      X11/Narzêdzia
9 URL:            http://www.obsession.se/gentoo
10 Source0:        ftp://ftp.obsession.se/gentoo/%{name}-%{version}.tar.gz
11 Source1:        gentoo.wmconfig
12 Patch:          gentoo-makefile.patch
13 BuildPrereq:    gtk+-devel >= 1.2.0
14 BuildPrereq:    glib-devel >= 1.2.0
15 BuildPrereq:    XFree86-devel
16 Requires:       file
17 BuildRoot:      /tmp/%{name}-%{version}-root
18
19 %description
20 gentoo is a file manager for Linux written from scratch in pure C. It
21 uses the GTK+ toolkit for all of its interface needs. gentoo provides
22 100%% GUI configurability; no need to edit config files by hand and re-
23 start the program. gentoo supports identifying the type of various
24 files (using extension, regular expressions, and/or the 'file' command),
25 and can display files of different types with different colors and icons.
26         gentoo borrows some of its look and feel from the classic Amiga
27 file manager "Directory OPUS"(TM) (written by Jonathan Potter).
28
29 %description -l pl
30 gentoo jest zarz±dc± plików dla Linuxa napisanym 'od zera' w czystym C.
31 U¿ywa zestawu narzêdzi GTK+ do zaspokojenia wszystkich potrzeb zwi±zanych
32 z interfejsem. gentoo zapewnia 100%-ow± konfigurowalno¶æ graficznego 
33 interfejsu; nie ma potrzeby rêcznego edytowania plików konfiguracyjnch
34 i ponownego uruchamiania programu. gentoo dostarcza identyfikacjê typów
35 ró¿nych plików (u¿ywaj±c rozszerzenia, wyra¿eñ regularnych i/lub polecenia
36 'file') oraz potrafi wy¶wietlaæ pliki ró¿nego typu w ró¿nych kolorach
37 i z ró¿nymi ikonami. gentoo zapo¿ycza trochê ze swojego wygl±du od 
38 klasycznego zarz±dcy plików Amigi -- "Directory OPUS"(TM) (napisanego
39 przez Jonathana Pottera).
40
41 %prep
42 %setup -q
43 %patch -p1
44
45 %build
46
47 CFLAGS="$RPM_OPT_FLAGS" \
48 make
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/usr/X11R6/{bin,share/gentoo/icons,man/man1} \
54         $RPM_BUILD_ROOT/etc/X11/wmconfig
55
56 install -s gentoo $RPM_BUILD_ROOT/usr/X11R6/bin
57 install gentoorc-example $RPM_BUILD_ROOT/usr/X11R6/share/gentoo/gentoorc
58 install icons/* $RPM_BUILD_ROOT/usr/X11R6/share/gentoo/icons
59 install docs/gentoo.1x $RPM_BUILD_ROOT/usr/X11R6/man/man1
60 install %{SOURCE1} $RPM_BUILD_ROOT/etc/X11/wmconfig/gentoo
61
62 gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man1/* \
63         BUGS FIXES-0.11 FIXES-0.9 README README.gtkrc
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc {BUGS,FIXES-0.11,FIXES-0.9,README,README.gtkrc}.gz
71 %doc docs gentoogtkrc-example gentoorc-example
72
73 %attr(755,root,root) /usr/X11R6/bin/gentoo
74 /usr/X11R6/share/gentoo
75 /usr/X11R6/man/man1/gentoo.1x.gz
76
77 /etc/X11/wmconfig/gentoo
78
79 %changelog
80 * Mon Apr 26 1999 Piotr Czerwiñski <pius@pld.org.pl>
81   [0.11.5-2]
82 - updated to 0.11.5,
83 - added pl translation,
84 - changed install prefix to /usr/X11R6,
85 - changed gentoo's files path to /usr/X11R6/share/gentoo 
86   (new gentoo-makefile.patch),
87 - fixed passing $RPM_OPT_FLAGS during compile,
88 - modified %install and %files section,
89 - added gzipping documentation and man pages,
90 - added full %defattr and %attr description,
91 - added some BuildPrereqs and Requires,
92 - added wmconfig file,
93 - recompiled on rpm 3,
94 - minor changes.
95
96 * Tue Apr  6 1999 Ryan Weaver <ryanw@infohwy.com>
97   [gentoo-0.11.4-1]
98 - 0.11.4
99 - Statusbar now shows the amount of free space for the filesystem
100   the current pane's directory is in. Note that the call that makes
101   this possible (statfs(2) on Linux, statvfs(2) on e.g. Solaris and
102   Irix) seems to be somewhat unstandardized. There might be trouble.
103 - Fixed a problem with nesting modal dialogs. Noticable when e.g.
104   Rename caused an overwrite confirmation to occur.
105 - Fixed a related dialog problem; now, if you close the Rename
106   dialog with the Overwrite confirm window still open, nothing evil
107   will happen.
108 - Did numerous clean-ups in the main "gentoo.h" header file, moving
109   many type definitions into separate C files, thus reducing coupling.
110 - Removed a useless dialog (the "child_dialog" module).
111 - Discovered what I suppose is a compiler bug in gcc 2.8.1; when
112   compiling gentoo with optimization level 2 (-O2), a supposedly
113   harmless statement in the dialog module will cause a segfault...
114 - When you write a path, the keyboard events no longer trigger
115   commands. This is better. Reported by J. Hanson <johan@tiq.com>.
116 - Added a freeze/thaw pair to the textviewer used for command output
117   capturing, resulting in way better performance and no flickering.
118 - Removed the (nonfunctional) "Print" button from the text viewer,
119   slightly changing the button layout in the process.
120 - Slowed down the animation of the busy indicator (used by the
121   Information and GetSize commands) a bit. It made me nervous. :)
122 - The hex text viewing (used by ViewHex & ViewTextOrHex) code was
123   *very* memory-inefficient (it always loaded the entire file, but
124   only looked at 16 bytes at a time). Now it reads 16 bytes at a
125   time, thus using constant buffer space (and running slower).
126 - ViewTextOrHex now correctly reports the error if it fails to
127   open a file for reading. Er, ViewText & ViewHex don't (yet).
128 - Designed and implemented a system for keeping track of each
129   command's individual configuration options. The options them-
130   selves have been around for quite a while, but they haven't been
131   configurable (without editing source, that is). Now they appear
132   on the "Command Options" page in the configuration window, and
133   are loaded and saved along with the rest of the config. Neat.
134     Please read "docs/scratch/command_options.txt" to learn what
135   different options do.
136
137 * Tue Mar 30 1999 Ryan Weaver <ryanw@infohwy.com>
138   [gentoo-0.11.3-1]
139 - Damn! That command sequence selection dialog just didn't work.
140   Typical, since I spent about 3 hrs banging on it before releasing
141   0.11.2. Perhaps I should have tested it. Reported by J. Minnberg.
142 - Eh, seems I broke the main "gentoo.h" include file, too. Fixed.
143 - Fixed a minor error (typo) in the cmdgrab module.
144
145 - package is FHS 2.0 compliant,
146 - spec file rewritten for PLD use,
147 - based on spec written by Ryan Weaver <ryanw@infohwy.com>.
This page took 0.091347 seconds and 3 git commands to generate.