]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
- massive attack, adding Source-md5
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 # _with_msdblib - use MS-style dblib
4 #
5 # %%define tdsver - protocol version; valid versions:
6 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
7 # 4.6
8 # 5.0 (used by Sybase SQLServer >= 11)
9 # 7.0 (used by MS SQL Server 7.0) [default]
10 # 8.0 (not finished yet!)
11
12 %{!?tdsver:%define tdsver 7.0}
13
14 Summary:        Free implementation of Sybase's db-lib
15 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
16 Name:           freetds
17 Version:        0.61
18 Release:        2
19 License:        LGPL
20 Group:          Libraries
21 Source0:        ftp://ftp.ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tgz
22 # Source0-md5: 15cc9829beb534606deb3020b3118eb9
23 Patch0:         %{name}-nolibnsl.patch
24 URL:            http://www.freetds.org/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  glib-devel
28 BuildRequires:  libltdl-devel
29 BuildRequires:  libtool
30 BuildRequires:  unixODBC-devel
31 Requires(post): /sbin/ldconfig
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _sysconfdir     /etc/tds
35
36 %description
37 FreeTDS is a free (open source) implementation of Sybase's db-lib,
38 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
39 databases). Currently, dblib and ctlib are most mature. Both of these
40 libraries have several programs known to compile and run against them.
41 ODBC is not quite as mature, but may work depending on your needs.
42
43 %description -l pl
44 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
45 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
46 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
47 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
48 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
49 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
50
51 %package devel
52 Summary:        FreeTDS header files
53 Summary(pl):    Pliki nag³ówkowe FreeTDS
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}
56
57 %description devel
58 FreeTDS header files.
59
60 %description devel -l pl
61 Pliki nag³ówkowe FreeTDS.
62
63 %package static
64 Summary:        FreeTDS static libraries
65 Summary(pl):    Statyczne biblioteki FreeTDS
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}
68
69 %description static
70 FreeTDS static libraries.
71
72 %description static -l pl
73 Statyczne biblioteki FreeTDS.
74
75 %prep
76 %setup -q
77 %patch -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__automake}
84 %configure \
85         --with-tdsver=%{tdsver} \
86         %{?_with_msdblib:--with-msdblib} \
87         --with-unixodbc=/usr
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT \
95         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
96
97 mv -f src/pool/BUGS BUGS.pool
98 mv -f src/pool/README README.pool
99 mv -f src/pool/TODO TODO.pool
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 /sbin/ldconfig
106 if [ -f /etc/freetds.conf ]; then
107         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
108 fi
109
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS BUGS* ChangeLog README* TODO*
115 %attr(755,root,root) %{_libdir}/lib*.so.*.*
116 %attr(755,root,root) %{_bindir}/*
117 %dir %{_sysconfdir}
118 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
119 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
120 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/pool.conf
121 %{_mandir}/man1/*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/lib*.so
126 %{_libdir}/lib*.la
127 %{_includedir}/*
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
This page took 0.037884 seconds and 3 git commands to generate.