]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
- updated to 0.60
[packages/freetds.git] / freetds.spec
1 # Conditional build:
2 # _with_msdblib - use MS-style dblib
3 #
4 # %%define tdsver - protocol version; valid versions:
5 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
6 # 4.6
7 # 5.0 (used by Sybase SQLServer >= 11)
8 # 7.0 (used by MS SQL Server 7.0) [default]
9 # 8.0 (not finished yet!)
10
11 %{!?tdsver:%define tdsver 7.0}
12
13 Summary:        Free implementation of Sybase's db-lib
14 Summary(pl):    Wolnodostêpna implementacja db-lib firmy Sybase
15 Name:           freetds
16 Version:        0.60
17 Release:        1
18 License:        LGPL
19 Group:          Libraries
20 Source0:        ftp://ftp.ibiblio.org/pub/Linux/ALPHA/freetds/stable/%{name}-%{version}.tgz
21 URL:            http://www.freetds.org/
22 BuildRequires:  autoconf
23 BuildRequires:  glib-devel
24 BuildRequires:  unixODBC-devel
25 Requires(post): /sbin/ldconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _sysconfdir     /etc/tds
29
30 %description
31 FreeTDS is a free (open source) implementation of Sybase's db-lib,
32 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
33 databases). Currently, dblib and ctlib are most mature. Both of these
34 libraries have several programs known to compile and run against them.
35 ODBC is not quite as mature, but may work depending on your needs.
36
37 %description -l pl
38 FreeTDS to wolnodostêpna (z otwartymi ¼ród³ami) implementacja
39 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których mo¿na u¿ywaæ
40 tak¿e do pracy z bazami MS SQL). Aktualnie najlepiej dzia³aj± dblib i
41 ctlib - istnieje trochê programów, o których wiadomo, ¿e kompiluj± siê
42 i dzia³aj± z tymi bibliotekami. ODBC nie jest jeszcze na tyle
43 skoñczony, ale mo¿e dzia³aæ w zale¿no¶ci od potrzeb.
44
45 %package devel
46 Summary:        FreeTDS header files
47 Summary(pl):    Pliki nag³ówkowe FreeTDS
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}
50
51 %description devel
52 FreeTDS header files.
53
54 %description devel -l pl
55 Pliki nag³ówkowe FreeTDS.
56
57 %package static
58 Summary:        FreeTDS static libraries
59 Summary(pl):    Statyczne biblioteki FreeTDS
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}
62
63 %description static
64 FreeTDS static libraries.
65
66 %description static -l pl
67 Statyczne biblioteki FreeTDS.
68
69 %prep
70 %setup -q
71
72 %build
73 %{__autoconf}
74 %configure \
75         --with-tdsver=%{tdsver} \
76         %{?_with_msdblib:--with-msdblib} \
77         --with-unixodbc
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT \
85         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post
91 /sbin/ldconfig
92 if [ -f /etc/freetds.conf ]; then
93         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
94 fi
95
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc AUTHORS BUGS ChangeLog README* TODO
101 %attr(755,root,root) %{_libdir}/lib*.so.*.*
102 %attr(755,root,root) %{_bindir}/*
103 %dir %{_sysconfdir}
104 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/freetds.conf
105 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/locales.conf
106 %{_mandir}/man1/*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/lib*.so
111 %attr(755,root,root) %{_libdir}/lib*.la
112 %{_includedir}/*
113
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/lib*.a
This page took 0.05468 seconds and 3 git commands to generate.