]> git.pld-linux.org Git - SPECS.git/blob - foot.spec
SPECS updated Tue 30 Apr 15:13:02 CEST 2024
[SPECS.git] / foot.spec
1 #
2 # Conditional build:
3 %bcond_with     pgo             # disable profile guided optimizations
4
5 Summary:        A fast, lightweight and minimalistic Wayland terminal emulator
6 Name:           foot
7 Version:        1.17.2
8 Release:        1
9 License:        MIT
10 Group:          Applications/Terminal
11 Source0:        https://codeberg.org/dnkl/foot/archive/%{version}.tar.gz
12 # Source0-md5:  9b758352f552e0c1eb72b9c29109c893
13 Patch0:         x32.patch
14 URL:            https://codeberg.org/dnkl/foot/
15 BuildRequires:  fcft-devel < 4.0.0
16 BuildRequires:  fcft-devel >= 3.0.1
17 BuildRequires:  fontconfig-devel
18 BuildRequires:  libutf8proc-devel
19 BuildRequires:  meson >= 0.59.0
20 BuildRequires:  ninja
21 BuildRequires:  pixman-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  python3
24 BuildRequires:  rpm-build >= 4.6
25 BuildRequires:  rpmbuild(macros) >= 2.011
26 BuildRequires:  scdoc
27 BuildRequires:  systemd-devel
28 BuildRequires:  tllist-devel >= 1.1.0
29 BuildRequires:  wayland-devel
30 BuildRequires:  wayland-protocols >= 1.32
31 BuildRequires:  xorg-lib-libxkbcommon-devel >= 1.0.0
32 %if %{with pgo}
33 BuildRequires:  cage
34 BuildRequires:  fonts-TTF-DejaVu
35 %endif
36 Requires(post,postun):  desktop-file-utils
37 Requires(post,postun):  gtk-update-icon-cache
38 Requires(post,preun):   systemd-units >= 1:250.1
39 Requires:       fcft < 4.0.0
40 Requires:       fcft >= 3.0.1
41 Requires:       hicolor-icon-theme
42 Requires:       terminfo >= 6.2.20210731
43 Requires:       xorg-lib-libxkbcommon >= 1.0.0
44 Obsoletes:      terminfo-foot < 1.10.3-2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 A fast, lightweight and minimalistic Wayland terminal emulator.
49
50 %package -n bash-completion-foot
51 Summary:        Bash completion for foot command line
52 Group:          Applications/Shells
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       bash-completion >= 1:2.0
55 BuildArch:      noarch
56
57 %description -n bash-completion-foot
58 Bash completion for foot command line.
59
60 %package -n fish-completion-foot
61 Summary:        fish-completion for foot
62 Group:          Applications/Shells
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       fish
65 BuildArch:      noarch
66
67 %description -n fish-completion-foot
68 fish-completion for foot.
69
70 %description -n fish-completion-foot -l pl.UTF-8
71 Pakiet ten dostarcza uzupełnianie nazw w fish dla foot.
72
73 %package -n zsh-completion-foot
74 Summary:        ZSH completion for foot command line
75 Group:          Applications/Shells
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       zsh
78 BuildArch:      noarch
79
80 %description -n zsh-completion-foot
81 ZSH completion for foot command line.
82
83 %prep
84 %setup -q -n %{name}
85 %patch0 -p1
86
87 %build
88 %meson build \
89         %{?with_pgo:-Db_pgo=generate} \
90         -Dutmp-backend=libutempter \
91         -Dutmp-default-helper-path=/usr/sbin/utempter \
92         -Dterminfo=disabled
93
94 %ninja_build -C build
95
96 %if %{with pgo}
97 %ninja_test -C build
98
99 ./pgo/full-headless-cage.sh . build
100
101 %__meson configure build \
102         -Db_pgo=use
103
104 %ninja_build -C build
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %ninja_install -C build
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 %update_desktop_database_post
117 %update_icon_cache hicolor
118 %systemd_user_post foot-server.service foot-server.socket
119
120 %preun
121 %systemd_user_preun foot-server.service foot-server.socket
122
123 %postun
124 %update_desktop_database_postun
125 %update_icon_cache hicolor
126
127 %files
128 %defattr(644,root,root,755)
129 %doc CHANGELOG.md README.md
130 %dir %{_sysconfdir}/xdg/foot
131 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/foot/foot.ini
132 %attr(755,root,root) %{_bindir}/foot
133 %attr(755,root,root) %{_bindir}/footclient
134 %{systemduserunitdir}/foot-server.service
135 %{systemduserunitdir}/foot-server.socket
136 %{_datadir}/foot
137 %{_desktopdir}/org.codeberg.dnkl.foot.desktop
138 %{_desktopdir}/org.codeberg.dnkl.foot-server.desktop
139 %{_desktopdir}/org.codeberg.dnkl.footclient.desktop
140 %{_iconsdir}/hicolor/*/apps/foot.png
141 %{_iconsdir}/hicolor/scalable/apps/foot.svg
142 %{_mandir}/man1/foot.1*
143 %{_mandir}/man1/footclient.1*
144 %{_mandir}/man5/foot.ini.5*
145 %{_mandir}/man7/foot-ctlseqs.7*
146
147 %files -n bash-completion-foot
148 %defattr(644,root,root,755)
149 %{bash_compdir}/foot
150 %{bash_compdir}/footclient
151
152 %files -n fish-completion-foot
153 %defattr(644,root,root,755)
154 %{fish_compdir}/foot.fish
155 %{fish_compdir}/footclient.fish
156
157 %files -n zsh-completion-foot
158 %defattr(644,root,root,755)
159 %{zsh_compdir}/_foot
160 %{zsh_compdir}/_footclient
This page took 0.193032 seconds and 3 git commands to generate.