]> git.pld-linux.org Git - packages/fluidsynth.git/blob - fluidsynth.spec
Version: 2.0.2 (soname change)
[packages/fluidsynth.git] / fluidsynth.spec
1 #
2 # Conditional build:
3 %bcond_without  lash            # LASH support (GPL)
4 %bcond_with     midishare       # MidiShare support
5 %bcond_without  portaudio       # portaudio support
6 %bcond_without  readline        # readline line editing (GPL)
7 #
8 Summary:        FluidSynth - a software, real-time synthesizer
9 Summary(pl.UTF-8):      FluidSynth - programowy syntezator działający w czasie rzeczywistym
10 Name:           fluidsynth
11 Version:        2.0.2
12 Release:        1
13 %if %{with ladcca} || %{with lash} || %{with readline}
14 License:        GPL v2+ (enforced by ladcca/lash/readline), LGPL v2+ (fluidsynth itself)
15 %else
16 License:        LGPL v2+
17 %endif
18 Group:          Applications/Sound
19 #Source0Download: https://github.com/FluidSynth/fluidsynth/releases
20 Source0:        https://github.com/FluidSynth/fluidsynth/archive/v%{version}/%{name}-%{version}.tar.gz
21 # Source0-md5:  fdc3c131786d5a93136f6fbfde787bf1
22 URL:            http://www.fluidsynth.org/
23 BuildRequires:  alsa-lib-devel >= 0.9.1
24 BuildRequires:  cmake >= 3.1.0
25 BuildRequires:  dbus-devel >= 1.0.0
26 BuildRequires:  gettext-tools
27 BuildRequires:  glib2-devel >= 1:2.6.5
28 BuildRequires:  jack-audio-connection-kit-devel
29 %{?with_ladcca:BuildRequires:   ladcca-devel < 0.4.0}
30 %{?with_ladcca:BuildRequires:   ladcca-devel >= 0.3.1}
31 BuildRequires:  ladspa-devel
32 %{?with_lash:BuildRequires:     lash-devel >= 0.3}
33 BuildRequires:  libgomp-devel
34 BuildRequires:  libsndfile-devel >= 1.0.18
35 %{?with_midishare:BuildRequires:        midishare-devel}
36 BuildRequires:  pkgconfig
37 %{?with_portaudio:BuildRequires:        portaudio-devel >= 19}
38 BuildRequires:  pulseaudio-devel >= 0.9.8
39 %{?with_readline:BuildRequires: readline-devel}
40 BuildRequires:  rpmbuild(macros) >= 1.213
41 Requires:       alsa-lib >= 0.9.1
42 Requires:       glib2 >= 1:2.6.5
43 Requires:       libsndfile >= 1.0.18
44 Suggests:       soundfont-fluid
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Fluid Synth is a software, real-time synthesizer based on the
49 Soundfont 2 specifications.
50
51 %description -l pl.UTF-8
52 Fluid Synth to programowy, działający w czasie rzeczywistym syntezator
53 oparty na specyfikacji Soundfont 2.
54
55 %package devel
56 Summary:        Development files for the FluidSynth
57 Summary(pl.UTF-8):      Pliki nagłówkowe dla FluidSynth
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       alsa-lib-devel >= 0.9.1
61 Requires:       dbus-devel >= 1.0.0
62 Requires:       glib2-devel >= 1:2.6.5
63 Requires:       jack-audio-connection-kit-devel
64 %{?with_lash:Requires:  lash-devel >= 0.3}
65 Requires:       libsndfile-devel >= 1.0.18
66 %{?with_midishare:Requires: midishare-devel}
67 Requires:       portaudio-devel >= 19
68 Requires:       pulseaudio-devel >= 0.9.8
69 %{?with_readline:Requires: readline-devel}
70
71 %description devel
72 This package contains the header files necessary to develop
73 applications using FluidSynth.
74
75 %description devel -l pl.UTF-8
76 Pakiet ten zawiera pliki nagłówkowe potrzebne do tworzenia i
77 kompilacji aplikacji korzystających z bibliotek FluidSynth.
78
79 %prep
80 %setup -q
81
82 %build
83 mkdir -p build
84 cd build
85 %cmake \
86         -Denable-midishare=%{with midishare} \
87         -Denable-lash=%{with lash} \
88         -Denable-portaudio=%{with portaudio} \
89         -Denable-readline=%{with readline} \
90         ..
91
92 # define missing in autotools suite
93 echo '#define DEFAULT_SOUNDFONT "%{_datadir}/soundfonts/default.sf2"' >> src/config.h
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 cd build
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS NEWS README.md THANKS TODO
113 %attr(755,root,root) %{_bindir}/fluidsynth
114 %attr(755,root,root) %{_libdir}/libfluidsynth.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libfluidsynth.so.2
116 %{_mandir}/man1/fluidsynth.1*
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libfluidsynth.so
121 %{_includedir}/fluidsynth.h
122 %{_includedir}/%{name}
123 %{_pkgconfigdir}/fluidsynth.pc
This page took 0.034807 seconds and 3 git commands to generate.