]> git.pld-linux.org Git - packages/firejail.git/blob - firejail.spec
cdaa61f6572924f2856041548e8f16649e777a3a
[packages/firejail.git] / firejail.spec
1 Summary:        A SUID sandbox program
2 Name:           firejail
3 Version:        0.9.40
4 Release:        1
5 License:        GPL v2+
6 Group:          Applications
7 Source0:        https://github.com/netblue30/firejail/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  d5a544de97d72cf14a27cd14aa6ba9dd
9 URL:            https://firejail.wordpress.com/
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Firejail is a SUID security sandbox program that reduces the risk of
14 security breaches by restricting the running environment of untrusted
15 applications using Linux namespaces and seccomp-bpf. It allows a
16 process and all its descendants to have their own private view of the
17 globally shared kernel resources, such as the network stack, process
18 table, and mount table.
19
20 %prep
21 %setup -qn %{name}-%{version}
22
23 # Fix libdir.
24 sed -i -e 's#/usr/lib#%{_libdir}#g' etc/disable-devel.inc
25
26 %build
27 %configure
28 %{__make}
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 %{__make} install \
33         DESTDIR=$RPM_BUILD_ROOT
34
35 chmod +x $RPM_BUILD_ROOT%{_libdir}/%{name}/*.so
36
37 # Install documentation ourselves.
38 rm -r $RPM_BUILD_ROOT%{_docdir}/%{name}
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(644,root,root,755)
45 %doc README README.md RELNOTES
46 %dir %{_sysconfdir}/%{name}
47 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.inc
48 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.net
49 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.profile
50 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.config
51 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/login.users
52 %attr(4755,root,root) %{_bindir}/firejail
53 %attr(755,root,root) %{_bindir}/firecfg
54 %attr(755,root,root) %{_bindir}/firemon
55 %{_mandir}/man1/firecfg.1*
56 %{_mandir}/man1/firejail.1*
57 %{_mandir}/man1/firemon.1*
58 %{_mandir}/man5/firejail-config.5*
59 %{_mandir}/man5/firejail-login.5*
60 %{_mandir}/man5/firejail-profile.5*
61 %dir %{_libdir}/%{name}
62 %attr(755,root,root) %{_libdir}/%{name}/fshaper.sh
63 %attr(755,root,root) %{_libdir}/%{name}/ftee
64 %attr(755,root,root) %{_libdir}/%{name}/libtrace.so
65 %attr(755,root,root) %{_libdir}/%{name}/libtracelog.so
66 %attr(755,root,root) %{_libdir}/%{name}/firecfg.config
67
68 # bash-completions
69 %{bash_compdir}/firejail
70 %{bash_compdir}/firemon
71 %{bash_compdir}/firecfg
This page took 0.111245 seconds and 3 git commands to generate.